ParanoidAndroid 3.00 for Sony Xperia Tipo schlägt fehl

  • 9 Antworten
  • Neuester Beitrag
Diskutiere ParanoidAndroid 3.00 for Sony Xperia Tipo schlägt fehl im Root / Custom-ROMs / Modding für Sony Xperia Tipo im Bereich Sony Xperia Tipo Forum.
sfaber83

sfaber83

Neues Mitglied
hallo,
wollte gestern dieses rom installieren aber es schlägt fehl.
das passiert aber auch bei jedem rom das ich ausprobieren möchte :-(

- Copy ROM to Sdcard or Internal
- Reboot to CWM
- Flash the ROM
- Wipe data/cache/dalvik
- Reboot
- Enjoy

so gehe ich ja auch vor aber sollte man nicht erst alle wipen und danach flash the rom machen?
ich habe es auf meiner externen sd karte.
jedenfalls wenn ich es so mache installiert es zwar aber glaube eine installation sieht bissl anders aus.
jedenfalls läuft ein balken durch und der sagt dann das es installiert ist und wenn ich dann reboot mache is das handy wieder tot und man kann wieder nur erst mit der flashtoolbox erstma den bootloader aufspielen und schon geht das spiel wieder von vorne los :-(

was mach ich denn falsch?
 
Zuletzt bearbeitet:
meetdaleet

meetdaleet

Ehrenmitglied
Hallo sfaber83,

dein Bootloader ist also offen ?
( Siehe auch: https://www.android-hilfe.de/forum/...2/anleitung-bootloader-entsperren.461085.html ) oder im Allgemeinen Sony Bereich -> Anleitungen -> BL öffnen mit dem Flashtool.

Wenn dem so ist, so würde ich (auf Grundlage neuerer Geräte... Ich kann also nicht nachvollziehen, ob das beim Tipo auch so ist!) wie folgt vorgehen:

1. boot.img aus der PA.zip herauskopieren
2. Rom auf das Gerät/extSD kopieren
3. Gerät via Fastboot anschließen und - A) mit dem Flashtool via Fastboot oder B) mit der Fastboot.exe - den Kernel (boot.img) flashen.
4. In die PA Recovery booten
5. Factory Reset
6. Install zip -> Rom installieren
6.1 (optional) Install zip -> GApps installieren
7. Wipe Cache / Advanced -> Wipe Dalvik Caches
8. Reboot to system

Wie gesagt, ich habe kein Tipo und kann insofern nicht einschätzen, ob es bei deinem Gerät "mehr" zu beachten gilt.

Gruß
meet
 
sfaber83

sfaber83

Neues Mitglied
hi,
also ich hab das stockrom einfach mit kingoroot bearbeitet und somit ist ja alles offen wenn ich recht weis.
dann cwm recovery installiert.

1. boot.img aus der PA.zip herauskopieren
2. Rom auf das Gerät/extSD kopieren

dann ist die zip ja keine zip mehr.
oder die zip so belassen wie sie ist (beinhaltet natürlich das boot.image)
und das dann 6. Install zip -> Rom installieren nachdem ich das
3. Gerät via Fastboot anschließen und - A) mit dem Flashtool via Fastboot oder B) mit der Fastboot.exe - den Kernel (boot.img) flashen gemacht habe?
 
Zuletzt bearbeitet:
meetdaleet

meetdaleet

Ehrenmitglied
Das besagte Root-Tool öffnet den Bootloader (meines Wissens nach) nicht!

Du musst also (und dafür ist Root auch nicht notwendig) den Bootloader zuvor öffnen.

Ob er geöffnet ist findest du wie folgt heraus:

*#*#7378423#*#* (SERVICE) anrufen.
Hier dann "Service Info -> Configuration". Hier muss stehen:
"Bootloader unlocked: yes".

Sollte dort stehen "Bootloader unlock allowed: yes", so ist der Bootloader noch geschlossen, kann jedoch geöffnet werden. Ebenso kann dort "Bootloader unlock allowed: no" ersichtlich sein, was bedeuten würde, der BL ist zu und kann auch nicht geöffnet werden. (Hiervon gehe ich jedoch nicht aus)

Ich lege dir jedoch folgendes noch ans Herz, bevor du den BL öffnest:

Sofern du auf der Stock Rom Root hast, sichere die (falls beim Tipo vorhanden?!) die Trimm Area (Anleitung findest du in meiner Signatur/Sammlung in der Signatur). Ohne dieses Backup kriegst du später dein Device nicht mehr "vollends" auf den Originalzustand zurück (Stichwort: Garantie).

Gruß
meet
 
sfaber83

sfaber83

Neues Mitglied
hi meetdaleet,
da steht "Bootloader unlock allowed: yes"
muss aber allerdings auch nichts speichern denn ich bekomme montag en neues handy weil das schon so alt ist.
bedeutet ich kann jetzt grad so alles "zerstören" :)
 
meetdaleet

meetdaleet

Ehrenmitglied
Dann solltest du als ersten Schritt (wie empfohlen) dies hier umsetzen:

https://www.android-hilfe.de/forum/...ung-bootloader-oeffnen-schliessen.588557.html

Ich vermute, dass deine Bootloops/Unfunktionalität von einem geschlossenen Bootloader kommt, da die meisten AOSP/AOKP basierten Roms einen offenen Bootloader voraussetzen.
Es gibt selbstredend ausnahmen, wenn ein Contributor, dass so umsetzt.
Aus welcher Quelle stammt die Rom denn genau? (Threadlink o.Ä.)

Gruß
meet
 
sfaber83

sfaber83

Neues Mitglied
das romt stammt von hier:

[ROM][4.1.2][Tipo/J][Paranoid Android 3.0][U… | Sony Xperia Miro, Tipo (Dual), J, E | XDA Forums

habe es nun offen.
zumindest steht das im flasher.
wenn ich aber ims servicemenü gehe ist es nicht offen :-(

bleibt das dann eigentlich immer offen?
wie nun vorgehen mit dem neuen image das ich habe?

und wenn ich select kernel to hotboot nehme und dann dieses besagte image auswähle kommt eine fehlermeldung das ich es doch bitte zuerst rooten soll :-(

das handy kotzt mich einfach nur an!

wie ändert man den code eigentlich?
wenn ich ins unlock menü komme und da den code nochmal neu schreiben möchte geht das nichmehr.


ist denn niemand aus dem main-spessart hier ?^^

ich lass das jetzt.das leben is zu kurz für sowas :-(
 
Zuletzt bearbeitet:
meetdaleet

meetdaleet

Ehrenmitglied
Naja ich hab dir doch oben ne Variante genannt, die eigentlich beim Tipo auch gehen sollte.

Sprich Unlock mit dem Flashtool und dann mit dem Flashtool via Fastboot die img flashen.
Recovery, Factory Reset, ROM installieren, GApps (falls gewünscht) installieren, wipe cache und dalvik cache.
Reboot to system -> fertig.

Die ULBL Anleitung verwenden :
https://www.android-hilfe.de/forum/...ung-bootloader-oeffnen-schliessen.588557.html
Und hier nochmal die Anleitung zum flashen:
https://www.android-hilfe.de/forum/...m-flashtool-kernel-und-custom-rom.588559.html

Gruß
Meetdaleet
 
sfaber83

sfaber83

Neues Mitglied
hi meetdaleet,
ich lass es jetzt besser erstmal.muss mich beruhigen.
das handy kost mic zuviel nerven.
es will eben einfach nicht :-(
trotzdem vielen dank

ps.kommando zurück,habs über die konsole gemacht und nun steht im service menü:bootloader unlock:yes
es kann also weiter gehn^^

hab da samprix.com entdeckt und glaub das macht es einigen leichter was das erklären angeht :)
 
Zuletzt bearbeitet:
sfaber83

sfaber83

Neues Mitglied
hab dieses rom installiert.
und auch mal ein anderes.
nun ist mein problem das keines dieser systeme meine d1 karte annimmt?
kann das sein?
wo liegt denn der fehler?
es verlangt von mir das ich eine karte einlegen soll
 
Zuletzt bearbeitet: