Fragen/Probleme zu offiziellen Sony Updates bei gerooteten Geräten, manuelles Flashen

  • 163 Antworten
  • Neuster Beitrag
Ö

Östrogen

Neues Mitglied
taigatiger schrieb:
Hallo,
ich bin neuer Besitzer eines XZ und möchte es gern rooten, aber das klappt mit der DooMLoRD-Methode bei der aktuellsten FW 10.3.1.A.2.67 offenbar nicht.
Richtig
taigatiger schrieb:
Nach dem Flashen des Kernels der alten FW 10.3.A.0.423 - wie dort als WorkArround vorgeschlagen - geht erst einmal WLan nicht mehr, was nicht so tragisch wäre, aber der Rootprozeß mi der DooMLoRD-Batch-Datei runme-win.bat wird mit Fehler abgeschlossen, weil gemeldet wird, daß die Version ...2.67 nicht unterstützt wird.
Das ist auch richtig.
M.M. hast du einen Fehler beim Flashen gemacht (Treiber installiert?)
taigatiger schrieb:
Geflasht wurde nur der Kernel, so dass die Versionsnummer nicht geändert wurde.
Glaube nicht das der Kernel geflasht wurde.
taigatiger schrieb:
Sony PCCompanion macht dann anstandslos ein Update auf die aktuelle Version und tauscht dazu offenbar nur den Kernel aus, weil es nur wenige Minuten dauert. Danach funktioniert wieder alles wie vorher.
Wer weiß was und kann dazu was sagen? Warum klappt das Routing nicht? Ich habe selbstverständlich "USB-Debugging" und "externe Quellen" freigeschaltet.
Ich möchte gern Root haben wegen Titanium und rSAP.
Schau nach der Verbindung mit dem Z.
Nur eine Sitzung laufen lassen.
PCCompanion u. ä. deaktiveren.
NUR FLASHTOOL
taigatiger schrieb:
 
taigatiger

taigatiger

Neues Mitglied
Hallo Östrogen, vielen Dank für deine Antwort. Es hat jetzt geklappt. Mein Fehler war die Verwendung eines veralteten DooMLoRD-Tools. Anschließend den .67-Kernel geflascht. Root ist da.
Gruß
taigatiger
 
M

Maxprivat

Neues Mitglied
Jetzt habe ich es geschafft. Ständiger reboot! Hab nicht zum ersten mal geflasht, aber genau das war mein Problem. Zu sicher gefühlt und falschen Kernel genommen und jetzt komme ich nicht mehr aus dem Bootloop heraus. Habe zuerst:

1. Update über PC durchgeführt - problemlos
2. wollte Kernel 423 flashen (für darauffolgend root mit doomlord)

Habe aber leider den vorhandenen Kernel genommen, der beim flashtool dabei war.
Ergebniss - XZ lies sich zuerst gar nicht mehr starten - nur rote led leuchtete. Hardreset brachte zwar wieder leben ins Spiel, aber ich wenn ich einen anderen Kernel flashe (was funktioniert) bin ich wieder im Bootloop!

Hat wer eine Lösung?
 
Dacool

Dacool

Experte
Reparatur mit Emma oder SUS schon versucht? Hat bei mir damals auch geholfen
 
M

Maxprivat

Neues Mitglied
Hmm, Emma geht nicht da jetzt gelockt.
Wenn ich nach SUS suche bekomme ich nur die Sony PC Companion Software.
Und da gibts leider keinen Reparatur-Option.
Oder meinst Du ein anderes SUS? :blushing:
 
M

Maxprivat

Neues Mitglied
Danke! :blushing:
Nachster Versuch ... sch...

Zitat: "Für Ihr Telefon ist keine neue Software verfügbar. Auf Ihrem Telefon ist bereit die neueste Software installiert."

und nur mehr der Button zum beenden, sonst nix.
 
Zuletzt bearbeitet:
evasion

evasion

Lexikon
Dann wirste wohl noch mal flashen müssen !
 
M

Maxprivat

Neues Mitglied
hmmm, neu geflasht - ok, handy geht wieder an - hurra
alten kernel geflasht - (den ich ja beim erstenmal rooten auch funktionierte) - B O O T L O O P :scared:!!!
HILFE!
EMMA geht nicht - da ja jetzt gelockt.
Zumindest läuft jetzt mal das update ... wieder warten ...
kann der virenscanner (avast) schuld sein beim flashen? werd ihn beim nächstenmal deaktivieren.
 
evasion

evasion

Lexikon
Avast kann schon stören !
Solten da nicht zum wipen irgendwo Hacken rein, beim Flashtool ? Weis nicht genau, nutze mal die Suche !
 
F

FrankFurious

Ambitioniertes Mitglied
Seadart schrieb:
OT: Zum Glück habe ich das Drama mit den Updates nicht mehr :D

Nexus 5 mit 4.4.2 :thumbsup:
Pff :D

Wenn man das 4.3 update einspielt, verliert man root rechte oder?
 
B

BadFlexx

Fortgeschrittenes Mitglied
natürlich
 
M

mmm4

Ambitioniertes Mitglied
Hallo,
Habe gerade probiert wieder ein OTA einzuspielen. Leider ohne Erfolg.
>Gibt's wo einen Log in dem ich sehe, bei welchem Part das OTA abgebrochen wurde?
>Hat jemand für mich den Inhalt von /system/fonts/? Ich vermute dass der Hund hier begraben liegt. (10.31.A.2.67)
Gruß und Danke
Andreas
 
thoco2012

thoco2012

Ambitioniertes Mitglied
Seit einigen Wochen wird mir dauernd das aktuelle Update auf 10.4.1.B.0.101 angezeigt. Derzeit habe ich 10.4.B.0.569 mit Root und geschlossenem BL.

Erste Frage: Macht das Update Sinn?
Zweite Frage: Bleibt mein Root erhalten? Mit welcher Update Methode?

... Dritte Frage, wenn auf die ersten beiden Frage ein Nein als Antwort folgt: Wie bekomme ich den Hinweis auf das Update weg?

Gruß T
 
B

bwammi

Neues Mitglied
Hallo zusammen,
vorhin habe ich manuell auf 4.3 upgedatet. Seitdem ist mein Xperia extrem langsam. Des Weiteren ist (bei gleichen Apps) viel weniger Arbeitsspeicher verfügbar. Ist das Problem bekannt und gibt es Abhilfe? Falls nicht, besteht die Möglichkeit problemlos wieder auf 4.1.2 zu wechseln?
Wre super wenn ihr mir helfen könnt.
 
M

mh090366

Ambitioniertes Mitglied
Steht doch oben drüber. Einfach mal lesen und auf den Link klicken.
 
J

j.red

Fortgeschrittenes Mitglied
Hallo,
wie funktioniert eigentlich die Reihenfolge der Updates? Muss man alle Updates nacheinander vollziehen?
Folgender Fall:
Bin noch 4.2.2 (10.3.1.A.2.67)- User. Aus einem einfachem Grund: 4.2.2 war die letzte Version, die noch relativ einfach zu rooten war (1-click-Methode). Ausserdem läuft die absolut stabil. Nachdem dann klar war, das die Folgeversionen nicht mehr so einfach zu rooten sind, habe ich die Update-App auf dem Handy deaktiviert um die ständigen nervigen Update-Erinnerungen zu umgehen.

Nun ist es ja so, das die neueste Versionen (4.4.2 bzw. 14.3.A.0.681) anscheinend wieder einfacher zu rooten ist. Deshalb hab ich die Update-App wieder aktiviert. Jetzt bietet mir die App aktuell ein Update auf 10.4.B.0.569 an. Das ist doch nicht das aktuellste? Muss ich jetzt alle Versionen installieren und dann immer wieder aktualisieren, bis ich bei der aktuellsten Version angekommen bin? Oder liegt es an der Update-Art (in diesem Fall also OTA)?
 
Dacool

Dacool

Experte
Es kann einfach daran liegen, dass deine Custom-Nr noch nicht an der Reihe ist mit dem aktuellsten Update. Außerdem bist du ziemlich schlecht informiert, es lassen sich zurzeit ALLE Android Versionen mit einer App rooten, einfacher gehts echt gar nicht mehr (Stichwort towelroot).
Am einfachsten du suchst dir die neueste .ftf für dein Handy heraus, und flasht sie mit dem Flashtool, fertig.
 
M

mh090366

Ambitioniertes Mitglied
OTA sollte bei Root garnicht gehen.
 
Oben Unten