[ROOT] Xperia Z für LB und UB nur für die 253 und 244

  • 439 Antworten
  • Neuester Beitrag
Diskutiere [ROOT] Xperia Z für LB und UB nur für die 253 und 244 im Root / Custom-ROMs / Modding für Sony Xperia Z im Bereich Sony Xperia Z Forum.
der_henk

der_henk

Experte
Nee, habe's mit der 24er gemacht, die 25er bietet laut Changelog ja in der Richtung keinerlei Neuerungen.
Aber ich versuch's dann jetzt trotzdem damit nochmal.

Edit: So nochmal mit der 25er gerootet + Ordner gelöscht und nun scheint es wirklich zu gehn.
 
Zuletzt bearbeitet:
Rebellsche

Rebellsche

Ambitioniertes Mitglied
Da ich mich (noch) nicht bedanken kann/darf, möchte ich das hiermit auf diesem Wege tun :thumbsup:

Die folgende Methode hat sehr schnell und einfach funktioniert.

VIELEN DANK!

root mit bin4rys methode

root pack laden entweder aus dem anhang (im anhang ist die geänderte von mir) oder
hier:
http://uploaded.net/file/aa18qpkh <= original von bin4ry
und entpacken.


runme.bat starten und 3 wählen



jetzt handy anschliessen und enter drücken.



auf dem handy hat sich jetzt das geöffnet



jetzt 'meine daten wiederherstellen' drücken
und schon gehts wieder weiter



jetzt öffnet sich wieder ein fenster aufm handy,
dort drück das im screen rot markierte



das nächste fenster geht auf,
dort auch wieder das im screen rot markierte



ist das auch getan, wird der display weiß,
davon hab ich kein screen gemacht und
ihr müsst etwas warten





fertig



Der ursprüngliche Beitrag von 12:47 Uhr wurde um 12:53 Uhr ergänzt:

Und auch hierfür ein herzliches DANKE!
Filo schrieb:
Hallo....
hab mein Problem selbst gelöst - nach einiger Recherche.
Das NFC ließ sich nicht wieder einschalten nach dem Rootvorgang. Beim Booten ist es zwar angeschaltet und erkennt auch Tags, aber nach dem Umschalten geht es nicht mehr einzuschalten.

Ein Fix sieht wie folgt aus:
Mit einem Root-Explorer den Ordner "data/usf" löschen oder umbenennen, Reboot, fertig.

Nun bin ich zufrieden mit dem Root :)

Grüße,
Martin!
 
Gleggl

Gleggl

Fortgeschrittenes Mitglied
Hallo, ich habe dasselbe Problem , dass KingChaos hatte :(
Ich weiß einfach nicht mehr weiter..
Kann mir jemand helfen?
Bitte :(
 
Filo

Filo

Erfahrenes Mitglied
@Gleggl:

Wenn es bei dem weißen Bildschirm bleibt, dann teste mal:

a) Beim Tippen auf den Bildschirm wechselt die Farbe, bei "zurück" bist Du wieder im Menu
-> Rootvorgang fehlgeschlagen. Fenster in Windows schließen, erneut von vorne probieren

b) Rootvorgang schlägt auch beim nächsten Mal fehl
-> Handy "Auf Werkseinstellungen zurücksetzen" und als ALLERERSTES rooten - dann sollte es klappen.

Ich hab mein XZ mittlerweile ca. 10x gerootet, weil ich am Anfang mit dem NFC-Bug gekämpft hab. Daher weiß ich, dass die Root-Methode nur zu ca. 25% klappt. Aber zu 90 - 100 % klappt es nach einem Werksreset (SD-Karte musst Du dabei NICHT löschen).

Versuch's mal.

Grüße,
Martin!
 
Gleggl

Gleggl

Fortgeschrittenes Mitglied
ich hänge jetzt (nach der Zurücksetzung) hier: rm: descend into directory '/data/usf'?

Jetzt gehts, habe root!!
Danke 1000mal!!

 
Zuletzt bearbeitet:
Filo

Filo

Erfahrenes Mitglied
Hm... gute Frage, den Punkt kenne ich nicht, war vielleicht bei der von mir verwendeten Methode noch nicht da...

Wie auch immer, die Wahl an dieser Stelle ist eigentlich egal - im Zweifelsfall bejahen. Einen möglichen NFC-Bug bekommt man hinterher auch weg.

Grüße,
Martin!
 
Gleggl

Gleggl

Fortgeschrittenes Mitglied
ich konnte dar gar nichts drücken ?? egal, bin dan zum Xperia gewechstelt, RootChecker und BusyBox geladen, und jetzt läuft alles perfekt :)
Danke nochmal!!!
 
Filo

Filo

Erfahrenes Mitglied
Ja subbi :) Schau doch mal, ob NFC auch funzt, bitte.

Grüße,
Martin!
 
Gleggl

Gleggl

Fortgeschrittenes Mitglied
Ich verwende NFC nie ;)

SKRILLEX, what else?!
 
Filo

Filo

Erfahrenes Mitglied
Nur mal zum Test mehrmals an- und ausschalten bitte ;-)
 
Gleggl

Gleggl

Fortgeschrittenes Mitglied
okay, was muss passieren? :)

Der ursprüngliche Beitrag von 18:46 Uhr wurde um 18:48 Uhr ergänzt:


So siehts dan aus ;)
SKRILLEX, what else?!
 
Filo

Filo

Erfahrenes Mitglied
Der Bug wäre, dass Du NFC (nach dem Ausschalten) wieder anschaltest und der Haken von selbst wieder ausgeht, also NFC nicht startet... Ich wollte nur mal wissen, ob das bei Deinem Gerät auch der Fall war, sieht aber gut aus :)
Danke!
 
Gleggl

Gleggl

Fortgeschrittenes Mitglied
Kein Problem :)

SKRILLEX, what else?!
 
Darkpower

Darkpower

Erfahrenes Mitglied
Nfc geht nicht lässt sich nicht an schalten

Gesendet von meinem C6603 mit Tapatalk 2
 
Filo

Filo

Erfahrenes Mitglied
@Darkpower: Den Fehler kannst Du selbst beheben. Benenne den Ordner data\usf (im Telefonspeicher) einfach um in z.B. data\_ehemals_usf (so geht er nicht verloren wie beim Löschen). Dann klappt's auch mit NFC. *edit*: Neustart nicht vergessen!

@Gleggl: NFC ist für mich im Auto und auf der Arbeit recht angenehm. Klar... soweit, dass man überall damit bezahlen könnte, ist die Welt noch nicht, aber nett find ich's schon, kann aber verstehen, dass man ohne eine Nahfeldkommunikation leben kann :)

Grüße,
Martin!
 
D

Darth1996Vader

Erfahrenes Mitglied
@Filo:
Kannst du mal bitte den genauen Pfad nennen.Also vollständig.
Z.b. System/abc/123/hjg/ggdgaj.fd

Wäre nett.
Oder mal biite ein screenshot machen.

Der ursprüngliche Beitrag von 23:02 Uhr wurde um 23:03 Uhr ergänzt:

Und kann man den ordner auch löschen?
 
Filo

Filo

Erfahrenes Mitglied
Das ist der Pfad... Du kommst vom Telefonspeicher (noch oberhalb von /sdcard).
Data\usf
Ob man ihn später mal braucht, weiß ich nicht. Bei mir Hat er 2,6GB... Ich konnte nirgendwo herausfinden, wofür der Ordner ist, deswegen hab ich ihn vorsichtshalber nur umbenannt.

Grüße,
Martin
 

Anhänge

Rebellsche

Rebellsche

Ambitioniertes Mitglied
Mir ist grad aufgefallen das nach dem Root bootloader unlock allowed auf no steht... Vorher yes



Gesendet von meinem C6603 mit der Android-Hilfe.de App
 

Anhänge

der_henk

der_henk

Experte
Hatte ich auch schon festgestellt und vor Schreck gleich mal das Telefon komplett neugeflasht... Das ist aber normal. Wenn man das Gerät wieder zurücksetzt oder neuflasht wird auch der Bootloaderstatus wieder "korrigiert".

Btw. mit der v25 + 434er Firmware wird bei mir der Bootloaderstatus richtig angezeigt.
 
Rebellsche

Rebellsche

Ambitioniertes Mitglied
ok... danke. beruhigt ein bisschen:thumbup:
 
Zuletzt bearbeitet von einem Moderator: