Breeze"D" macht kein Spass

  • 8 Antworten
  • Neuester Beitrag
Diskutiere Breeze"D" macht kein Spass im Root / Custom-ROMs / Modding für Surftab Breeze 7.0 im Bereich Surftab Breeze 7.0 Forum.
B

baer.elektro

Neues Mitglied
weil ich eine D Version habe und "nur" original ROM damit läuft, bin ich traurig. Es ist zwar die CWM von TheSSJ drauf. Aber ohne vernünftigen ROM mit neusten Android ist es nur ein Gebrauchsgerät und kein Spielzeug für Männer.
Wie bringe ich dem Breeze"D" 4.2.2 bei?

Eigentlich musste nur der TS Treiber für 4.2.2 und in diesen ROM eingepflegt werden und schon hätten wir den neusten Android und ein gutes Motorradspiel als Bonus mit dazu. Doch mir fehlen die Kenntnisse.
Wenn ich den ROM installiere wird der A13_gslX680 erkannt. Aber TS macht nichts.
Wo soll ich anfangen.
Linux "Mint" habe ich installiert, SDK auch. ADB läuft. Und nun?

lsmod
8188eu 767523 0 - Live 0x00000000
dmard06 11388 0 - Live 0x00000000
mc32x0 13474 0 - Live 0x00000000
device 26958 0 - Live 0x00000000
rtl8150 10305 0 - Live 0x00000000
mcs7830 7581 0 - Live 0x00000000
qf9700 9152 0 - Live 0x00000000
asix 24601 0 - Live 0x00000000
camera 53105 0 - Live 0x00000000
videobuf_dma_contig 6243 0 - Live 0x00000000
videobuf_core 20242 1 videobuf_dma_contig, Live 0x00000000
cedarx 11869 0 - Live 0x00000000
mali 199639 67 - Live 0x00000000
ump 34033 13 mali, Live 0x00000000
A13_gslX680 61266 0 - Live 0x00000000
nand 224992 8 - Live 0x00000000

ChinesenROM partitioniert den Breeze"D" komplett anders also müste ich die CWM auch neu anpassen.

cat /proc/partitions

93 0 16384 nanda
93 8 16384 nandb
93 16 32768 nandc
93 24 524288 nandd
93 32 524288 nande
93 40 16384 nandf
93 48 32768 nandg
93 56 327680 nandh
93 64 262144 nandi
93 72 1966080 nandj

mount

rootfs / rootfs rw 0 0
tmpfs /dev tmpfs rw,nosuid,relatime,mode=755 0 0
devpts /dev/pts devpts rw,relatime,mode=600,ptmxmode=000 0 0
proc /proc proc rw,relatime 0 0
sysfs /sys sysfs rw,relatime 0 0
none /acct cgroup rw,relatime,cpuacct 0 0
tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0
tmpfs /mnt/obb tmpfs rw,relatime,mode=755,gid=1000 0 0
/dev/block/nandd /system ext4 rw,nodev,noatime,user_xattr,barrier=0,data=ordered 0 0
/dev/block/nande /data ext4 rw,nosuid,nodev,noatime,user_xattr,barrier=0,journal_checksum,data=ordered,noauto_da_alloc 0 0
/dev/block/nandh /cache ext4 rw,nosuid,nodev,noatime,user_xattr,barrier=0,journal_checksum,data=ordered,noauto_da_alloc 0 0
/dev/block/vold/93:72 /mnt/sdcard vfat rw,dirsync,nosuid,nodev,noexec,relatime,uid=1000,gid=1015,fmask=0702,dmask=0702,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
/dev/block/vold/93:72 /mnt/secure/asec vfat rw,dirsync,nosuid,nodev,noexec,relatime,uid=1000,gid=1015,fmask=0702,dmask=0702,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0tmpfs /mnt/sdcard/.android_secure tmpfs ro,relatime,size=0k,mode=000 0 0
 
Zuletzt bearbeitet:
B

baer.elektro

Neues Mitglied
Was mir noch aufgefallen ist - in der ChinaROM steht nur

[ctp_para]
ctp_used = 1
ctp_name = "gslX680"
ctp_twi_id = 1
ctp_twi_addr = 0x40
ctp_screen_max_x = 800
ctp_screen_max_y = 480
ctp_revert_x_flag = 0
ctp_revert_y_flag = 1
ctp_exchange_x_y_flag = 1
ctp_int_port = port:pG11<6><default><default><default>
ctp_wakeup = port:pB03<1><default><default><1>
ctp_reset = port:pB03<1><default><default><1>
ctp_io_port = port:pG11<6><default><default><default>

in der script.bin und im Original steht

[ctp_para]
ctp_used = 1
ctp_name = "sitronix_ts"
ctp_twi_id = 1
ctp_twi_addr = 0x60
ctp_screen_max_x = 800
ctp_screen_max_y = 480
ctp_revert_x_flag = 1
ctp_revert_y_flag = 0
ctp_exchange_x_y_flag = 0
ctp_int_port = port:pG11<6><default><default><default>
ctp_wakeup = port:pB03<1><default><default><1>
ctp_io_port = port:pG11<0><default><default><default>

[ctp_para1]
ctp_used = 1
ctp_name = "gslX680"
ctp_twi_id = 1
ctp_twi_addr = 0x40
ctp_screen_max_x = 800
ctp_screen_max_y = 480
ctp_revert_x_flag = 0
ctp_revert_y_flag = 1
ctp_exchange_x_y_flag = 0
ctp_int_port = port:pG11<6><default><default><default>
ctp_wakeup = port:pB03<1><default><default><1>
ctp_io_port = port:pG11<0><default><default><default>

kann das der Grund für nicht funktionierendes TS sein?

Der ursprüngliche Beitrag von 20:13 Uhr wurde um 21:16 Uhr ergänzt:

Habe jetzt die script.bin und script0.bin wie im Original geändert und Reset gemacht.
TS funzt noch nicht. Dmesg sagt:

4>[ 3.739687] ==gsl_ts_init==
<4>[ 3.739706] ctp_fetch_sysconfig_para.
<3>[ 3.739729] ctp_fetch_sysconfig_para: name sitronix_ts does not match CTP_NAME.
<3>[ 3.739738] gslX680gsl_ts_init: err.
<6>[ 3.739981] init: command 'insmod' r=-1
<6>[ 3.762732] hello, sun4i_vibrator init
<3>[ 3.762763] sun4i_vibrator_init: motor_unused.
<6>[ 3.762770] =========script_parser_fetch_err============
 
TheSSJ

TheSSJ

Stammgast
Hi, ich kann dir jetzt nur einen Tipp geben, da ich selbst das Tab nicht besitze...
Schau mal bei den images von den odys tablets nach, dass xelio pro oder so könnte vielleicht den selben ts haben..sag doch bescheid ob du was gefunden hast..

Gruß

/EDIT: http://forum.xda-developers.com/showthread.php?t=2189569

Könnte gehen?
 
Zuletzt bearbeitet:
B

baer.elektro

Neues Mitglied
FaaastJB-v2.5.img mit Android 4.2.2. läuft auch ohne TS.
 
TheSSJ

TheSSJ

Stammgast
ich habe mehr darauf abgezielt, dass du mal alle TS driver zips durchflashst, vielleicht geht einer von denen ?
 
B

baer.elektro

Neues Mitglied
Die Treiber habe ich erfolglos ausprobiert. Der Breezed landet in der Schublade, wo alle meine "nicht mehr macht Spaß Sachen" landen. Ohne TS treiber ist das Ding nutzloss. Weg damit.
 
TheSSJ

TheSSJ

Stammgast
Hallo nochmal...
Wärst du bereit für noch einen Test? Flashe doch mal die stock rom bei der der Touchscreen geht, aber beim WLAN abstürzt. Danach gehe ins CWM und mache ein Backup der boot Partition. Danach flashe eine Android Version deiner Wahl und spiel mal dann NUR das boot Backup wieder zurück..mich würde interessieren ob soweit das ROM wenigstens hochfährt und wenn ja, ob der Rest funktioniert..wenn möglich kein cyanogenmod basiertes ROM
 
B

baer.elektro

Neues Mitglied
TheSSJ schrieb:
Flashe doch mal die stock rom bei der der Touchscreen geht
Wie meinst du? Gibt es solch einen ROM mit Android >= 4.2? Alle Roms die ich ausprobiert habe, musste ich mit einer Maus bedienen. Alles andere incl. WLAN hat funktioniert.
 
B

baer.elektro

Neues Mitglied
Ich habe nur einen ROM (Android 4.1.1) gefunden wo unser ilead GSL 1680 lebt.

nuclear_evb-eng 4.1.1 jro03c 20130416 test-keys


Da ist aber TS um 2 cm nach Rechts verschoben, Spiegelverhalten war auch da, aber lässt sich im script0 abstellen.
 
Zuletzt bearbeitet: