Mitglieder surfen ohne Werbung: Jetzt kostenlos registrieren!

[HowTo] Root/Modding/Debloating für das U8600-1

  • 249 Antworten
  • Neuester Beitrag
Diskutiere [HowTo] Root/Modding/Debloating für das U8600-1 im Root / Custom-ROMs / Modding für Telekom Move im Bereich Telekom Move Forum.
Status
Für weitere Antworten geschlossen.
T

trintyjck

Ambitioniertes Mitglied
Ab sofort findet ihr fürs Rooten das neue Thema hier: https://www.android-hilfe.de/forum/...telekom-move.631/howto-root-u8600.367511.html


Hinzugefügt von MorphX
--------------------------------------------------------------------







Hallo allerseits,
nachdem Segler11 (besten Dank!) gestern ein Script geschrieben hat, mit man das U8600-1 rooten kann, gehts jetzt weiter im Text :)

Root-Anleitung (von Segler11 & mir):

1. adb & fastboot Treiber müssen installiert sein (Drivers.zip im Anhang sollte beides beinhalten)
2. adb Debugging zulassen (Einstellungen->Anwendungen->Entwicklung)
3. angehängtes Archiv "root-U8600.zip" herunter laden und entpacken
4. Telefon mit dem Rechner verbinden
5. root.bat ausführen und den Anweisungen auf dem Bildschirm folgen.
6. Nachdem das Telefon neugestartet hat in den Anwendungen "Root Check Basic" suchen und ausführen -> "Verify Root Access" und wenn die SuperUser-Anfrage kommt "Erlauben"

Für die nächsten Schritte wird der Root-Explorer benötigt.

Alle Änderungen am Gerät auf eigene Gefahr !!!

1) Was kann alles gelöscht werden:


Der gesamte Inhalt des /system/cust/ Ordners
Dadurch wird man die ganzen unnützen Telekom-Programme los :D

Im /system/app/ Ordner:
sparkunlock.apk -> Das ist der T-Com Lock-Screen. Wenn die Datei gelöscht wird gibts wieder den Standard-Android-Lockscreen

Achtung: Folgendes nur unter Vorbehalt. Die Stock-Tastatur hat im Auslieferungszustand kein deutsches Wörtbuch.
BulgarianPack.apk; CroatianPack.apk; CzechPack.apk; DutchPack.apk; GermanPack.apk; GreekPack.apk; MacedonianPack.apk; PolishPack.apk; RomaniaPack.apk; SlovakPack.apk; TouchPal_HUAWEI.apk

-> Das sind die Dateien der (m.E.) grottenschlechten Huawei-Tastatur.
Im System ist auch noch das Stock-Keyboard vorhanden, dass sich wesentlich besser bedienen lässt.

Im /dataapp/ Ordner:

DocumentToGo.apk -> Standard-Office Programm. Gibt im Play-Store leistungsfähigere kostenlose Alternativen.

2) Wer die T-Com Animationen loswerden möchte kann unter /system/media/ die beiden Dateien:
bootanimation.zip & shutdownanimation.zip
löschen. Im Anhang ist eine einfache Bootanimation, die stattdessen in /system/media/ kopiert werden kann.

3) Der Huawei-Launcher kann durch den Stock-Launcher ersetzt werden, indem man die Launcher2.apk aus dem Anhang in /system/app/ kopieren und ANSCHLIEßEND HuaweiLauncher2.apk löscht.

4) Link2SD - Oder wie bekomme ich mehr Platz für Programme

Achtung, der SD-Karten Inhalt geht dabei verloren. Vorher unbedingt und Backup machen!

Das Telefon muss wieder ins CWM-Recovery gebootet werden. Dazu gibts mehrere Möglichkeiten, ich erkläre hier nur eine:
Die Root-Anleitung bis Schritt 5 durchgehen.
Sobald das Telefon im CWM-Recovery ist und der PC auf "eine beliebige Taste" wartet, wird das Skript am PC mit Strg+C und J abgebrochen.

Danach am Telefon 20x Volume-Up drücken (bis unten "Back menu button enabled" steht).

Mit den Volume-Tasten "Advanced" auswählen und mit dem Power-Button bestätigen. Nun wählen wir "Partition SD Card" aus und bestätigen wieder, danach steht ganz oben "Ext Size", dort nehmen "1024MB" (das ist die Größe der zukünftigen App-Partition), bei Swap Size brauchen wir nur "0M".
--> Warten (dauert bei mir gefühlte ~5 Minuten)
--> Go Back --> Reboot

"Link2SD" aus dem Market/Play-Store installieren (ist kostenlos).
Beim ersten Start erbittet Link2SD Root-Rechte.
Dann muss die zweite Partition gemountet werden. In der Liste ist "ext2" bereits angewählt. Mit "ok" bestätigen und Telefon neustarten.
Link2SD aufrufen, Menütaste betätigen -> Einstellungen -> "Automatisches Verschieben" aktivieren, bei "Installationsort" muss "interner Speicher" gewählt werden.
Von jetzt an werden alle neu installierten Anwendungen auf der zweiten Partition der SD-Karte installiert. Der nutzbare Speicher der SD-Karte verringert sich dadurch um 1GB, aber das ist zu verschmerzen. Allerdings gehen die Programme "verloren", sofern die SD-Karte ersetzt wird.
Weitergehende Infos gibts hier.

----------------------------------------------------------------------
To-Do Liste:
-Multitouch einpflegen
-Die rosa Animationen/Highlights/Symbole loswerden
-Die Cust-Partition loswerden, weil das Telefon sonst nach dem Wipen immer den T-Com Müll wiederherstellen möchte, was aber natürlich nicht geht...
Man kann einfach den Ordner /cust/t-mobile/ löschen, dann wird das Telefon nachdem wipen mehr oder weniger als Stock-Android wiederhergestellt. Bis auf die rosa Menüs :D Leider geht dabei auch das Notification-Bar-Toggle-Widget verloren. Dieses basiert auf der toolbox.apk, welche ebenfalls ins /system/app/ liegt. Die Toolbox enthält das Energie-Widget und alle Symbole. Ein Versuch die APK mit neuen nicht-rosa Icons zu packen funktioniert nicht, bzw. die APK ist nicht ausführbar.

Speziell bei der To-Do-Liste bin ich überfordert. Trotz Root kann ich immer noch kein komplettes Boot-Image vom Gerät pullen :-(
 

Anhänge

  • bootanimation.zip
    466,5 KB Aufrufe: 1.370
  • Launcher2.apk
    6,4 MB Aufrufe: 1.235
  • Drivers.zip
    8,3 MB Aufrufe: 2.480
  • root_U8600.zip
    8,9 MB Aufrufe: 2.181
Zuletzt bearbeitet von einem Moderator:
T

trintyjck

Ambitioniertes Mitglied
Changelog:
(10.12.12 - 17:30Uhr) - Link2SD Anleitung eingefügt
 
Zuletzt bearbeitet:
K

Kitara

Neues Mitglied
Hallo Leute
Danke für die mühe !!!
Das Rooten ist sicherlich immer wieder eine herausforderung

Nach der anleitung zu folge bleibt allerdings bei mir der bildschirm im ladevorgang stehen -.-

bat schreibt :
* daemon not running. starting it now *
* daemon started successfully *
< waiting for device >

danach geht es nichts mehr Stecker ab händy aus und einschalten und es ist wieder wie zuvor nicht gerootet *schnief*
 
P

Paddel0815

Neues Mitglied
Bei mir auch kein root.

Hier mal die Ausgabe:
Code:
* daemon not running. starting it now *
* daemon started successfully *
< waiting for device >
downloading 'boot.img'... OKAY
booting... OKAY
* daemon not running. starting it now *
* daemon started successfully *
adbd is already running as root
remount failed: Unknown error: 0
4989 KB/s (91980 bytes in 0.018s)
5289 KB/s (996704 bytes in 0.184s)
5220 KB/s (416954 bytes in 0.078s)
und ohne @echo off:
Code:
C:\U8600>root

C:\U8600>adb kill-server

C:\U8600>adb reboot bootloader
* daemon not running. starting it now *
* daemon started successfully *

C:\U8600>ping -n 5 127.0.0.1  1>nul

C:\U8600>fastboot devices

C:\U8600>fastboot boot recovery.img
< waiting for device >
downloading 'boot.img'... OKAY
booting... OKAY

C:\U8600>ping -n 5 127.0.0.1  1>nul

C:\U8600>adb kill-server

C:\U8600>adb root
* daemon not running. starting it now *
* daemon started successfully *
adbd is already running as root

C:\U8600>adb remount
remount failed: Unknown error: 0

C:\U8600>adb push su /system/bin/su
4989 KB/s (91980 bytes in 0.018s)

C:\U8600>adb shell chown 0.0 /system/bin/su

C:\U8600>adb shell chmod 6755 /system/bin/su

C:\U8600>adb push Superuser.apk /system/app/Superuser.apk
4656 KB/s (996704 bytes in 0.209s)

C:\U8600>adb shell chown 0.0 /system/app/Superuser.apk

C:\U8600>adb shell chmod 0644 /system/app/Superuser.apk

C:\U8600>adb push RootExplorer.apk /system/app/RootExplorer.apk
5577 KB/s (416954 bytes in 0.073s)

C:\U8600>adb shell chown 0.0 /system/app/RootExplorer.apk

C:\U8600>adb shell chmod 0644 /system/app/RootExplorer.apk

C:\U8600>adb reboot

C:\U8600>
 
S

sim4000

Neues Mitglied
kann ich bestätigen. ebenfalls error bei remount und superuser oder rootexplorer werden nicht installiert.

@Kitara: Hört sich so an als bräuchtest du die adb-Treiber. Beim Einstecken des Handys den Huawei-Kram einfach installieren lassen
 
Zuletzt bearbeitet:
T

trintyjck

Ambitioniertes Mitglied
Nach der anleitung zu folge bleibt allerdings bei mir der bildschirm im ladevorgang stehen -.-

bat schreibt :
* daemon not running. starting it now *
* daemon started successfully *
< waiting for device >

danach geht es nichts mehr Stecker ab händy aus und einschalten und es ist wieder wie zuvor nicht gerootet *schnief*
Das Telefon "hängt" dann aber beim weißen Bildschirm mit dem Kringel in der Mitte? Scheint mir so, als wären die Fastboot-Treiber nicht installiert.
 
K

Kitara

Neues Mitglied
trintyjck schrieb:
Das Telefon "hängt" dann aber beim weißen Bildschirm mit dem Kringel in der Mitte? Scheint mir so, als wären die Fastboot-Treiber nicht installiert.
Jepp genau da

Der ursprüngliche Beitrag von 13:03 Uhr wurde um 13:03 Uhr ergänzt:

sim4000 schrieb:
kann ich bestätigen. ebenfalls error bei remount und superuser oder rootexplorer werden nicht installiert.

@Kitara: Hört sich so an als bräuchtest du die adb-Treiber. Beim Einstecken des Handys den Huawei-Kram einfach installieren lassen
doch sind installiert nur springen die kaum an muss immer wieder usb port wechseln

Der ursprüngliche Beitrag von 13:03 Uhr wurde um 13:10 Uhr ergänzt:

So bei mir erscheint nun folgendes ^^

Link zu Bilder
ImageShack Album - 2 images
 
S

sim4000

Neues Mitglied
trintyjck schrieb:
Das Telefon "hängt" dann aber beim weißen Bildschirm mit dem Kringel in der Mitte? Scheint mir so, als wären die Fastboot-Treiber nicht installiert.
Da hängt mein Telefon nun auch bei jedem Start für ca. 20 Sekunden, danach bootet es normal...
 
T

trintyjck

Ambitioniertes Mitglied
Kitara schrieb:

So bei mir erscheint nun folgendes ^^

Link zu Bilder
ImageShack Album - 2 images
Das ist das CWM-Recovery, da sollte das Script eigentlich anfangen die Sachen zu kopieren und danach das Telefon neustarten. Das scheint aber nicht zu funktionieren. Ich bastel da nochmal was. Scheint so, als würde das System nicht korrekt gemountet.
 
K

Kitara

Neues Mitglied
So nun bin ich auch soweit


C:\root>adb kill-server

C:\root>adb reboot bootloader
* daemon not running. starting it now *
* daemon started successfully *

C:\root>ping -n 5 127.0.0.1 1>nul

C:\root>fastboot devices

C:\root>fastboot boot recovery.img
< waiting for device >
downloading 'boot.img'... OKAY
booting... OKAY

C:\root>ping -n 5 127.0.0.1 1>nul

C:\root>adb kill-server

C:\root>adb root
* daemon not running. starting it now *
* daemon started successfully *
adbd is already running as root

C:\root>adb remount
remount failed: Unknown error: 0


C:\root>adb push su /system/bin/su
5748 KB/s (91980 bytes in 0.015s)

C:\root>adb shell chown 0.0 /system/bin/su

C:\root>adb shell chmod 6755 /system/bin/su

C:\root>adb push Superuser.apk /system/app/Superuser.apk
4791 KB/s (996704 bytes in 0.203s)

C:\root>adb shell chown 0.0 /system/app/Superuser.apk

C:\root>adb shell chmod 0644 /system/app/Superuser.apk

C:\root>adb push RootExplorer.apk /system/app/RootExplorer.apk
4343 KB/s (416954 bytes in 0.093s)

C:\root>adb shell chown 0.0 /system/app/RootExplorer.apk

C:\root>adb shell chmod 0644 /system/app/RootExplorer.apk

C:\root>adb reboot

C:\root>warte auf benutzereingabe
Drücken Sie eine beliebige Taste . . .
 
T

trintyjck

Ambitioniertes Mitglied
Ich hab den ersten Beitrag aktualisiert. Bitte das Skript neu herunterladen und ausprobieren :)
 
P

Paddel0815

Neues Mitglied
RootCheckBasic sagt:

Congratulations!
This device has root access!


Also unter cwm system mounten, das war es!
 
Zuletzt bearbeitet:
K

Kitara

Neues Mitglied
RootCheckBasic sagt:

Congratulations!
This device has root access!
:thumbsup::thumbsup::thumbsup::thumbsup::thumbsup::thumbsup:
 
P

Paddel0815

Neues Mitglied
trintyjck schrieb:
Trotz Root kann ich immer noch kein komplettes Boot-Image vom Gerät pullen :-(
Probier die mal, die ist mit cwm gemacht.
 

Anhänge

  • boot.zip
    3,2 MB Aufrufe: 264
M

musikant01

Ambitioniertes Mitglied
RootCheckBasic taucht nicht auf . extra runterladen ?
 
P

Paddel0815

Neues Mitglied
Sollte beim rooten installiert werden.
 
M

musikant01

Ambitioniertes Mitglied
kein root
 
T

trintyjck

Ambitioniertes Mitglied
Sind der Rootexplorer und SuperSu vorhanden? Kommt du SuperUser-Abfrage, wenn der Rootexplorer gestartet wird?

Kannst du mal die Ausgabe der Batch-Datei posten?
 
M

musikant01

Ambitioniertes Mitglied
Nein, Rootexplorer und SuperSu sind NICHT vorhanden. Es läuft alles durch, Handy startet neu, aber es passiert nichts.
 
T

trintyjck

Ambitioniertes Mitglied
musikant01 schrieb:
Nein, Rootexplorer und SuperSu sind NICHT vorhanden. Es läuft alles durch, Handy startet neu, aber es passiert nichts.
Da würde ich spontan behaupten, dass das System nicht gemountet wurde.

Nachtrag: Ich habs gerade ausprobiert. Wenn das System nicht gemountet wurde (also das auf dem Telefon ausgeführt wurde, was die Batch-Datei vorgibt), dann funktioniert das nicht. Das Skript läuft aber trotzdem fehlerfrei durch.
 
Zuletzt bearbeitet:
Status
Für weitere Antworten geschlossen.