ZTE Blade L3 - Cyanogenmod und CWM Recovery

M

McTrampiboy

Gast
Hall Leute,

Ich habe gestern mein neues Handy bekommen. Zuerst hab ich es gerootet, alles ohne Probleme. Nun wollte ich schauen ob ich eine custom Recovery und danach eine custom Rom für das Blade L3 finde. Leider beides ohne Erfolg.

Nun meine Frage an euch, gibt es schon jemanden der erfolgreich die CWM Recovery (oder alternativ auch TWRP) auf dieses Handy gebracht hat? Und dazu am besten noch eine aktuelle Version von Cyanogenmod?

Ich habe zwar schon zwei Handys erfolgreich mit CWM und Cyanogemod geflasht, nur bis jetzt weder die ZIP selbst aus den repositorys gebaut geschweige denn auf ein neues Handy portiert (was nach den beschreibungen bei Cyanogenmod noch schwieriger sein soll)

Falls es wirklich keinen gibt der es bis jetzt versucht und geschafft hat, dann würde ich mich selbst da ran setzten.

Grüße

Martin
 
R

Rincee

Ambitioniertes Mitglied
Hallo McTrampiboy, ich kann Dir zwar bei Deinem Problem nicht wirklich helfen, mich würde aber brennendst interessieren, wie Du das L3 hast rooten können... bei mir scheitern alle Versuche, siehe dazu auch der Post hier im Board... Ich hätte echt gern eine Anleitung dazu, möglichst Schritt für Schritt, damit ich nichts übersehe, möglicherweise bin ich ja auch einfach zu blöd dazu... bei mir ist übrigens lollipop 5.0.2 drauf, zur Info
 
M

McTrampiboy

Gast
Hey, bei mir hat es mit KingRoot geklappt. Nicht zu verweckseln mit KingoRoot. damit hat es nicht geklappt. Ich habe mir die APK runter gleaden und der one klick root hat ohne Probleme geklappt. Bei mir ist aber auch nur 5.0 drauf. Auf einer der Seiten zu den oneclickRootern (weiß leider nicht mehr welcher) stand auch was, dass man sich melden kann wenn es bei einem Handy nicht klappt und sie versuchen es zu beheben. Das könnte noch eine Möglichkeit sein, auch wenn es etwas länger dauern könnte.
ZTE Blade L3 - lollipop 5.0.2 funktionierender ROOT gesucht
 
M

McTrampiboy

Gast
Hey,

ich habe eine funktionierende Version von der CWM Recovery erstellt.

!!! Ich habe sie nocht nicht vollständig getestet !!!

Aber auch später bin ich nicht dafür verantwortlich wenn ihr euch mit dem Recovery Image euer Handy zerschießt.

Ich werde die Recovery in den nächsten Tagen testen und verbessern, wer sie trotzdem schon benutzen will kann sie bei GitHub runter laden. Ich werde es dann demnächst mit einer Detalierten beschreibung bei XDA Developers reinstellen.

Und jetzt noch eine kurze Anleitung zum installieren:

Da ich es nicht geschafft habe fastboot zu aktivieren ("fastboot oem unlock") habe ich die Recovery über adb und dd geflasht.

Dazu erstmal ADB installieren (findet sich viel zu im Internet) und folgende Befehle ausführen

1. adb push recovery.img /sdcard/recovery.img
Das überträgt das image auf den internen Speicher eures Handys, ihr könnt es auch auf die sd karte speichern.
2. adb shell
Das öffnet euch eine ADB shell auf dem Handy.
3. su
Das macht euch zum superuser (root) auf eurem Handy
4 cat /cache/recovery/last_log
Das gibt euch eine Lange ausgabe. Dort sucht ihr die partitionstabelle raus, bei mir sieht das ganze so aus:
.
.
.
Partition Information:
preloader 0x0000000001400000 0x0000000000000000 2 /dev/misc-sd
mbr 0x0000000000080000 0x0000000000000000 2 /dev/block/mmcblk0
ebr1 0x0000000000080000 0x0000000000080000 2 /dev/block/mmcblk0p1
pro_info 0x0000000000300000 0x0000000000100000 2 /dev/block/mmcblk0
nvram 0x0000000000500000 0x0000000000400000 2 /dev/block/mmcblk0
protect_f 0x0000000000a00000 0x0000000000900000 2 /dev/block/mmcblk0p2
protect_s 0x0000000000a00000 0x0000000001300000 2 /dev/block/mmcblk0p3
seccfg 0x0000000000020000 0x0000000001d00000 2 /dev/block/mmcblk0
uboot 0x0000000000060000 0x0000000001d20000 2 /dev/block/mmcblk0
bootimg 0x0000000001000000 0x0000000001d80000 2 /dev/block/mmcblk0
recovery 0x0000000001000000 0x0000000002d80000 2 /dev/block/mmcblk0
sec_ro 0x0000000000600000 0x0000000003d80000 2 /dev/block/mmcblk0p4
misc 0x0000000000080000 0x0000000004380000 2 /dev/block/mmcblk0
logo 0x0000000000300000 0x0000000004400000 2 /dev/block/mmcblk0
expdb 0x0000000000a00000 0x0000000004700000 2 /dev/block/mmcblk0
android 0x0000000080000000 0x0000000005100000 2 /dev/block/mmcblk0p5
cache 0x000000000e200000 0x0000000085100000 2 /dev/block/mmcblk0p6
usrdata 0x000000013cc80000 0x0000000093300000 2 /dev/block/mmcblk0p7
bmtpool 0x0000000001500000 0x00000000febf00a8 2 /dev/block/mmcblk0
.
.
.
dort seht ihr die Zeile mit "recovery am Anfang
recovery 0x0000000001000000 0x0000000002d80000 2 /dev/block/mmcblk0
Das bedeutet unsere Recovery Partition liegt auf dem Medium /dev/block/mmcblk0 und dort fängt sie an bei byte 2d80000 und ist 1000000 lang. Ich weiß nicht ob es bei euch abweicht, sollte es aber nicht.
!! Vosicht, diese Angaben isnd Hexadezimalzahlen !!

5. dd if=/dev/zero of=/dev/block/mmcblk0 bs=1 seek=47710208 count=16777216
Was hier passiert ist eigentlich ganz einfach, wir überschriben die gesamte recovery partition mit nullen. dabei bedeutet bs=1, dass in schritten von 1 byte geschrieben wird, seek=... wie viele blöcke er am Anfang auslässt (Dann beginnt er genau da wo auch unsere Recovery ist) und count=... wie viele folgende blöcke er schreiben soll.
Ab hier könnte etwas schief gehen. Am besten ihr macht vor diesem schritt erstmal ein backup diese bereiches, das geht mit
dd if=/dev/block/mmcblk0 of/sdcard/backup_recovery.img bs=1 skip=47710208 count=16777216
6. dd if=/sdcard/recovery.img of=/dev/block/mmcblk0 bs=1 seek=47710208
das schreibt euch jetzt das Image auf eure Recovery Partition.


Wenn ich jetzt mit adb reboot recovery das handy neu startet seit ihr in der CWM Recovery.


!!!!!! DOWNLOAD LINK !!!!!!
McTrampiboy/android_device_zte_p182a20-build_cwm_recovery · GitHub
 
R

Rincee

Ambitioniertes Mitglied
ZTE Blade L3 ROM, Recovey, Root, Herramientas y más ist ein Blog, der sich wohl anscheinend ausschliesslich mit dem L3 befasst... Dummerweise komplett auf spanisch, was mir leider mal so gar nix bringt, aber vielleicht kennt hier jemand einen, der jemanden kennt, der....


Ich kann also auch root und SU über die ADBgeschichte bekommen, habe ich das richtig begriffen? Bislang schlagen alle Versuche mit den oneclicktools fehl... Im anderen Thread pflichtet mir übrigens jemand bei, das l3 mit 5.0.2 scheint per OneClick unrootbar zu sein.

However, alsbald als Dein Recovery komplett getestet ist, und Du eine DummUserAnwendbarmachmethode dafür zusammen hast, lass es mich wissen ;)
 
M

mitchde

Erfahrenes Mitglied
DANKE!
Hinweis: dd if=/dev/block/mmcblk0 of/sdcard/backup_recovery.img bs=1 skip=47710208 count=16777216
Hier fehlt ein =, daher Fehlermeldung.
dd if=/dev/block/mmcblk0 of=/sdcard/backup_recovery.img bs=1 skip=47710208 count=16777216

Mein L3 : (aus cat ....)
ro.mediatek.version.release=DIS_EU_B128DL_P182A20V1.0.0
ro.build.fingerprint=ZTE/P182A20/P182A20:5.0/LRX21M/20150522.103455:user/release-keys

Partitioninfos bei mir (cat ...) ist wie bei der Anleitung = ich wage mal das mit dem ADB :) (unter Mac OS X :) )

adb devices
List of devices attached
0123456789ABCDEF device

GA-EP35:~ andreasm$ adb push /Users/andreasm/Desktop/recovery.img /sdcard/recovery.img
5040 KB/s (6266880 bytes in 1.214s)
GA-EP35:~ andreasm$ adb shell
shell@P182A20:/ $ su
root@P182A20:/ #
oot@P182A20:/ # dd if=/dev/block/mmcblk0 of=/sdcard/backup_recovery.img bs=1 skip=47710208 count=16777216 (Hinweis: dauerte ca. 30 Minuten!!)
16777216+0 records in
16777216+0 records out
16777216 bytes transferred in 1815.880 secs (9239 bytes/sec)
(Info: das backup_recovery.img ist 16 MB groß.
root@P182A20:/ # dd if=/dev/zero of=/dev/block/mmcblk0 bs=1 seek=47710208 count=16777216 (Hinweis: dauerte ca. 3 Minuten)
16777216+0 records in
16777216+0 records out
16777216 bytes transferred in 158.850 secs (105616 bytes/sec)
root@P182A20:/ #
oot@P182A20:/ # dd if=/sdcard/recovery.img of=/dev/block/mmcblk0 bs=1 seek=47710208 (Hinweis: dauerte ca. 1 Minute)
6266880+0 records in
6266880+0 records out
6266880 bytes transferred in 62.117 secs (100888 bytes/sec)

Reboot in CWM recovery (6.xxxx) hat geklappt!

ABER:
Lauter Fehlermeldungen wie cant mount ...., cant format, beim starten con CWM bzw. bei backup oder auch mount usb - somit ohne Funktion.
Somit bisher nicht nutzbar.

PS:
Kann mir jemand das backup_recovery image erstellen und hochladen? (Bitte checken ob gleiches Gerät)
Ich Depp hatte zuerst das nullen gemacht, dann das backup! Habe das im Ablauf oben jetzt (für backup)
in der richtigen Reihenfolge aufgelistet.

Recovery Mode (ohne ADB)
  1. Turn off the device
  2. Press and hold Volume Up key + Power key about 10 seconds
  3. Release all keys when Android logo appears
  4. Press Power key to enter Recovery Mode
  5. Use Volume Down key to select Menu
  6. Use Volume UP key to Confirm
funzt!

Kann mir jemand ein backup_recovery erstellen/hochladen das VOR dem dd zero backuped wurde?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
So für Fehlersuche (CWM meldet massig cant mout, cant format errors)

Hier mein Parttable (von cat ...)
Partition Information:
preloader 0x0000000001400000 0x0000000000000000 2 /dev/misc-sd
mbr 0x0000000000080000 0x0000000000000000 2 /dev/block/mmcblk0
ebr1 0x0000000000080000 0x0000000000080000 2 /dev/block/mmcblk0p1
pro_info 0x0000000000300000 0x0000000000100000 2 /dev/block/mmcblk0
nvram 0x0000000000500000 0x0000000000400000 2 /dev/block/mmcblk0
protect_f 0x0000000000a00000 0x0000000000900000 2 /dev/block/mmcblk0p2
protect_s 0x0000000000a00000 0x0000000001300000 2 /dev/block/mmcblk0p3
seccfg 0x0000000000020000 0x0000000001d00000 2 /dev/block/mmcblk0
uboot 0x0000000000060000 0x0000000001d20000 2 /dev/block/mmcblk0
bootimg 0x0000000001000000 0x0000000001d80000 2 /dev/block/mmcblk0
recovery 0x0000000001000000 0x0000000002d80000 2 /dev/block/mmcblk0
sec_ro 0x0000000000600000 0x0000000003d80000 2 /dev/block/mmcblk0p4
misc 0x0000000000080000 0x0000000004380000 2 /dev/block/mmcblk0
logo 0x0000000000300000 0x0000000004400000 2 /dev/block/mmcblk0
expdb 0x0000000000a00000 0x0000000004700000 2 /dev/block/mmcblk0
android 0x0000000080000000 0x0000000005100000 2 /dev/block/mmcblk0p5
cache 0x000000000e200000 0x0000000085100000 2 /dev/block/mmcblk0p6
usrdata 0x000000013cc80000 0x0000000093300000 2 /dev/block/mmcblk0p7
bmtpool 0x0000000001500000 0x00000000febf00a8 2 /dev/block/mmcblk0


recovery filesystem table
=========================
0 /tmp ramdisk (null) (null) 0
1 /boot emmc boot (null) 0
2 /cache ext4 /dev/block/mmcblk0p6 (null) 0
3 /data ext4 /dev/block/mmcblk0p7 (null) 0
4 /misc emmc misc (null) 0
5 /recovery emmc recovery (null) 0
6 /sdcard vfat /dev/block/mmcblk1p1 /dev/block/mmcblk1 0
7 /sdcard2 vfat /dev/block/mmcblk1p1 (null) 0
8 /system ext4 /dev/block/mmcblk0p5 (null) 0
9 /custom ext4 @? (null) 0


Ich habe mal im gitgub bei der Source des CWM L3 reingeschaut. McTrampiboy/android_device_zte_p182a20 · GitHub
Kann es sein, das dieses recovery.fstab evtl. Anpassungen / Änderungen braucht?
Irgendwie stehen da doch andere Pfade beim recovery filesystem table (oben).
Kenne mich jedoch mit fstab Einträgen gar nicht aus.

recovery.fstab
# mount point fstype device [device2]

/boot mtd boot
/cache yaffs2 cache
/data yaffs2 userdata
/misc mtd misc
/recovery mtd recovery
/sdcard vfat /dev/block/mmcblk0p1 /dev/block/mmcblk0
/system yaffs2 system
/sd-ext ext4 /dev/block/mmcblk0p2




[
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Last but not least: Screenshoot mit den Fehlermeldungen.
Scheint wirklich was mit der fstab zu tun zu haben - steht am Anfang auch was von skipping... malformed!
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
PS: So sieht die recovery.fstab aus die in /system/etc liegt (wohl die die zum orig. system gehört)
Anders als die aus dem github.
recovery.fstab aus die in /system/etc
# mount point fstype device [device2]

/boot emmc boot
/cache ext4 /dev/block/mmcblk0p4
/data ext4 /dev/block/mmcblk0p5
/misc emmc misc
/recovery emmc recovery
/sdcard vfat /dev/block/mmcblk0p6
/system ext4 /dev/block/mmcblk0p3
/custom ext4 /dev/block/mmcblk0p2
 

Anhänge

M

McTrampiboy

Gast
hallo mitchde,

Die Fehlermeldungen kamen bei mir auch allesamt, ich habe es bis jetzt auf eine einzige runter bekommen. Morgen habe ich etwas zeit und hoffe, dass ich es schaffe das zumindest die Grundfunktionen wie backup und recovery laufen. Ich bin guter dinge. Aber danke für den ausführlichen Fehlerbericht. Es ist mein erstes mal, dass ich ein android selbst geportet habe und da kann ich jede unterstützung brauchen. Ich war erstmal froh nach bestimmt 10 Stunden überhaupt einen fehlerfreien build Befehl ausführen zu können.

Ich habe meine Stock Recovery in das Github verzeichniss mit der CWM Recovery geladen und die CWM Recovery auf die Aktuellste Version die ich im Moment habe upgedated, Die jedoch immer noch nicht voll funktioniert.

Grüße
 
M

mitchde

Erfahrenes Mitglied
Danke! Ich denke wir bekommen das mit der Zeit schon hin.
 
No3ight

No3ight

Fortgeschrittenes Mitglied
Hallo,

vielen Dank an euch erst mal das ihr euch mit diesem Thema beschäftigt. Ich möchte mich ganz gerne in die Geschichte einbringen und meinen Senf dazu geben.

79,99€ super Preis. Recovery Backup, CWM geflasht, alles wunderbar. Zurück zur Stock?--> Softbrick? Was habe ich falsch gemacht?

Ich habe die Stock Recovery mit Flashify gesichert, und per CWM wieder geflasht, ich glaube das war fatal.

Wäre ja nicht mal so tragisch, doch besteht bei mir nicht mal mehr die Mögliichkeit in den Downloadmodus zu kommen um evtl. die Stock Firmware via Odin zu flashen.

Nun die Frage an diejenigen die etwas mehr von der Sache verstehen. Wie kann ich mein Handy wieder retten? Wenn ich das Device starte geht es an und verfällt systematisch in den Bootloop. Weder Recovery noch Downloadmodus möchte mir das Blade L3 bescheren.

Ich verfüge über Ubuntu 14.01 x64 und Windows 10 x64.


Vielen Dank im Voraus.

No3ight
 
M

McTrampiboy

Gast
Lässt sich nur die recovery nicht starten oder das ganze System? Wenn das System noch startet kannst du die stock recovery die ich in das GitHub repository hochgeladen habe mithilfe von dd wieder aufspielen. Das geht auch wenn du anderweitig eine adb shell auf dem Handy starten kannst, was aber glaube ich sonst nur über die recovery geht.

Kommt das Handy noch in den fastboot modus? Also in den Bootloader rein?
 
R

Rincee

Ambitioniertes Mitglied
Hallo Jungs, habs schon im anderen Thread beschrieben, bei den XDA developers hat sich jemand auf meine Root Challenge gemeldet und versuchts zu Fuß, vielleicht meldet der sich bei euch fürn paar Tipps. ich kann ja leider ohne root euren Port von Cyanogen nicht auf mein Fon kriegen, oder?
 
M

mitchde

Erfahrenes Mitglied
Rincee schrieb:
Hallo Jungs, habs schon im anderen Thread beschrieben, bei den XDA developers hat sich jemand auf meine Root Challenge gemeldet und versuchts zu Fuß, vielleicht meldet der sich bei euch fürn paar Tipps. ich kann ja leider ohne root euren Port von Cyanogen nicht auf mein Fon kriegen, oder?
Das klappt mit der KingRoot App (kein PC nötig!) einwandfrei. Link dazu weiter oben.

Das CWM 0.4 zeigt diese Startfehler nicht mehr, jedoch wohl noch nicht funktionsfähig (außer menüführung)


PS: Habe ein Forum (ru) gefunden dass auch das Blade L3 behandelt was CWM, TRWP angeht.
Doch bisher klappt das bei mir nicht mit den TRWP Images - rebootet.
Google Übersetzer (übersetzt)

orig. ZTE Blade L3 - Прошивки - 4PDA
 
R

Rincee

Ambitioniertes Mitglied
Hey Mitchde, Kingroot funzt bei mir nicht, alles schon versucht, die App und die WinVersion. Ich hab eben die etwas gehärtetere Lolli 5.0.2 drauf, da rootet mal kingroot so gar nicht. nix zu machen.
 
No3ight

No3ight

Fortgeschrittenes Mitglied
Hallo,

vielen Dank für deine Aufmerksamkeit. Also ich komme nicht mal mehr ins System rein. Somit ist es wohl nicht möglich das Gerät per ADB zu steuern.

Gibt es vielleicht irgendwelche Flashtools die jenes ermöglichen würden?

Danke.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
@
McTrampiboy

folgendes habe ich schon erfolglos ausprobiert:


ZTE Blade L3
 
A

Arty45

Gast
Ich glaube SP flashtool hilft aber dafür brauchst du die scatter file vom zte blade l3
 
M

mitchde

Erfahrenes Mitglied
Rincee schrieb:
Hey Mitchde, Kingroot funzt bei mir nicht, alles schon versucht, die App und die WinVersion. Ich hab eben die etwas gehärtetere Lolli 5.0.2 drauf, da rootet mal kingroot so gar nicht. nix zu machen.
OK,. das kann sein. meins ist noch 5.0 (wieausgeliefert).
Doch wie immer wird es auch da neuere Kingroot Versionen geben die das dann können.
Aktuell ist 4.6.2. (Kingroot hat intern eigene Updatefunktion).
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Arty45 schrieb:
Bei mir rebootet es einfach nahcdem es erfolglos versucht das recovery zu booten - sprich bootet in normales LL.

NEU: Inzwischen läuft TWRP 2.8.7.0 :) Siehe Seite 2
DSCF0646.jpg
 
Zuletzt bearbeitet:
Thread starter Similar threads Forum Replies Date
F Root / Custom-ROMs / Modding für ZTE Blade L3/L3 Plus 1
Oben Unten