Das Xelio übertakten

  • 24 Antworten
  • Neuester Beitrag
Diskutiere Das Xelio übertakten im Root / Hacking / Modding für das Odys Xelio im Bereich Odys Xelio Forum.
SmokeDroid

SmokeDroid

Experte
Ich würde mir gerne eigee werte mit cpuset machen da musik ab und zu ruckelt wenn display aus und push kommt rein.
Ich habe beim scaling default fantasy nur halt minimum auf 120 statt 60mhz (hoffe das reicht).

So das problem ist der max speed, wenn ich auf 1200 mache freezed der sofrt und reboot, der soll doch 1,2ghz haben?
Wenn ich auf 1008mhz stelle steht da beim ergebnis und im widget aber 1200mhz, was habe ich jetzt 1ghz oder 1,2?

Also so habe ich das jetzt 108-1008mhz.

Und dazu gefragt wie vie mhz brauch ich minimum damit zb musik m standby nicht ruckelt?

Hat jemand epfehlenswerte eintellungen, bin noch bisel noob und hatte gestern schn gennug reboo loops :D
 
L

lynxxx

Fortgeschrittenes Mitglied
hast du auch die neuere Firmware vom April? ich meine mich zu erinnern, dass erst dort die 1,2 ghz aktiviert wurden. ansonsten ist die smartass Einstellung oft eine gute Wahl
 
SmokeDroid

SmokeDroid

Experte
Jo hab ich, setcpu läuft nur schlecht bzw buggy.
Habe jetzt cpu master, aber auch hier gibt es probleme.
Beim reboot, rebootet er auch wieder,ich muss ondemand 204-1200 immer selber nachträglich einstellen wenn ich gebootet habe.
Und shedulder einstellungen funktionieren garnicht, der speichert die einfach nicht.

Gibt es eine möglichkeit das alles ordentlich zum laufen zu bekommen zb ein vernünftiger oc kernel wo ich auch gleich mehr mhz speichern kann?
 
Zuletzt bearbeitet:
splotz

splotz

Stammgast
Hallo,

ich habe auf dem Xelio mit dem app No-frills CPU Control bei der Einstellung "fantasy"
rumgespielt und es nach abstürzen bei 1,104Ghz stabil einstellen können.

Die Bedienung ist dadurch sehr viel flüssiger geworden und auch das Surfen mit dem Firefox macht mehr spass :)

Bei 1,15Ghz ging es auch noch, aber das Wlan ging dann nicht immer an...

Er taktet sich bei Fantasy automatisch, aber langsam in Schritten wieder runter
bis das Display berührt wird oder ein App mehr CPU-Leistung braucht
(Schön zu sehen mit dem App "System Tuner" bei "Times", (Vorsicht, mächtiges Tool!))


Meine Frage dazu:
Kann sich das (bis auf die Batterielaufzeit) negativ auswirken, ist die CPU dazu gedacht länger bei diesen Frequenzen zu laufen ?


Gruß
Splotz
 
Zuletzt bearbeitet:
hävksitol

hävksitol

Ehrenmitglied
Hallo splotz, schau mal hier.
 
splotz

splotz

Stammgast
Danke!
Eine 4xFullHD GPU mit 2160p, boah!
(Laut eng. Wikipedia: 4K UHDTV 3840×2160 )


Also scheint die CPU bis 1,2GHz ausgelegt zu sein...
Warum die dann nicht bis dahin funktioniert habe ich nicht ganz verstanden...

Sind andere Bauteile abhängig von der internen Taktrate und nicht dafür ausgelegt ?
Kann man die damit beschädigen ?
 
SmokeDroid

SmokeDroid

Experte
splotz schrieb:
Hallo,

ich habe auf dem Xelio mit dem app No-frills CPU Control bei der Einstellung "fantasy"
rumgespielt und es nach abstürzen bei 1,104Ghz stabil einstellen können
Hab meins jetzt auch mit der app nach langer zeit mal wieder hoch geprügelt, läuft stable bis jetzt (seit heut nachmittag).
In antutu bin ich von 2925@1008mhz auf 3087@1104mhz gekommen :D


Gesendet von meinem Xelio mit Tapatalk 2
 
jna

jna

Ehrenmitglied
Sind das bloß 160 Gummipunkte mehr, oder merkt man tatsächlich was (In dem Sinne, dass Programme "geschmeidiger" werden, der Akku schneller leer ist o.ä.)?
 
Oma7144

Oma7144

Lexikon
Klassisches Busproblem. Mit steigendem CPU-Takt geht die GPU in die Knie.
Wir haben schon SoC's gesehen, die bei 1,2 GHz hochgegangen sind, also Vorsicht!


:thumbup:
 
SmokeDroid

SmokeDroid

Experte
jna schrieb:
Sind das bloß 160 Gummipunkte mehr, oder merkt man tatsächlich was (In dem Sinne, dass Programme "geschmeidiger" werden, der Akku schneller leer ist o.ä.)?
Da ich den minimum takt angehoben habe, ja zb bildschirm geht schneller an.
Geschmeidiger joa, is eh noch an anderen stellen getweakt, aber denke etwas.
Akku is sone sache, ich glaube advanced wifi lock verhindert deep sleep bei mir eh.
Also mehr als 4h benutzung hab ich noch nie geschafft :D
Das ding geht selbst im standby ratz fatz leer :thumbdown:

Oma7144 schrieb:
Klassisches Busproblem. Mit steigendem CPU-Takt geht die GPU in die Knie.
Wir haben schon SoC's gesehen, die bei 1,2 GHz hochgegangen sind, also Vorsicht!


:thumbup:
Also noch läufts alles, kann ich den fsb wie am pc auch anheben?:D
Wie merk ich ob ich die gpu (jetzt schon?) abwürge?
Sind doch erst 10% oc, hmmm ....


Gesendet von meinem Xelio mit Tapatalk 2
 
Zuletzt bearbeitet:
splotz

splotz

Stammgast
jna schrieb:
Sind das bloß 160 Gummipunkte mehr, oder merkt man tatsächlich was (In dem Sinne, dass Programme "geschmeidiger" werden, der Akku schneller leer ist o.ä.)?
Ich finde es so erst annehmbar.
Die Reaktionen beim App-wechseln , Browsen oder Home-Screen wischen kommen mir sehr viel flüssiger vor.

ed.: Ich bin aber auch noch auf dem Stock ROM
 
Zuletzt bearbeitet:
SmokeDroid

SmokeDroid

Experte
Jep komt mir auch flüssiger vor als vorher, obwohl meins eh schon gut lief.
Benutze auch das stock rom, bis auf paar fehlende bibliotheken ist es ja ganz gut.
Der grösste unterschied ist bei mir, das voher der bildschirm zt paar sekunden ausm standby brauchte, und jetzt mit minimum 120mhz (statt 60) geht er sofort an :thumbup:
Akku verbrauch ist gefühlt ähnlich geblieben, einzig 3d games hab ich nicht getestet.
Sollte da schon bei 10% oc n engpass am bus sein gibts wohl n reboot :D

Ps: spielereien am gov oder sheduler können rnd reboots herbei führen, die besser auf default lassen, dann passts.
Und noch angemerkt cm9 war nicht besser, das hat sich bei 1,2ghz auch rnd verabschiedet ;)

Gesendet von meinem Xelio mit Tapatalk 2
 
Zuletzt bearbeitet:
splotz

splotz

Stammgast
Das Übertakten in Verbindung mit "Fanatsy " statt "Interactive" macht für mich viel aus.

Mit Interactive sollte er sparsamer sein, da er schneller runtertaktet.
Mit Fantasy bleibt er immer ein paar Sekunden auf dem höheren Wert bevor er ein bisschen runtergeht.
 
splotz

splotz

Stammgast
Bei externer Spannungsversorgung (USB oder Netzteil)
scheint das Tablet immer auf dem max. Takt zu bleiben.
(performance)

Kann das jemand bestätigen?
(zu sehen beim App "System Tuner" unter "Times")
 
SmokeDroid

SmokeDroid

Experte
Joa kommt so rüber, hab zwar kein tool gerade aber wenn ich mit display on in nofrills nach ner minute nichts tuen aktualisiere bleibt es bei 100% load.
Aber in den gesammt stats ist auch 17% 96mhz, wahrscheinlich wo ich gepennt hab und display off war.

Gesendet von meinem Xelio mit Tapatalk 2
 
splotz

splotz

Stammgast
splotz schrieb:
Bei externer Spannungsversorgung (USB oder Netzteil)
scheint das Tablet immer auf dem max. Takt zu bleiben.
(performance)

Kann das jemand bestätigen?
(zu sehen beim App "System Tuner" unter "Times")
Scheint doch nur zu sein wenn am USB ein Computer erkannt wird (zum synchronisieren).
 
splotz

splotz

Stammgast
So, mit 1,152 Ghz und "interactive" läuft er auch relativ stabil.

Da er sich schnell runtertaktet schafft auch das wlan anzuspringen und weiterzulaufen. Ob dabei die Datenübertragung verschlechert wird konnte ich noch nicht ausprobieren.

Das surfen macht so aber viel mehr spass.
Die Seiten erscheinen mit dem stockbrowser bereits nach 5 Sek.
(Natürlich nur wenn die nicht noch viel werbung beinhalten und man nur einen tab offen hat)
 
Zuletzt bearbeitet:
SmokeDroid

SmokeDroid

Experte
Ich komm jetzt mit oc und noch mehr build.prop tweaks auf 3225 in antutu.
Also wenn der nich komplett falsche ergebnisse zeigt, hab ich das ende der fahnenstange erreicht, die A10 soc's reihen sich da alle bei ~3k ein, wenn ich die stats so betrachte.
Mit den eben noch zu gefügten buildprop tweaks hängt die tastatur auch nicht mehr so hinterher beim schnell tippen :D


Gesendet von meinem Xelio mit Tapatalk 2
 
splotz

splotz

Stammgast
Was hast du alles dafür verändert?
Gibt es dazu einen thread wo man das nachlesen kann?
 
SmokeDroid

SmokeDroid

Experte
Naja ich hab das komplette programm durch inzwischen, ich poste dir die build.prop mal, läuft echt gut, ähnlich schnell wie das cm10 rom :D
Voller store support, tether gps in meine tracks und google navi, mehr speed, angeblich akku sparender, und wenn n kollege die phone apk für natives sip zum laufen bekommt auch dafür gleich die tweaks.
Gibt noch 3g und wlan tweaks, aber das läuft ja beides gut bis jetzt, und bild quali tweaks braucht man mit der cam ja nicht :p

# begin build properties
# autogenerated by buildinfo.sh
ro.build.id=IML74K
ro.build.display.id=cm_907-userdebug 4.0.4 IMM76L eng.alan.20120721.090954 test-keys
ro.build.version.incremental=BGLP8
ro.build.version.sdk=15
ro.build.version.codename=REL
ro.build.version.release=4.0.4
ro.build.date=sab 21 lug 2012, 09.10.48, CEST
ro.build.date.utc=1342854648
ro.build.type=userdebug
ro.build.user=alan
ro.build.host=Audrey
ro.build.tags=test-keys
ro.product.model=MP907C
ro.product.brand=samsung
ro.product.name=GT-I9100
ro.product.device=907
ro.product.board=crane
ro.product.cpu.abi=armeabi-v7a
ro.product.cpu.abi2=armeabi
ro.product.manufacturer=Allwinner
ro.product.locale.language=en
ro.product.locale.region=US
ro.wifi.channels=
ro.board.platform=exDroid
# ro.build.product is obsolete; use ro.product.device
ro.build.product=907
# Do not try to parse ro.build.description or .fingerprint
ro.build.description=GT-I9100-user 4.0.3 IML74K BGLP8 release-keys
ro.build.fingerprint=samsung/GT-I9100/GT-I9100:4.0.3/IML74K/BGLP8:user/release-keys
ro.build.characteristics=tablet
ro.cm.device=907
# end build properties

#
# ADDITIONAL_BUILD_PROPERTIES
#
ro.com.android.dateformat=dd-MM-yyyy
ro.config.ringtone=Ring_Synth_04.ogg
ro.config.notification_sound=pixiedust.ogg
ro.config.alarm_alert=Alarm_Classic.ogg
dalvik.vm.heapstartsize=5m
dalvik.vm.heapgrowthlimit=48m
dalvik.vm.heapsize=64m
ro.kernel.android.checkjni=0
persist.sys.timezone=Europe/Amsterdam
wifi.interface=wlan0
wifi.supplicant_scan_interval=180
debug.egl.hw=1
ro.display.switch=1
ro.opengles.version=131072
persist.sys.strictmode.visual=0
persist.sys.strictmode.disable=1
hwui.render_dirty_regions=false
persist.sampling_profiler=1
persist.sys.usb.config=mass_storage,adb
ro.product.firmware=1.1
persist.service.adb.enable=1
persist.sys.language=de
persist.sys.country=DE
ro.sf.lcd_density=120
ro.build.display.id=A10_ANDROID4.0.3_ODYS_XELIO_V1.01_20120508
ro.config.3ginformation.path=/system/etc/3ginfo.gz
ro.setupwizard.mode=DISABLED
net.bt.name=Android
dalvik.vm.stack-trace-file=/data/anr/traces.txt
debug.sf.hw=1
debug.performance.tuning=1
ro.kernel.checkjni=0
ro.config.nocheckin=1
persist.sys.use_dithering=0
video.accelerate.hw=1
ro.com.google.locationfeatures=1
ro.com.google.networklocation=1
net.dns1=208.67.222.222
net.dns2=208.67.220.220
persist.sys.ui.hw=1
ro.ril.disable.power.collapse=1
pm.sleep_mode=1
windowsmgr.max_events_per_sec=60
ro.max.fling_velocity=12000
ro.min.fling_velocity=8000
ro.telephony.call_ring.delay=0
ro.lge.proximity.delay=25
mot.proximity.delay=25
dalvik.vm.dexopt-flags=m=v,o=y
persist.sys.purgeable_assets=1
dalvik.vm.execution-mode=int:jit
ro.HOME_APP_ADJ=1

Beschreibungen zu den (meisten) tweaks:
androidforums.com/triumph-all-things-root/495620-build-prop-performance-tweaks-updated-04-14-2012-a.html

Alte build.prop sichern nicht vergessen!

OT:
Für alle dl im store zb gps apps wie meine tracks, den trick aus dem ''db navigator auf dem xelio" und "google maps navigation per build.prop frei schalten" thread (2 xml und 1 apk fehlt) nutzen (third party apps können gps aber nicht nutzen).
Und vorher store und ich glaube service provider apk zurück setzen und reboot!

Gesendet von meinem Xelio mit Tapatalk 2
 
Zuletzt bearbeitet: