[How-To] Dell 2.2/318 rooten [09.01.2011]

  • 35 Antworten
  • Neuester Beitrag
Diskutiere [How-To] Dell 2.2/318 rooten [09.01.2011] im Root / Hacking / Modding für Dell Streak im Bereich Dell Streak 5 Forum.
UKSheep

UKSheep

Experte
Hi, habe deinen Beitrag mal hierher verschoben :) Mit ein wenig lesen hättest den Thread eigentlich finden sollen ;) OneToolClick ist vermutlich so was in der Art wie du suchst. Sollte das Tool nicht zum Erfolg führen, gibt es darunter noch eine andere Anleitung (diese hat bei mir auf anhieb funktioniert)

MfG

UKSheep
 
Hoffighter

Hoffighter

Neues Mitglied
UKSheep schrieb:
Habe die Anleitung bereits überarbeitet. ;) SuperOneClick steht nun als erstes mit bei und die andere Anleitung ist dann die Lösung für diejenigen bei denen das SuperOneClick nicht funktioniert, wie z.B. bei mir. :)

MfG

UKSheep
Danke für die Anleitung
da bei mir adb spinnt habe ichs mit dem Superoneclick getestet.
3 mal ohne Erfolg.
Erst als ich es als Admininstrator ausführte hat es geklappt.....

kann Zufall sein .... wenns bei jemanden nicht klappt Bitte mal testen..

THX
 
UKSheep

UKSheep

Experte
Habe deinen Tipp mal in den 1. Post hinzugefügt.

THX

MfG

UKSheep
 
E

enidandreas

Erfahrenes Mitglied
Hallo,

habe mich jetzt doch mal an das rooten gewagt. Da Superoneclick bei mir ebenfalls nicht lief habe ich mich an diese Anleitung gehalten.
Bin bis zu dem Punkt gekommen:

###########################
******this will kill adb server but manually kill it anyway and restart it ******
adb kill-server

adb start-server
* daemon not running. starting it now *
* daemon started successfully *
#################################

als ich dann aber den Befehl
adb shell
ausführte erhielt ich:

error: device not found :angry:
...und der streak reagiert nun gar nicht mehr. er lässt sich auch nicht ausschalten um evtl. einen reboot zu probieren.
was hab ich falsch gemacht? kann mir jemand helfen?

Achso: Der Debugging Modus ist aktiviert, Flugmodus aktiviert, wlan gps nd bluetooth sind ausgeschaltet.

Hoffe der streak lebt bald wieder...
danke schonmal für hilfe
gruß
 
UKSheep

UKSheep

Experte
Hi, also "aus" bekommst du ihn zur not durch "sehr langes" drücken des Power Buttons... oder durch entfernen des Akkus... danach erneut versuchen zu booten... und am besten erneut versuchen zu rooten... Habe von deinem beschriebenen Problem noch nichts gehört und kann deswegen leider wenig dazu sagen.
Evtl. kennt jemand anderes das Problem.

MfG

UKSheep
 
E

enidandreas

Erfahrenes Mitglied
Hallo UKSheep,

vielen Dank!!! hatte nicht gewusst ob ich irgendwo hänge wo man den streak besser NICHT abschalten sollte. Habe getan was Du gesagt hast und nu:

hatklappt - freumir :lol::lol::lol:

habe mal den kompletten Inhalt meiner cmd kopiert, vielleicht hilft es ja jemandem:
################################################
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Dokumente und Einstellungen\Andi>cd..

C:\Dokumente und Einstellungen>cd..

C:\>cd adb

C:\adb>adb push rageagainstthecage-arm5.bin /data/local/tmp/rageagainstthecage
adb server is out of date. killing...
* daemon started successfully *
5 KB/s (5392 bytes in 1.000s)

C:\adb>adb push Superuser.apk /data/local/tmp/Superuser.apk
1535 KB/s (196521 bytes in 0.125s)

C:\adb>adb push su /data/local/tmp/su
1641 KB/s (26264 bytes in 0.015s)

C:\adb>adb push busybox /data/local/tmp/busybox
1898 KB/s (1062992 bytes in 0.546s)

C:\adb>adb shell chmod 700 /data/local/tmp/rageagainstthecage

C:\adb>adb shell chmod 700 /data/local/tmp/busybox

C:\adb>adb shell
$ cd /data/local/tmp
cd /data/local/tmp
$ ./rageagainstthecage
./rageagainstthecage
[*] CVE-2010-EASY Android local root exploit (C) 2010 by 743C

[*] checking NPROC limit ...
[+] RLIMIT_NPROC={3145, 3145}
[*] Searching for adb ...
[+] Found adb as PID 106
[*] Spawning children. Dont type anything and wait for reset!
[*]
[*] If you like what we are doing you can send us PayPal money to
[*] 7-4-3-C@web.de so we can compensate time, effort and HW costs.
[*] If you are a company and feel like you profit from our work,
[*] we also accept donations > 1000 USD!
[*]
[*] adb connection will be reset. restart adb server on desktop and re-login.
$

C:\adb>adb kill-server

C:\adb>adb start-server
adb server is out of date. killing...
ADB server didn't ACK
* failed to start daemon *

C:\adb>adb kill-server

C:\adb>adb start-server
adb server is out of date. killing...
* daemon started successfully *

C:\adb>adb shell
# mount -o remount,rw -t yaffs2 /dev/block/mtdblock6 /system
mount -o remount,rw -t yaffs2 /dev/block/mtdblock6 /system
# cd /data/local/tmp
cd /data/local/tmp
# ./busybox cp busybox /system/bin/
./busybox cp busybox /system/bin/
# chmod 4755 /system/bin/busybox
chmod 4755 /system/bin/busybox
# busybox cp Superuser.apk /system/app/
busybox cp Superuser.apk /system/app/
# busybox cp su /system/bin/
busybox cp su /system/bin/
# chmod 4755 /system/bin/su
chmod 4755 /system/bin/su
# exit
exit

C:\adb>adb shell
adb server is out of date. killing...
ADB server didn't ACK
* failed to start daemon *
error:

C:\adb>adb shell
adb server is out of date. killing...
* daemon started successfully *
$ # su
# su
$ su
su
Permission denied
# mount -o remount,ro -t yaffs2 /dev/block/mtdblock6 /syst$$
# mount -o remount,ro -t yaffs2 /dev/block/mtdblock6 /syst$
$ exit
exit

C:\adb>
###############################################

Wie Du siehst habe ich in dem Bereich REMOUNT FILESYSTEM ein Leerzeichen eingefügt. Ich weiss ja nicht ob das unbedingt nötig war, aber evtl. stolpert ja jemand drüber...

Nochmal:

VIELEN DANK

Gruß
 
I

ixi

Experte
sieht mir ganz danach aus, als ob es vorher am fehlenden Leerzeichen gelegen hat.
 
T

Tolker

Ambitioniertes Mitglied
Gibt´s auch ´ne Anleitung wie ich Super One Klick hinkriege? Ich versteh´ nur Bahnhof! Ich hab´s auf Win7 als ZIP - und wie krieg´ ich´s auf´s Streak?
 
T

Tolker

Ambitioniertes Mitglied
TimoBeil schrieb:
.....Herunterladen kannst du das Tool bei den xda-developers. Und zwar direkt auf den Streak laden und dort ausführen. Oft musste man das Rooten 2x durchziehen. Beim 1. Mal klappe es teils nicht.
Dort kann ich´s nicht finden. Bei google direkt eingegeben erscheint´s als apk, allerdings als beta - sogar mit Barcode. Kann ich´s riskieren?
 
TimoBeil

TimoBeil

Ehrenmitglied
Zuletzt bearbeitet:
T

Tolker

Ambitioniertes Mitglied
Erstmal nix. Es erscheint nach Sekunden "Failed!No~~~Fugoo~~~" Ich probier´s noch´n bisschen, vielleicht auch nach Reset und frag´ dann wieder (Wenn ich wieder Zeit hab´ - Ihr seid ja zum Glück geduldig...)
 
T

Tolker

Ambitioniertes Mitglied
So - jetzt hab´ ich einen Factoryreset gemacht! Sinnigerweise auf der Reise zur Arbeit mit dem Ergebnis daß alles weg war und nur weil ich ein paar Apps löschen wollte. Mit Backup & Restore hab´ ich zwar das meiste wieder hingekriegt aber halt nicht alles. Meine drei WLAN Zugänge waren weg. Da muß ich mir wohl wieder die Schlüssel besorgen... Wie verhält es sich eigentlich mit Dell Sync. Da kann ich USB mäßig einstellen was ich will - funzt nicht. Geht das nur über WLAN? Was mach´ ich falsch daß ich nicht in Funknetze komme (GPRS/EDGE/3G/HSPA)? Gehört das überhaupt noch hierher?
 
UKSheep

UKSheep

Experte
Tolker schrieb:
So - jetzt hab´ ich einen Factoryreset gemacht! Sinnigerweise auf der Reise zur Arbeit mit dem Ergebnis daß alles weg war und nur weil ich ein paar Apps löschen wollte. Mit Backup & Restore hab´ ich zwar das meiste wieder hingekriegt aber halt nicht alles. Meine drei WLAN Zugänge waren weg. Da muß ich mir wohl wieder die Schlüssel besorgen... Wie verhält es sich eigentlich mit Dell Sync. Da kann ich USB mäßig einstellen was ich will - funzt nicht. Geht das nur über WLAN? Was mach´ ich falsch daß ich nicht in Funknetze komme (GPRS/EDGE/3G/HSPA)? Gehört das überhaupt noch hierher?
Hi, ich glaube dafür wär fast ein eigener Thread drin ;)
Hat ja nicht viel mit dem rooten des Dell 2.2/318 Rom zu tun :)

Das nach einem Factory Reset "alles" weg ist... war doch klar (oder nicht?)

MfG

UKSheep
 
F

flyyy

Experte
direkt nach der ersten zeile: "error: device not found"

streak ist im debugging modus, per usb verbunden und nicht als massenspeicher aktiviert.

muss denn sonst nichts installiert sein? telefontreiber etc?