ICS: Partitionierung im APX-Modus - wozu?

A

andro-eddi

Fortgeschrittenes Mitglied
Threadstarter
Hallo Leute,

ich hatte bisher auf meinem Hannsi außer dem Original nur das Hanns-Titan-ROM. Jetzt wollte ich endlich mal auf ICS und bin nach dieser Anleitung hier vorgegangen: https://www.android-hilfe.de/forum/anleitungen-fuer-hannspree-hannspad-sn10t1.481/ice-cream-sandwich-installationsanleitungen-drh-team-rom-fards-rom.188417.html#post-2843611

Hat alles bestens geklappt, bis auf "3. Partitionierung des Hannspad". In den APX-Modus bin ich gekommen, allerdings habe ich die Verbindung zum PC nicht zustande gebracht. Ich habe auch die Anleitung https://www.android-hilfe.de/forum/custom-roms-fuer-hannspree-hannspad-sn10t1.482/teamdrh-ics-preview-2b.211134-page-4.html#post-2817648 durchgeführt, aber das hat nicht funktioniert (Treiber wurde nicht installiert).

Nach einiger Zeit habe ich 3. aufgegeben und einfach mit 4. weitergemacht - und siehe da, alles lief einwandfrei bis zum Schluss, ICS rennt ohne Probleme.

Jetzt frage ich mich allerdings: was habe ich verpasst, da ich nicht 3. nicht ausführen konnte? Dort steht ja eindeutig "
Dies ist Voraussetzung für die weitere Installation" und bei mir ging es auch ohne.

Falls meine Frage hier bereits irgendwo erklärt ist, bitte ich um Entschuldigung. Ich habe weder bei der Suche nach "APX" noch nach "Partitionierung" Erhellung gefunden.

Grüße
 
4dro1d

4dro1d

Lexikon
Kanns sein das du das Pad gebraucht gekauft hast ?

Die Partitionierung wird eigentlich gebraucht, da das ROM normalerweise zu groß ist. Du hast auch keine Abstürtze oder sonstiges ?
 
A

andro-eddi

Fortgeschrittenes Mitglied
Threadstarter
Hi,

ich habe das Pad in der Tat gebraucht gekauft, allerdings habe ich den Verkäufer persönlich kennengelernt - er hat es weiterverkauft, weil er damit nicht klarkam und ich bin mir nahezu 100%ig sicher, dass er daran nichts gemoddet hat, geschweide denn über PC-Verbindung die Partitionen verändert. Ich habe damals als erstes seine persönlichen Daten gelöscht und das Gerät zurückgesetzt...

Jedenfalls läuft das ICS nun seit zwei Tagen ohne Probleme, ich habe auch schon drei neue Apps aus dem Play Store dazuinstalliert.

Wenn ich diese APX-Verbindung mal hinbekommen würde, könnte ich vermutlich die Partitionen sehen, oder? Ich habe die Anleitung zur Treiberinstallation exakt befolgt, der Treiber wurde aber nicht installiert und taucht auch nicht im Gerätemanager auf (Win7). Was könnte ich noch probieren? Mich interessierts ja selber.
 
P

Papandroid

Neues Mitglied
Hallo,

meinem HannsI hat der APX-Modus schon 2 mal das Leben gerettet, weil sonst nichts mehr ging. Du hast also Recht, wenn Du Alles versuchst, diese Verbindung ans Laufen zu bekommen.

Ich bin kein APX-Experte, bis bessere Hilfe kommt stelle ich einfach mal die üblichen dümmsten Fragen (manchmal übersieht man ja nur was)
:flapper::
- APX-Modus am Hannspad hast Du hinbekommen sagst Du, also:
- Hannspad ausgeschaltet und nicht per USB mit PC verbunden
- Minus- und Powertaste gleichzeitig gedrückt gehalten bis Bildschirm schwarz.
- Minus- und Powertaste gleichzeitig losgelassen.
dann:
- Hannspad per USB-Kabel mit laufendem Windows-PC verbinden

Versuche, falls keine Verbindung zustande kommt:
- USB-Kabel direkt und ohne Verlängerungen, Hubs etc. an einen PC-USB- Anschluss
- Alle USB-Anschlüsse am PC testen (falls vorhanden Hinten und Vorne)
- Anderes USB-Kabel testen

Mehr dümmere Fragen habe ich leider im Moment nicht auf Lager.

Ergänzung:
Den in Deinem ICS-Preview-2b-Ling beschriebenen Treiber brauchst Du hierfür meines Wissens nicht. Der ist aber sehr nützlich, wenn Du per USB-Verbindung Daten zwischen PC und Hannspad austauschen willst. Bei diesem Treiber hast Du auch Zugriff auf eine evtl. eingesetzte SD-Karte, was bei "normaler" USB-Verbindung nicht der Fall ist.
 
Zuletzt bearbeitet:
P

Papandroid

Neues Mitglied
Das System-Rom sollte ja größer sein
bei mir: 259 / 1,97 / 14,0
 
A

andro-eddi

Fortgeschrittenes Mitglied
Threadstarter
@Papandroid:

habe jetzt mal anderen USB-Port *und* anderes Kabel genommen und das Pad im APX-Modus angesteckt und siehe da: bei der üblichen Suche nach einem passenden Treiber wurde nun einer gefunden und installiert (irgendwas mit NVIDIA recovery - war leider zu schnell wieder weg) und es kam die Meldung, dass das Gerät verwendet werden kann.

Aber was nun? Im Explorer oder unter Computer oder im Gerätemanager sehe ich keine neuen Laufwerke.
:huh:

Edit: beim Auswerfen konnte ich es nun lesen, installiert wurde der "NVIDIA USB-Boot recovery Treiber"
 
Zuletzt bearbeitet:
A

andro-eddi

Fortgeschrittenes Mitglied
Threadstarter
Das System-Rom sollte ja größer sein
bei mir: 259 / 1,97 / 14,0
Ja und nun...?
Bei mir läufts wie gesagt auch so.
Oder gibt es irgendwelche kritischen Applikationen, die den größeren Speicher brauchen? Eigentlich hätte das ROM ja dann gar nicht draufpassen dürfen, oder?
 
P

Papandroid

Neues Mitglied
Prima, das ist OK, dass Du "nichts" siehst. Ist so richtig.
Dieser Modus ist auch nicht dazu gedacht, "normale" USB-Datenaktionen wie bei USB-Sticks oder USB-Festplatten über den Explorer durchzuführen.

In diesem Modus müsstest Du ab Punkt 3. der Beschreibung "Partitionierung des Hannspad" fortfahren.
D. h. ab Spiegelstrich 3 - "entpacke das heruntergelandene Backup....".
Wenn Du dann im nächsten Schritt die "hann_guide.bat" startest, macht die alles Nötige selbst.

Ich vermute, Du musst dann den kompletten Prozess bis zum Ende durchführen (also 4.Rooten und 5.RomInstallation). Würde ich ohnehin machen, um mögliche Fehler auszuschließen.
 
P

Papandroid

Neues Mitglied
Ja und nun...?
Bei mir läufts wie gesagt auch so.
Oder gibt es irgendwelche kritischen Applikationen, die den größeren Speicher brauchen? Eigentlich hätte das ROM ja dann gar nicht draufpassen dürfen, oder?
Das kann ich Dir auch nicht beantworten. Im Zweifelsfall einfach mal laufen lassen, geht ja nichts kaputt.
Allerdings musst Du im Hinterkopf halten, dass das System vielleicht irgendwann einfach hängen bleibt und Du alles neu machen musst.
Das ist kein Problem, man muss sich nur vorher immer seine Daten so sichern, dass man sie für diesen Fall dann noch griffbereit hat und man alles wieder herstellen kann.
 
A

andro-eddi

Fortgeschrittenes Mitglied
Threadstarter
Alles klar, danke erst mal. Ich werde es zunächst einmal so laufen lassen. Falls sich der eine oder andere dafür interessiert, warum es bei mir funtioniert, obwohl doch angeblich diese Partitionierung Voraussetzung sein soll, bin ich gerne bereit, noch irgendwelche Dinge nachzusehen.

Kann ich denn irgendwie feststellen, ob der APX-Modus tatsächlich mit der PC-Verbindung funktioniert, ohne deswegen gleich das Partitionierungsskript drauf loszulassen?

Grüße
 
M

mikaole

Gast
Das Rom funktioniert auch bei kleiner Partition, aber sobald noch eine etwas größere System App dazu kommt, wird das Rom entweder extrem langsam, oder geht garnicht mehr. Würde an deiner Stelle die Partition anpassen.
 
red-orb

red-orb

Lexikon
wenn du im APX-Modus bist und du dein Pad mit dem PC verbindest sollte der Ton USB-gerät verbunden kommen.
Und im Gerätemanager sollst du dann ein Nvidia gerät oder ein APX Gerät haben

Gesendet vom ACE
 
P

Papandroid

Neues Mitglied
kannst natürlich auch einfach mal ein Nvflash-Backup (nur Backup) machen um die Funktion zu testen...

siehe unter (wie setzt man da jetzt schnell den Link ins Forum :huh:) /RootHackingModding/Anleitungen/NVFlashBackup..
 
A

andro-eddi

Fortgeschrittenes Mitglied
Threadstarter
Danke euch. Der Ton für USB-Gerät kommt und das NV-Flash Backup funktioniert auch!

Also werde ich bei Gelegenheit auch mal die Neupartitionierung durchführen.

:cool2:
 
Oben Unten