[brick] Kein System, kein Recovery. Und jetzt?

  • 4 Antworten
  • Neuester Beitrag
Diskutiere [brick] Kein System, kein Recovery. Und jetzt? im Root / Hacking / Modding für HTC Desire Z im Bereich HTC Desire Z Forum.
A

Arrakaij

Neues Mitglied
Hallo,

ich habe hier ein Desire Z (von O2), das ich auf den Werkszustand zurücksetzen wollte zwecks Displayschaden. (Vorher: Andromadus Mimicry)

Das hat nach Anleitung bis zu dem Punkt gut funktioniert, bis ich das Orginal hboot draufgeflasht habe. Nach dem Neustart geht jetzt fast gar nichts mehr:

- Ins System komme ich nicht. Da kommt nur das HTC-Logo, bis der Akku leer ist
- Ins Recovery komme ich auch nicht. Auch nur das HTC-Logo

Ich habe damit nur einen VISION PVT SHIP S-OFF bootloader mit fastboot und dem RUU-Updater, den man mit "fastboot oem rebootRUU" bekommt.

So richtig viel machen kann ich damit aber auch nicht:

- via fastboot oem rebootRUU und dann die original RUU[...].exe starten sagt mir nur, daß das Handy nicht gefunden worden ist und bricht ab.
- Wenn ich die rom.zip aus der RUU per hand flashen möchte, kommt "02 data length is too large"
- Wenn ich irgendein backup flashen möchte (zum beispiel das des alten Bootloaders) kommt ein "not allowed"
- zips auf der SD-Card werden zwar gelesen, nach "parsing..." kommt aber nur wieder das Startmenü

Jetzt weiß ich auch nicht mehr weiter. Prinzipiell würde es mir reichen, den Bootloader wieder auf S-ON zu schalten. Dazu braucht man meines Wissens aber adb, und das wiederum braucht ein System.

Aber vielleicht habt ihr eine Idee?
 
A

appel11

Neues Mitglied
A

Arrakaij

Neues Mitglied
Na, immerhin ein Fortschritt

Von der SD-Karte hat er dieses Archiv nicht genommen. Leider war das Bild zu schnell weg, um es zu lesen.

nach fastboot oem rebootRUU konnte ich es aber manuell aufs Handy schicken.
Dort kam zwar ein Fehler, aber ich denke, daß der Download einfach eine Macke hatte. Muss ich also noch einmal laden (dauert nur ne Weile)

Code:
>>>fastboot.exe flash zip ..\1.34.405.5_PC10IMG.zip
< waiting for device >
sending 'zip' (158438 KB)...
OKAY [ 25.598s]
writing 'zip'...
(bootloader) zip header checking...
(bootloader) shift signature_size for header checking...
FAILED (remote: 32 header error)
finished. total time: 34.721s
Man sieht ja, das ding ist zu klein. (Komischerweise zeigt mein Betriebssystem eine ganz andere Größe an > unterbrochener Download wohl.
Aber auf jeden Fall danke, das hilft mir zumindest etwas weiter


~~~~~~~~~~~~~~

Habe jetzt das komplette Image.
Beim Laden von SD-Card kommt "Lack of Heap"
Beim Laden via fastboot kommt "02 data length is too large"

Anscheinend ist das image zu groß? kann man das irgendwie aufteilen?
Denn die fehlerhafte 150MB Variante, die ich vorher hatte, schien beim laden ganz gut zu funktionieren



Noch ein Edit: Mittels einem zip-programm, das deflate konnte, habe ich das image in mehrere Teile teilen können (Rest - System.img)
Dann gings. Habe die zips nacheinnander per fastboot geschickt und habe jetzt ersteinmal ein system.
Damit kann ich cid ändern und s-on schalten.

Danke appel für den denkanstoss
 
Zuletzt bearbeitet:
A

Arrakaij

Neues Mitglied
Nun doch mal ein Doppelpost.

Hab CID und S-ON jetzt wiederhergestellt. Damit ist das Problem gelöst.
Danke nochmal an appel11
Leider sehe ich noch keinen danke-button, den ich benutzen kann. Ich hole das nach, wenn es soweit ist
 
A

appel11

Neues Mitglied
Nichts zu danke denn du hast ja letzt endlich eine Lösung selber gefunden.