SD-Card fehlerhaft und CM9 ROM (ICS 4.0.4 BCM RC4.1U2)

  • 8 Antworten
  • Neuester Beitrag
Diskutiere SD-Card fehlerhaft und CM9 ROM (ICS 4.0.4 BCM RC4.1U2) im Root / Hacking / Modding für Nexus One im Bereich Google Nexus One Forum.
J

juliusmod

Neues Mitglied
Hallo Spezialisten,
mein Update auf mein uralt N1 auf eine ROM Version 4.04 mit CM9 war erfolgreich, alles geht, bis auf die von mir bisher verwendete SD-Card kann jetzt vom System nicht mehr gelesen werden "SD Karte ist zerstört".
In den Foren habe ich verschiedene Hinweise auf die begrenzte Partition auf 1GB und die notwendige ext4 Formatierung gelesen, so habe ich meine 2GB Card in 3 Partionions mit 1, und je 2 * 0,5GB aufgeteilt.
Ergebnis : Card bringt noch immer Fehler und kann auch nicht angesprochen werden. Der ROM Manager kann auf die SD-Card nicht zugreien, da dise nicht gemounted wurde...
Wie weiter ? Ich habe mich gedanklich etwas verrannt ...

Danke !

Update : ich hätte es nicht gedacht : meine SD Card wird nicht mehr vom N1 akzeotiert, obwohl sie in anderen Smartphones + PC gut funktioniert. Eine 16GB Card aus meinem Nokia funktioniert nun tadellos... hm
 
Zuletzt bearbeitet:
meckergecko

meckergecko

Stammgast
Verstehe nicht ganz: was genau für Partitionen hast du jetzt auf der Karte? Reihenfolge, Größe, Dateisysteme? Und wieso hast du 3 Partitionen? Du brauchst eine FAT32 und eine ext.
 
J

juliusmod

Neues Mitglied
ja, genau. Gute Frage. Ich dachte, wenn meine Karte nicht lesbar ist, liegt das am ROM... die neue 16GB Card kann jetzt gelesen werden ...
Die Funktion zur Auslagerung der Apps auf eine sd-ext habe ich dennoch nicht finden können - geht das nur über das Recovery-Menu und den Start des ROMs, oder geht das auch nachträglich und wenn ja wie ?
 
meckergecko

meckergecko

Stammgast
juliusmod schrieb:
Auslagerung der Apps auf eine sd-ext habe ich dennoch nicht finden können - geht das nur über das Recovery-Menu und den Start des ROMs, oder geht das auch nachträglich und wenn ja wie ?
Das ist von Rom zu Rom unterschiedlich und sollte in der Beschreibung des Roms stehen. Normalerweise gibt es zwei Möglichkeiten: ein App2ext Skript per Recovery flashen oder eine App wie S2E benutzen. Gib mal nen Link zum Rom.
 
meckergecko

meckergecko

Stammgast
Da ich nicht genau weiß, wo in der GUI die Konfiguration zu finden ist, würde ich vorschlagen, du probierst mal folgendes:

You can use the commad "m2sd <command> <value>" to alter configurations from the shell. Use "m2sd help" to get all available options.
Mein N1 hat mittlerweile meine kleine Schwester, aber wenn du mir die Ausgabe von "m2sd help" postest, kann ich zumindest versuchen, dir zu helfen.
 
r-zwo_d-zwo

r-zwo_d-zwo

Erfahrenes Mitglied
Wie hast du die Karte partitioniert? Über recovery oder über Tools wie gparted?
Kürzlich hatte ich meine Karte mit gparted partitioniert. Hat das System nicht akzeptiert, also habe ich über recovery (ext4) partitioniert. Ging dann.
Wobei ich auch schon gehört habe, daß cwm auch nicht ganz fehlerfrei partitioniert..
 
J

juliusmod

Neues Mitglied
ich habe das mittels PARAGON (free Version) auf ext4 partitioniert und formatiert... daran kann es nicht liegen. Die Karte ist für das N1 wirklich nicht erkennbar, auf dem PC ist diese aber lesbar. Ein Tets mit einer anderen 16GB Karte war positiv, so dass ich die Schmerzen erst mal los bin.
Danke !

Der ursprüngliche Beitrag von 23:14 Uhr wurde um 23:17 Uhr ergänzt:

meckergecko schrieb:
Da ich nicht genau weiß, wo in der GUI die Konfiguration zu finden ist, würde ich vorschlagen, du probierst mal folgendes:



Mein N1 hat mittlerweile meine kleine Schwester, aber wenn du mir die Ausgabe von "m2sd help" postest, kann ich zumindest versuchen, dir zu helfen.
Ja, ich denke, das ist mein Problem, ich habe es über das Terminal nicht hinbekommen, "m2sd command not found" jetzt fehlt mir der Hinweis, wo und wie ich m2sd eingeben kann... *peinlich*

Danke !
 
meckergecko

meckergecko

Stammgast
juliusmod schrieb:
ich habe das mittels PARAGON (free Version) auf ext4 partitioniert und formatiert... daran kann es nicht liegen.
Wie kommst du zu diesem Schluß?

Wenn der Befehl m2sd auf dem Handy nicht funktioniert, ist das entsprechende Skript nicht installiert und du musst es via Recovery flashen. Hätte ich aus der Rom Beschreibung anders verstanden, aber ist dann wohl so.