G1 Radio flashen geht nicht - kein Brick!?

  • 8 Antworten
  • Neuester Beitrag
Diskutiere G1 Radio flashen geht nicht - kein Brick!? im Root / Hacking / Modding für T-Mobile G1 im Bereich T-Mobile G1 Forum.
L

lucky47

Neues Mitglied
Hallo,

jetzt brauche ich doch mal Hilfe.
Habe alles versucht, was sich in den Unterforen finden laesst.
Mein G1 ist beratungsresistent: Radio flashen geht nicht!
Beim OTA Update vor 2,5 Jahren hat es das Radio nicht hochgezogen.
Ich habe immer noch 1.22.12.29 drauf.
Damit immer Probleme bei Netz und Bluetooth.
Historie:
1.6 war drauf, mit Androot und Rommanager alles ausprobiert.
Ich hatte auch schon ein anderes ROM drauf(update-cm-4.2.15.1-signedw.ar.x10theme), lief aber nicht stabil (jetzt ist es weg, geht auch nicht wieder).
Inzwischen bin ich 2-3mal über Stock 1.0 wieder zurueck und habe jetzt Recovery-RA-dream-1.7.0 und HSPL10.95.3000 (mit fastboot) drauf.

Radio flashen wird zwar durchgefuehrt, nach dem Reboot bleibt aber das alte Radio drin. SPL habe ich deshalb noch weggelassen.
Flash radio über fastboot sagt: Partition existiert nicht.

Bin mit Anleitungen und Latein am Ende - will aber kein neues Handy !

Kann da bitte jemand helfen?

lucky47

DREA110 PVT 32B - HSPL10.95.3000 - CPLD-4 - RADIO-1.22.12.29
Recovery RA-dream-1.7.0
ROM starten bleibt beim Boot-Splash hängen - immer.
 
Zuletzt bearbeitet:
L

lucky47

Neues Mitglied
Hallo,

tatsächlich niemand noch eine Idee für mich?
Oder bin ich doch im falschen Thread? - Dann bitte verschieben.- Danke.

lucky47
 
Sharks

Sharks

Fortgeschrittenes Mitglied
Hi.
Wollte fragen,ob es geschafft hast?
Ich könnte mir das Gerät anschauen,musst du aber mir zusenden oder persönlich in Herne/NRW vorbeikommen,wenn interessiert kontaktiere mich per PN oder Email.
MfG!Sharks
 
L

lucky47

Neues Mitglied
Nein, habe ich noch nicht geschafft. Zur Zeit geht nur Bootmenu und Recovery.
Ich will am WE noch mal komplett mit Stock 1.0 anfangen.
Dann sehe ich, ob es überhaupt noch tut.

Danke erstmal für das Feedback.

lucky47

Edit: Hatte heute schon Zeit: Stock1.0 und Recovery 1.7.0 wieder drauf. Immer noch altes Radio 1.22.12.29.
 
Zuletzt bearbeitet:
D

DiSa

Stammgast
Diese Situation hatten wir vor ca. 2,5 Jahren schon einmal ... ;-)

Mit dem HardSPL ist es nicht möglich mit fastboot ein radio image zu flashen (https://www.android-hilfe.de/forum/...ge-zum-radio-dangerspl.44673.html#post-570243), ob das auch Auswirkungen auf das Flashen per Recovery hat, kann ich jetzt nicht sagen. Ich würde zunächst versuchen, den Bootloader auf 1.33.2003 upzudaten (sollte per fastboot flash funktionieren) und dann das neue radio image ebenfalls per fastboot flashen.
 
L

lucky47

Neues Mitglied
Hallo,
die Variante fastboot habe ich auch probiert, da bringt das G1 "partition existiert nicht".
Allerdings hatte ich gestern das erste Mal richtigen adb-Zugang. Vielleicht war auch dort der Fehler.
Ich habe verschiedene Update-dateien gezogen, um von 1.0 auf 1.5 zu kommen, die wurden bisher abgelehnt (Verifizierung fehlgeschlagen). Habe gehofft, in dem update ist das Radio mit drin.
Per Recovery das Radio zu Flaschen schlägt fehl. Es tut so, als ob es alles macht, hat aber nach dem booten das alte noch drauf.

Wenn ich erst den SPL flashe und dann das Radio ist aber die Brick-gefahr größer, oder? Falls das Radio wieder versagt.

Habe auch schon nach Möglichkeiten gesucht, Radio per Telnet zu flashen, scheint es aber nicht zu geben, oder ich bin dafür nicht schlau genug.
Für JTag usw. reicht mein Wissen nicht.

lucky47

edit: Den Thread kenne ich, habe aber keine Lösung gefunden.
 
Zuletzt bearbeitet:
D

DiSa

Stammgast
Die SPLs 10.95.3000 und 1.33.2003 sind kompatibel und laufen beide mit dem 1.x Radio-Image, das Du aktuell noch installiert hast. Mit

fastboot flash bootloader <spl1_33_2003.img>

kannst Du auf den anderen Bootloader wechseln. Die Brickgefahr hält sich in Grenzen, aber da beim Flashen immer etwas schief gehen kann, lässt sie sich nicht ganz ausschließen. Mit

fastboot reboot bootloader

kannst Du dann den neuen Bootloader starten und mit

fastboot flash radio <radio_2_22_xxx.img>

dann das neue / passende Radio-Image flashen.

Gesendet von meinem Nexus 7 mit der Android-Hilfe.de App
 
L

lucky47

Neues Mitglied
Ja, Ja, Ja,..
genau das war es. Suuuuper, ich freue mich ja so.
Es hat geklappt.
Überall stand, dass man erst das Radio flashen soll, um den Brick zu verhindern
Die 1.33.2003 musste ich zwar über das Recovery flashen, aber egal.
Jetzt habe ich ein neues Radio!

lucky47
PS: Ich suche noch den Danke-Button - aber mehrmals drücken geht leider meist nicht. - Sorry - habe erst 6 Beiträge (wird nachgeholt)
 
Zuletzt bearbeitet:
D

DiSa

Stammgast
Herzlichen Glückwunsch! Ich freue mich, dass ich Dir helfen konnte. Viel Glück weiterhin mit Deinem G1.

P.S.: dass alle immer sagen, dass man zunächst das 2.x-Radio flashen soll, liegt daran, dass es Inkompatibilitäten zwischen SPL und Radio gibt, die unter Umständen zum Brick führen können. Man muss deshalb schon genau wissen, welcher SPL mit welchem Radio kompatibel ist. Die meisten gehen dann auf Nummer sicher und schalten vor, zunächst das Radio upzudaten.

Gesendet von meinem Nexus 7 mit der Android-Hilfe.de App