1. Hast Du Lust, bei uns mitzuarbeiten und das AH-Team zu verstärken? Alle Details zu dieser aktuellen Herausforderung findest Du hier.
  1. thrown-out, 14.06.2011 #1
    thrown-out

    thrown-out Threadstarter Neuer Benutzer

    hi.

    meine kamera funktioniert leider nicht mehr.
    direkt nach dem start der app schmierte sie ab.

    im log finde ich "probe of msm_camera_mt9t013.0 failed with error -5"
    der ordner /dev/msm_camera existiert nicht...
    (genaue logs habe ich leider nicht mehr)

    nun versuchte ich:
    - fix_permissions
    - wipe
    - neuinstall (direkt update von CM6 auf 6.1) per rom manager

    ergebnis: app crasht jetzt nicht mehr direkt beim starten, stattdessen schwarzer screen und nach ner weile dann "Aktivität Kamera (in Anwendung Kamera) reagiert nicht" mit schließen erzwingen/warten.

    Logs hierzu:

    Code:
    I/ActivityManager(  170): Starting activity: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=com.android.camera/.Camera }
    I/ActivityManager(  170): Start proc com.android.camera for activity com.android.camera/.Camera: pid=1971 uid=10011 gids={1006, 1015}
    W/ActivityManager(  170): Launch timeout has expired, giving up wake lock!
    W/ActivityManager(  170): Activity idle timeout for HistoryRecord{43f89978 com.android.camera/.Camera}

    Infos:
    HTC Dream (QWERTY)
    v2.2.1
    Baseband 62.50S.20.17U_2-22-19.26I
    Kernel 2.6.35.9-cyanogenmod
    CyanogenMod-6.1.0-DS
    Build FRG83

    für ideen zur lösung wäre ich sehr dankbar.

    sollten weitere infos benötigt werden, einfach fragen.


    mfg
    simon
     
  2. winne, 14.06.2011 #2
    winne

    winne Android-Guru

    Fullwipe und neu flashen (eventuell auch 2x) ist wohl angesagt. Wenn es danach immernoch nicht geht, solltest du mal nen anderes ROM versuchen.
     
  3. thrown-out, 14.06.2011 #3
    thrown-out

    thrown-out Threadstarter Neuer Benutzer

    danke winne.

    ich befürchte, es ist ein hardwareproblem :(

    hab verschiedene roms versucht, bin sogar runter auf die original 1.0 und 1.5 - leider ohne erfolg.

    hab jetzt wieder die 2.2 (CM6.1) drauf.
    logcat sagt:

    Code:
    I/ActivityManager(  173): Start proc com.android.camera for broadcast com.android.camera/.CameraButtonIntentReceiver: pid=527 uid=10009 gids={1006, 1015}
    E/QualcommCameraHardware(  128): startCamera X: /dev/msm_camera/control0 open failed: No such file or directory!
    E/QualcommCameraHardware(  128): createInstance: startCamera failed!
    W/ActivityManager(  173): Timeout of broadcast BroadcastRecord{43e2c5e8 android.intent.action.CAMERA_BUTTON} - receiver=android.os.BinderProxy@43f1eeb0
    noch ideen, außer verschrotten? :)


    edit: hab die kiste jetzt mal auseinandergenommen...
    die kamera hat wohl mal feuchtigkeit abbekommen, sieht nicht gut aus :(
    jemand ne idee, wo man das kameramodul her bekommt?
     
    Zuletzt bearbeitet: 14.06.2011
  4. thrown-out, 09.10.2011 #4
    thrown-out

    thrown-out Threadstarter Neuer Benutzer

    inzwischen ist das ersatzteil aus china da und eingebaut.
    kamera funktioniert wieder.

    ist aber wohl kein originalmodul, quali ist mist, kamera hat nen schatten...
    egal, werde mir demnächst wohl das nexus prime holen :)
     
Du betrachtest das Thema "Kamera funktioniert nicht mehr" im Forum "Root / Hacking / Modding für T-Mobile G1",