1. Hast Du Lust, bei uns mitzuarbeiten und das AH-Team zu verstärken? Alle Details zu dieser aktuellen Herausforderung findest Du hier.
  1. da.russe, 06.11.2010 #1
    da.russe

    da.russe Threadstarter Android-Hilfe.de Mitglied

    Hi,

    ich hab diverse Roms ausprobiert (SuperFroyo, CM5, CM6, SuperE, Pirate Rum...) und bei allen habe ich das Problem dass die Kamera nicht funktioniert. Sobald ich die App aufrufe, kommt die Meldung "Es tut uns leid!...".
    Ich habe Backups aufgespielt, die App mit Titanium wiederhergestellt, die App neuinstalliert, verschiedene Launcher ausprobiert, fix permission ausgeführt, aber nichts war erfolgreich.
    Das Problem trat von jetzt auf nachher auf (vor ein paar Tagen), ohne das ich bewusst was gemacht habe.

    Das gleiche Problem habe ich auch mit der Superuser app.

    Im moment habe ich die Pirate Rum drauf, mit Recovery Version: RA-D1.7.0 und Radio Version: 2.22.23.02

    Jemand eine Idee was ich noch versuchen könnte?
    Danke im Vorraus!
     
  2. magnummandel, 06.11.2010 #2
    magnummandel

    magnummandel Android-Experte

    Ist zwar ne Standardfrage, aber hast du vor den Flashes jeweils full gewiped?
     
  3. da.russe, 06.11.2010 #3
    da.russe

    da.russe Threadstarter Android-Hilfe.de Mitglied

    ja, immer alles gewiped!
     
  4. norbert, 06.11.2010 #4
    norbert

    norbert Ehrenmitglied

    Nutzt du Swap, A2ext oder ähnliches? Vielleicht mal die Speicherkarte tauschen, je nach Alter und Nutzung kann auch hier die Ursache liegen. Oder mal ein Rom nutzen, daß sicher auch ohne SD auskommt (CM4.x)
     
  5. da.russe, 06.11.2010 #5
    da.russe

    da.russe Threadstarter Android-Hilfe.de Mitglied

    Swap nutze ich nicht, zumindest bei Pirate Rum. A2ext nutze ich bei manchen Apps, aber die Kamera app liegt ja nicht auf der SD Karte oder?
    Die Speicherkarte selbst ist maximal 3 Monate alt.
    Ich werde mal eine ältere Rom testen.
     
  6. norbert, 06.11.2010 #6
    norbert

    norbert Ehrenmitglied

    Ich würde empfehlen, das Gerät komplett zu löschen (Fastboot!).

    Wenn das alles nichts hilft, wird's interessant ;)
     
  7. da.russe, 06.11.2010 #7
    da.russe

    da.russe Threadstarter Android-Hilfe.de Mitglied

    Wie genau läuft das ab?
    Wie lautet der Befehl für Fastboot?
    Und wenn ich das gemacht habe, was sind dann meine nächsten Schritte? Radio und SPL neu drauf machen und dann Rom flashen, bzw. vorher Recovery neu drauf machen?
    Oder wird dadurch nur die Rom gelöscht?
    Und wie sieht es mit dem Inhalt der SD-Karte aus, bleibt dieser erhalten?

    Ich frag nur so ausführlich, weil ich davon zum ersten mal hör ;)
     
  8. norbert, 06.11.2010 #8
    norbert

    norbert Ehrenmitglied

    Fastboot: Einschalten mit gedrückter Kamera-Taste, danach muss man glaub ich die USB-Verbindung noch aktivieren (lesen was am Bildschirm steht!)

    befehl am pc eingeben:
    fastboot devices (-> sollte dir anzeigen, wenn ein Gerät gefunden wird, sonst geht es nicht)
    fastboot erase system -w

    dadurch wird ein ordentlicher "Full Wipe" ausgeführt. Recovery und SPL bleiben davon unberührt.

    Danach einfach Rom neu einspielen - nachdenken ob eventuell der MTD-Patch von Firerat mal verwendet wurde, dann ist vielleicht der Boot-Patch auch erforderlich!

    Ansonsten gibt es zu Fastboot ein oder zwei Threads hier im Forum ;)
     
    da.russe gefällt das.
  9. magnummandel, 06.11.2010 #9
    magnummandel

    magnummandel Android-Experte

    Du schreibst, du hast Backups zurück gespielt. Hast du die Kamera mal vor dem zurückspielen getestet?

    Für fastboot musst du zunächst mal das android SDK und die passenden Treiber für dein Telefon auf deinem PC installieren. Dann das Gerät mit gleichzeitig gedrückter "back" und Einschalttaste starten. Du siehst dann einen Bildschirm mit 3 Androids am unteren Bildschirmrand. Jetzt das Telefon mit dem PC verbinden. Am PC kannst du dann das Kommando
    Code:
    fastboot erase system -w
    eingeben (im tools-Ordner des SDK). Wenn der Vorgang fertig ist, das Telefon mit der Menü-Taste neustarten und ins Recovery booten. Da dann nur das ROM neu flashen.

    Das sollte erstmal reichen. Man könnte auch noch Recovery und SPL löschen (aber zumindest Recovery scheint ja zu funktionieren) aber ich würde es erstmal so probieren. Alles andere kann man dann noch machen wenns nix bringt. Denn der Vorgang hier ist relativ ungefährlich.
     
    da.russe gefällt das.
  10. magnummandel, 06.11.2010 #10
    magnummandel

    magnummandel Android-Experte

    verdammt, norbert war den berühmten Bruchteil einer Sekunde schneller xD
     
  11. norbert, 06.11.2010 #11
    norbert

    norbert Ehrenmitglied

    Jetzt ist aber die Frage, ob man in den Fastboot mit Kamera-Taste (wie ich meinte) oder mit der Zurück-Taste (wie du meintest) kommt?
    Ich kanns ehrlich im Moment nicht sagen, und Reboot geht derzeit nicht, stelle gerade einen neuen Laufzeitrekord am G1 auf ;)

    Und schneller war ich nur, weil ich einfach schneller tippe als du :p
     
  12. magnummandel, 06.11.2010 #12
    magnummandel

    magnummandel Android-Experte

    also mit zurück gehts auf jeden Fall, heute noch BiffMod 2.1 geflasht und vorher per fastboot gewiped. Aber ich hatte auch schonmal was von der Kamerataste gehört. Geht am Ende beides? ;)
     
  13. norbert, 06.11.2010 #13
    norbert

    norbert Ehrenmitglied

    kann leicht sein, daß beides Möglich ist. Ich bild mir stark ein, beim letzten mal die Kamerataste genutzt zu haben, weil die Zurück ja ziemlich ungünstig liegt so knapp neben der Power-Taste :)

    Aber jetzt werden wir schon ein wenig OT ;)
     
  14. Denowa, 06.11.2010 #14
    Denowa

    Denowa Android-Guru

    In den Fastboot Mode bootet man mit gedrückter Kamerataste
    und muss dann die Zurück Taste drücken um den Fastboot Mode
    zu starten.

    Danach:

    Code:
    #fastboot erase recovery
    
    #fastboot flash recovery reovery.img
    
    #fastboot oem powerdown
     
    da.russe gefällt das.
  15. da.russe, 06.11.2010 #15
    da.russe

    da.russe Threadstarter Android-Hilfe.de Mitglied

    Morgen,

    vielen Dank für die Hilfe! Es hat Wirkung gezeigt. Ich hab das Wipe über fastboot gemacht, die Rom neu eingespielt und die Kamera funktioniert! Da werde ich wohl alles noch einmal einrichten müssen, denn wenn ich das Backup nach dem Wipe über Fastboot einspiele, funktioniert sie weiterhin nicht. Wobei ich mir echt sicher bin, dass sie vorher funktioniert hat. Ich habe ja Fotos gemacht...

    Die Superuser App funktioniert allerdings weiterhin nicht.

    Vielen Dank!
     
  16. magnummandel, 06.11.2010 #16
    magnummandel

    magnummandel Android-Experte

    gerade getestet: Kamerataste habe ich nicht gebraucht. back und anschalten halten, führt direkt in den fastboot.
     
  17. Denowa, 06.11.2010 #17
    Denowa

    Denowa Android-Guru

    Wow ... was dazu gelernt! :w00t00:

    Du/ Ihr habt Recht!

    Back + Power führt direkt in den Fastboot Mode.

    Mit Kamera Taste geht es aber auch, man muss
    nur zusätzlich später die Back Taste betätigen. :cool2:

    Kamera + Power ist eigentlich zum flashen eines
    NBH Images gedacht ...
     
  18. da.russe, 06.11.2010 #18
    da.russe

    da.russe Threadstarter Android-Hilfe.de Mitglied

    ja es funktioniert beides. ich mach es immer mit der Kamera+Power.
    Habt ihr vielleicht auch ne Idee wegen der Superuser App?
     
  19. Denowa, 06.11.2010 #19
    Denowa

    Denowa Android-Guru

    Wenn Du zw. durch mal die MTD Patches benutzt hast, oder ROMs
    die die schon integriert hatten, empfehle ich Dir dringend, per Fastboot,
    das Recovery zu löschen und neu zu flashen. Danach das ROM komplett
    neu aufsetzen.
     
  20. da.russe, 07.11.2010 #20
    da.russe

    da.russe Threadstarter Android-Hilfe.de Mitglied

    Hi,

    die Freude war nur von kurzer dauer. Die Kamera hat sich wieder verabschiedet. Habe nocheinmal alles durchgetestet, nichts hat geholfen.
    Hab die SD-Karte formatiert, Partitionen neu erstellt, über fastboot einen Wipe gemacht, und dann jeweils verschiedene Roms aufgespielt (vorher jedesmal gewiped), kein Erfolg :(
    Habe auch das Recovery neu geflashed, hat aber nichts gebracht.

    Kann ich noch etwas versuchen? Oder ist dass dann ziemlich sicher ein Hardwaredefekt (was blöd wäre, weil ich das G1 gebraucht bei ebay gekauft habe und annehme, es ist schon älter als 2 Jahre -> keine Garantie)


    p.s. DetWAR, ich hoffe du hast nichts dagegen, das ich meine Signatur an deine angelehnt habe ;)
     
    Zuletzt bearbeitet: 07.11.2010

Users found this page by searching for:

  1. lifetab p9516 kamera funktioniert nicht

Du betrachtest das Thema "Kamera funktioniert nicht mehr" im Forum "Root / Hacking / Modding für T-Mobile G1",