Sailfish auf XA2 ultra (H3213) aufgespielt - wie zurück ...?

  • 7 Antworten
  • Neuester Beitrag
Diskutiere Sailfish auf XA2 ultra (H3213) aufgespielt - wie zurück ...? im Sony Xperia XA2 / XA2 Ultra Forum im Bereich Sony Forum.
S

Salorius

Neues Mitglied
Hallo und guten Tag,
da habe ich mir (als Laie) doch tatsächlich Sailfish 3.0 auf mein XA2 aufgespielt. Nun bin ich aber mit dem Programm unzufrieden und wollte wieder auf die ursprünglich SONY xperia Software zurück. Das stellt sich für mich als in Android nicht ganz so geübter User als quasi unüberwindlich dar.

Was ich probiert habe:
1. Das SONY Tool Emma runtergeladen, leider findet Emma jedoch das Telefon nicht (bin im Datenmodus)
2. Den xperia companion benutzt, der hört mittendrin auf und sagt, ich möge auf dem Telefon weitermachen - da passiert aber nichts.

Wie es sich mir darstellt (ich mag falsch liegen) sollte ich zuerst ein neues Android aufspielen, Version 8 oder 9 ?
Dann wohl ein Binary von Sony holen

Leider weiss ich nicht, wie ich an das Telefon herankomme ... und welche Flashsoftware dann sinnvoll ist ?
Für ein paar Tips wäre ich sehr verbunden. Herzlichen Dank
 
MysticEnforcer

MysticEnforcer

Experte
Moin,
1. Led leuchtet grün?
Alle Treiber fürs XA2 installiert?
2. PC Companion kann mit offenem Bootloader zur Reparatur/Installieren der Firmware nicht mehr verwendet werden.

Wenn du ein 64bit System hast, könntest du das Flashtool von hier probieren:
www.flashtool.net
Anleitungen für das Flashtool findest du auch zu genüge hier im Forum
 
Zuletzt bearbeitet:
D

droidentocho

Neues Mitglied
Ich klinke mich hier mal ein.
Auch bei mir liegt ein verstaubtes XA2 auf dem ich SF ausprobierte.
Nun möchte ich schon seit längerem zurück zu Lineage OS.
Es scheitert seit ca. einem halben Jahr daran das das Sony am PC im Fastboot/Flash Mode vom PC nicht mehr erkannt wird.
Ich habe mit den bestehenden Computern und genau diesem XA2 bisher diverse Systeme wie Lineage oder SF ausprobiert.
Immer funktionierte es nach der korrekten Installation der Sony Treiber.
Ich kann das Handy auch dazu bringen blau oder grün zu leuchten, nur der PC meldet immer Fehlercode 10 beim Treiber.
Probiert... 3 verschiedene PC's 3, verschiedene Kabel (auch das org.), verschiedene USB Ports...
Gibt viel Literatur zu der Problematik, aber nichts half bisher.
Vielleicht hat ja noch einer ne Idee ;)
Ach ja hats beim Threadstarter geklappt?
 
S

Salorius

Neues Mitglied
Hallo Droide,
nein, leider liegt das Phone in der Schublade ganz hinten. Ich warte, das mir mal ein Nerd über den Weg läuft - der bekommt dann 50,--Euro, falls er das Teil wieder hinbringt ...
 
M

mx82

Neues Mitglied
Hmmm, ich hatte auch überlegt mal Sailfish zu testen.
Im XDA-Forum steht aber absolut nix von Eurem beider Problem.
Habt Ihr schon mal versucht das XA2 über Linux zu flashen? Vielleicht ist ja der Sony Treiber das Problem.
Auf meinem Ubuntu konnte ich fastboot einwandfrei nutzen, spezielle Anpassungen für Sony Geräte waren nicht nötig(komischerweise hat das Unlocking anfang nicht geklappt).

Holt Euch doch mal ein ubuntu image, installiert es auf einem USB Stick, bootet Linux und installiert schnell fastboot für einen kurzen Test.
 
D

droidentocho

Neues Mitglied
Habe ich in der Tat noch nicht getestet.
Bei mir läuft das aktuelle Fedora, ich werde es mir mal ansehen, danke.
 
D

droidentocho

Neues Mitglied
So ich habe mich nun mit Fastboot unter Fedora/Linux auseinandergesetzt.
Ich könnte mich in den Allerwertesten beissen, denn ich kämpfe seit Monaten mit dem Problem das ich mein XA2 nicht mehr flashen kann.
Ich bin mir nun ziemlich sicher es liegt an der Kombi Sony Treiber und aktuelles Windows 10 (2004).
Fastboot unter Fedora läuft bei vollkommen identischer HW.
Ich habe dann in meinem jugendlichen Leichtsinn eine 11er AOSP geflasht was zu einem Dauerbootloop führte.
Immerhin konnte ich es ausschalten (Vol-Up und Power) und wieder in den Fastboot Modus versetzen.
Denke es macht mal Sinn was Originales zu testen ;)
Vielleicht gibt es aber von SF auch keinen Weg zurück mehr.....
 
D

droidentocho

Neues Mitglied
Ich kann freudig Vollzug melden :)
Mein XA2 ist wieder mit einer Custom ROM Version einsatzbereit.
Die Versuche eine AOSP Version via fastboot einzuspielen waren gestern gescheitert.
Übrigens muß ich meine Aussage zu Windows 10 noch etwas erweitern.
Habe gestern eine Windows 7 Installation im VM durchgeführt. Alle Updates drauf und gleicher Fehler des Sony Treibers (Fehler 10).
Was Windows betrifft bin ich somit ratlos, das hatte alles mal funtioniert....(mit völlig identischer HW).
Dafür habe ich mich dann etwas ins Fedora Linux eingearbeitet und war angenehm überrascht.
Ich habe dann mit Fastboot das 3.4 TWRP aufgespielt, die ZIP mit der Custom ROM auf eine SD Karte (Dateien musste ich natürlich über ein anderes Handy kopieren da das XA2 ja nicht bootete). Dann mittels TWRP das Image geflasht.
Wenn man das nicht täglich macht muss man ordentlich Anleitungen im Netz wälzen, aber es hat gepasst.
Nun verwende ich:
[ROM][XA2][10.0] iodéOS = LineageOS 17.1 + MicroG + adblocker [02/12/2020]
Das SF das ich von seiner Ästhetik sehr geschätzt habe ist somit für mich Geschichte, es werden nie brauchbare nativ Apps dafür verfügbar sein.
Also ich betone... nicht aufgeben, irgendwie geht's immer :)
 
Ähnliche Themen - Sailfish auf XA2 ultra (H3213) aufgespielt - wie zurück ...? Antworten Datum
0