Treble Partition [4GB Stock/800MB Custom] für das Axon7 einrichten

  • 210 Antworten
  • Neuester Beitrag
Diskutiere Treble Partition [4GB Stock/800MB Custom] für das Axon7 einrichten im Treble und GSI's für ZTE Axon 7 im Bereich Root / Custom-ROMs / Modding für ZTE Axon 7.
wylot

wylot

Stammgast
Hille4711 schrieb:
installier dir LOS 15.1 drauf das erstellt Dir automatisch eine Vendor Partition
zwar aus einem anderen Speicher als nfound seine aber geht auch
Kann ich das direkt auf die AEX V. 5.5 ?
Oder muss ich zuerst den Bootstack B12 flashen und AEX 5.7?
Wenn ich den LOS 15.1 installiert habe : kann ich dann direkt auf AEX Treble ?
 
BaamAlex

BaamAlex

Ehrenmitglied
Der B12 Bootstack sollte schon vorhanden sein.
 
wylot

wylot

Stammgast
wylot schrieb:
Hille4711 schrieb:
installier dir LOS 15.1 drauf das erstellt Dir automatisch eine Vendor Partition
zwar aus einem anderen Speicher als nfound seine aber geht auch
Kann ich das direkt auf die AEX V. 5.5 ?
Oder muss ich zuerst den Bootstack B12 flashen und AEX 5.7?
Wenn ich den LOS 15.1 installiert habe : kann ich dann direkt auf AEX Treble ?
Feedback :

B12 Bootstack installiert, letzte AEX 5.7 (ohne Treble) installiert und startet. Magisk und Gaaps
TWRP 3.2.1-8 drauf und läuft :biggrin: (das schafft nur ein Android Experte :biggrin:)

Wie soll ich jetzt weiter vorgehen, damit ich die neuste Version mit Treble habe, und dass ich das nicht verkacke.
LOS 15.1 ??? Oder doch mit MiFlash probieren (hate Gestern keine verbindung) Edit : Heute auch nicht

Edit : Bevor ich weitermache :
Ich brauche Hilfe bei SD Karte. Zulezt habe ich sie im Paragan Partition Manager als ext4 formatiert. Sie wird auch im system als ext4 erkannt. Wenn ich jetzt dem TitaniumBackup sage, dass er die Backups dorthin schreiben soll, wird gezeigt, dass der Ort schreibgeschütz ist:cursing:. Wie kann ich den Schreibschutz entfernen.
Ich habe sie auch im Telefon formatiert, da kommt komisches "vtech" als format und die selbe geschichte.
 
Zuletzt bearbeitet:
BaamAlex

BaamAlex

Ehrenmitglied
Wenn du jetzt den B12 Bootstack installiert hast dann solltest du hier nach Anleitung vorgehen. Zuerst die Treble Twrp flashen. Und dann mit MiFlash weitermachen.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
wylot schrieb:
Ich habe sie auch im Telefon formatiert, da kommt komisches "vtech" als format und die selbe geschichte.
Dann ist sie nicht in ext4 formatiert. Ab in die Twrp und von dort aus formatieren.
 
H

Hille4711

Fortgeschrittenes Mitglied
wenn miflash nicht geht,dann geht auch nicht der Weg mit der Vendor Partition hier
such dir ein LOS 15 welches noch nicht Treble fähig ist und installiere dies ersteinmal,wenn das läuft dann das 10.8 welches Treblefähig ist und dann solltest du eine Treble Partiton haben und AEX 5.8 oder Havoc flashen können
 
BaamAlex

BaamAlex

Ehrenmitglied
Bei ihm war einfach das Problem dass der B12 Bootstack nicht installiert ist bzw war. Und das ist nun mal Voraussetzung alleine schon für neuere Releases.
 
H

Hille4711

Fortgeschrittenes Mitglied
Wie denn ohne Verbindung zu Miflash?
Schreibt er doch oben das miflash nicht geht ....
 
Sunny

Sunny

Urgestein
Dann wird es wohl an der MIflash Version liegen.
Da funktionieren nicht alle gleich gut.
Ich schau mal in meiner Gruschtelkiste....
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Also mit dieser hier im Anhang sollte es problemlos klappen.
Und wenn nicht, kann man die Vendor auch über das edl Tool flashen.
 

Anhänge

  • MiFlash20160401.zip
    26,5 MB Aufrufe: 51
wylot

wylot

Stammgast
Ich habe 5.8 Treble drauf :biggrin: AEX 5.8
Bin gerade dabei die dateien zu kopieren. Vendor habe ich noch vor ein Paar Tagen geflasht (als Miflash noch funktioniert hat), aber die alte TWRP hat es nicht gesehen. Nach dem ich Treble TWRP installiert habe, war die Partition sofort da.
Dann alle Anleitungen durch und ......
Android Experte hat`s geschafft :biggrin:
Spaß beiseite. Ohne EUCH wäre schon meine Wand kaputt und ich hätte Trouble mit meiner Frau, aber kein Treble.
Danke Euch vom Herzen.
 
Sunny

Sunny

Urgestein
@wylot
Freut mich sehr das es doch noch geklappt hat :)
Dann mach doch jetzt mal spaßeshalber einen Backup vom System in der TWRP und Pack das Backup am besten auf den PC.
 
wylot

wylot

Stammgast
Hab`schon 3
 
BaamAlex

BaamAlex

Ehrenmitglied
@Hille4711 weil du den B12 Bootstack ohne MiFlash sondern mit Twrp installierst.
 
H

Hille4711

Fortgeschrittenes Mitglied
Wir reden aneinander vorbei!
 
BaamAlex

BaamAlex

Ehrenmitglied
Nein. Machen wir nicht. Aber ist auch egal. Es läuft bei ihm und das ist die Hauptsache.
 
Carl52

Carl52

Erfahrenes Mitglied
Nachdem auf dem anderen A7 Lineage 16 halbwegs läuft, wollte ich auf dem andren A7 auf dem bisher FireHound_GSI lief auch Lineage 16 flashen, aber das wäre ja zu einfach. Geht nicht. Derzeitiger Stand: Ich kann die Vendor nicht einhängen um Project_Treble_v1.1_Axon7-by-NFound zu flashen.
Das Treble-Tool funktioniert auch nicht. Ich habe in Erinnerung, daß ich jede Abfrage mit Vol+ bestätigen mußte aber jetzt startet das tool mitten in den Abfragen neu in die TWRP. Könnt Ihr mir sagen was falsch läuft? Danke
 
H

haunted

Neues Mitglied
Hallo zusammen,

ich bin leider etwas verwirrt bzgl. der Bootloader-Versionen (und vllt. auch der sonstigen Versionen :confused2:) für das Axon 7 und Treble.

Mein Zeil ist es, mein A7 mit Treble zu versehen, auf die (hoffentlich) kommende LineageOS Version 15.1 von September zu gehen und anschließend, wenn der Test-Status verlassen wurde, auf LineageOS 16. Nun bin ich an dem Punkt angelangt an dem ich mich Frage wie ich dies am besten bewerkstellige:huh:.

Aktuell habe ich folgende Versionen:
- TWRP 3.2.2.0
- LinageOS 15.1 vom 25.06 (kein Treble)
- ZTE_A7LOSv1_UniversalBootStack
- A2017G_OreoModem

Reicht es nun aus, gemäß der Anleitung hier folgendes zu installieren:
- TWRP 3.2.1.8 TREBLE zu installieren
- Die Schritte aus dieser Anleitung ausführen
- Die neueste LineageOS 15.1 (Treble) aufspielen

Oder muss ich noch Bootloader/Modem/GApps/Sonstiges installieren?

Danke und Gruß

Haunted
 
BaamAlex

BaamAlex

Ehrenmitglied
haunted schrieb:
Reicht es nun aus, gemäß der Anleitung hier folgendes zu installieren:
- TWRP 3.2.1.8 TREBLE zu installieren
- Die Schritte aus dieser Anleitung ausführen
- Die neueste LineageOS 15.1 (Treble) aufspielen
Das hier reicht. Und du brauchst glaube ich noch den B12 Bootstack. Ansonsten mal warten was andere Nutzer der Rom sagen ob das Ding gebraucht wird oder nicht. Ich glaube aber allerdings doch. Und selbst wenn nicht ist es nicht schlimm da dann keine Rom einfach nicht installiert werden kann. Also wenn der falsche Bootloader/Bootstack installiert ist.
 
FlyingHorse

FlyingHorse

Stammgast
Schade finde ich das bei Treble nicht die Apps erhalten bleiben wenn man eine andere Costum Rom flasht.
Könnte man nicht etwas in Treble einarbeiten das die installierten apps erhalten bleiben, oder denke ich
da jetzt falsch.

Etid: zum Beispiel eine extra Partition nur für Apps wo dann das System zugriff darauf bekommt.
 
BaamAlex

BaamAlex

Ehrenmitglied
Nee das geht nicht. Aber wäre schon eine geile Idee da man sich nach der Neu-Einrichtung etwas an Zeit sparen kann. Ich denke mir aber allerdings dabei dass es sicherlich in Zukunft möglich sein wird.
 
FlyingHorse

FlyingHorse

Stammgast
Wäre echt gut wenn die Jungs aus der Costum Rom ecke das hinbekommen würden.
Wie schaut es den aus wenn ich eine Costum flashe und dann über TWRP Daten einspiele.
Funktionieren die Apps dann ohne Probleme oder muss der größte teil neu installiert werden.
Bis jetzt hab ich es selber nicht getestet sonder immer neu installiert und eingerichtet, dadurch habe ich teilweise die Lust am flashen verloren.
Weil das immer einen halben Tag dauert bis man fertig ist.