1. Rico65, 08.07.2011 #1
    Rico65

    Rico65 Threadstarter Neuer Benutzer

    Hallo an alle Defy Freunde,
    ich habe seit dem Update auf Froyo folgendes Problem, wenn ich über die original Kamera App ein Foto aufnehme wird der Breitengrad mit negativen Vorzeichen gespeichert! Will ich mir dann z.B. über Google Maps ansehen wo das Foto geschossen wurde wird mir eine Position im Südatlantik angezeigt!Bei älteren Aufnahmen vor dem Update ist dieser Effekt nicht! Bei Videoaufnahmen wird der Breitengrad korrekt als Positiver Wert gespeichert! Kann das jemand an seinen Defy nachvollziehen bzw. hat eine Lösung?
    Gruß Rico
     
  2. bitboy0, 08.07.2011 #2
    bitboy0

    bitboy0 Android-Guru

    Hast du mal die Einstellungen der Kamera gelöscht (anwendungsverwaltung) ?
    Nach dem Update gibt es da öfters mal Probleme und das nächste wäre dann wohl wipen wenn es dann immer noch nicht geht.

    gruß
     
  3. Rico65, 08.07.2011 #3
    Rico65

    Rico65 Threadstarter Neuer Benutzer

    Hallo Bitboy,
    den Cache der Kameraapp habe ich gelöscht, da ich auch das Problem der fehlenden Motivprogramme hatte!Das Wipen wollte ich mir erst mal noch verkneifen da ansonsten alles funktioniert!
    Gruß Rico
     
  4. mool, 08.07.2011 #4
    mool

    mool Erfahrener Benutzer

    hab ich und andere auch, schreibs mal in den froyo bug thread, vielleicht wirds dann mal auf die bugliste aufgenommen.

    allerdings wird das vorzeichen nicht im bild gespeichert, schaus dir mal am pc an, da passt alles - die gallery app scheint das minus einfach zu erfinden.
     
  5. Rico65, 10.07.2011 #5
    Rico65

    Rico65 Threadstarter Neuer Benutzer

    @Mool,

    ich bin mir nicht sicher ob Deine Theorie stimmt! Ich habe jetzt mal eine alternative Galerie App ausprobiert, mit dem gleichen Ergebnis! Wie hast Du auf dem PC die GPS Daten auslesen können? Bei mir wird unter Eigenschaften nicht allzu viel angezeigt! Das könnte aber auch am grünen Kameramodul liegen, das speichert definitiv weniger EXIF Daten als das rote Modul!

    Gruß Rico
     
  6. mool, 10.07.2011 #6
    mool

    mool Erfahrener Benutzer

    Ich schick die Fotos einfach zur dropbox oder per mail an einem PC
    da gibts genug exif reader die das anzeigen können.
    (z.b. Firefox oder Chrome extensions)
    wenn ich da auf "Karte" Klicke. bin ich genau da wo ich sein sollte.

    das die EXIF infos vom Kamera modul abhängen kann ich kaum
    glauben, vielleicht die Belichtungszeit etc, aber nicht die Daten vom GPS.
    allerdings haben sich die daten von elclair zu froyo etwas geändert(leider aber immernoch falsche zeitangaben)

    alternative gallery apps habe ich keine probiert.

    edit:

    hab grad Quickpic probiert, auch da wird der Standort korrekt angezeigt - ist definitiv die origianl app die da mist baut.
     
    Zuletzt bearbeitet: 10.07.2011
  7. obiwan, 10.07.2011 #7
    obiwan

    obiwan Ehrenmitglied

    Vor ein oder zwei Wochen hatten wir das Thema schonmal besprochen. Ist wirklich ein Fehler in der orginal galerieapp, kann nicht mittels wipe behoben werden, hab das bei mir auch verifizieren können(froyo 179.2)

    Ich nehm aber ebenfalls quickpic, nicht deswegen sondern weils ne extrem Performante app ist. Ist ein sehr harmloser Bug.
     
  8. Rico65, 11.07.2011 #8
    Rico65

    Rico65 Threadstarter Neuer Benutzer

    Danke für den Tip mit Quickview, funktioniert! Vielleicht kann ja jemand nochmal die EXIF Daten von Kameras mit roter und grüner Linse vergleichen?
    Gruß Rico
     
  9. mritsch, 11.07.2011 #9
    mritsch

    mritsch Erfahrener Benutzer

    Also das Problem ist äußerst verzwickt:
    Hintergrund: die Foto-App speichert bei mir (grünes Modul) den Breitengrad mit dem falschen GPSLatitudeRef ab. D.h. statt beispielsweise N50.0 E9.0 wird W50.0 E9.0 abgespeichert. Statt (Nord wird West in die Latitude geschrieben)

    Dies hat folgende Folgen:
    -die interne Galerie-App macht aus W50.0 E9.0 den Wert N-50.0 E9.0 und ruft jede Map-App zur Ortsbeziehung des Bildes mit N-50.0 E9.0 auf.
    -- GoogleMaps zeigt den Ort N-50.0 E9.0 an.

    -QuickPic macht übernimmt W50.0 E9.0 und ruft jede Map-App zur Ortsbeziehung des Bildes mit W50.0 E9.0 auf.
    -- GoogleMaps erkennt den Fehler im GPSLatitudeRef und zeigt die Position N50.0 E9.0 an

    Kleiner Fehler aber äußerst blöde für die Anwender.

    grüße
    mritsch
     
    Zuletzt bearbeitet: 18.07.2011
  10. maniac103, 11.07.2011 #10
    maniac103

    maniac103 Android-Lexikon

    Ist das mit der 'grünen' (SOC) oder 'roten' (Bayer) Kamera?
     
  11. mritsch, 11.07.2011 #11
    mritsch

    mritsch Erfahrener Benutzer

    meine erscheint mir grün... habe aber die Werte nicht ausgelesen. Oben ergänzt.
     
  12. simsoo, 11.07.2011 #12
    simsoo

    simsoo Android-Experte

    Habe genau den gleichen Fehler (grüne Linse)
     
  13. simsoo, 13.07.2011 #13
    simsoo

    simsoo Android-Experte

    Ich habe den Fehler nochmal mit einer frisch installierten Froyo Rom Build 3.4.2_179-002 nachgestellt.
    Leider wird auch hier als GPSLatitudeRef W statt N eingetragen.
    Kann es ein Softwarebug von Motorola sein oder evtl ein Hardwaredefekt?
     
  14. maniac103, 13.07.2011 #14
    maniac103

    maniac103 Android-Lexikon

    Das ist mit Sicherheit ein Softwarefehler.

    EDIT: Und noch dazu eine Regression. Mit Eclair ging's noch.
    EDIT2: Für CM7 habe ich einen Workaround gefunden. Den Leuten mit Stock-ROM kann ich leider nicht helfen.
     
    Zuletzt bearbeitet: 13.07.2011
  15. simsoo, 13.07.2011 #15
    simsoo

    simsoo Android-Experte

    Ist der Fix automatisch in der nächsten Nightly drin?

    Sent from my MB525
     
  16. maniac103, 14.07.2011 #16
    maniac103

    maniac103 Android-Lexikon

    Ja.

    Sent from my MB525 using Tapatalk
     
    simsoo bedankt sich.
  17. simsoo, 14.07.2011 #17
    simsoo

    simsoo Android-Experte

    Es funktioniert mit der CM7 Nightly von heute.
    Danke für die tolle Arbeit.
     
  18. Transalpler, 14.07.2011 #18
    Transalpler

    Transalpler Junior Mitglied

    ist bei mir auch so - ebenfalls Froyo mit grüner CAM - er zeigt mir Breitengrad -48 an, wenn ich in der Gallery die Infos zum Bild anzeigen lasse
     
  19. Hadrian_II, 15.07.2011 #19
    Hadrian_II

    Hadrian_II Android-Hilfe.de Mitglied

    Ebenfalls nach Update auf FROYO (T-Mobile), falsches Vorzeichen im Breitengrad bei neuen Aufnahmen.

    Eine kleine APP, die das Vorzeichen in Bilddateien tauscht wäre jetzt nett.:smile:

    Gruß an die Gemeinde.
     
  20. simsoo, 15.07.2011 #20
    simsoo

    simsoo Android-Experte

    Meldet den Fehler bitte den Motorola Support. Habe ich auch schon gemacht.
    Als schnelle Lösung ist z.Zt. nur ein Update auf die CM7 Nightly möglich.
    Aber je öfter der Bug gemeldet wird um so schneller wird er auch von Moto behoben ....
     

Besucher kamen mit folgenden Begriffen auf unsere Seite:

  1. nach Update Kamera negativ Motorola