1. Gewinne jetzt ein UMiDIGI C Note - alle Informationen findest du hier!!
  1. oliver.s, 08.12.2010 #1
    oliver.s

    oliver.s Threadstarter Neuer Benutzer

    Hallo,

    ich habe gestern begonnen mich mit dem Android Buch von Arno Becker zu beschäftigen.

    Bei ersten Beispiel hab ich jetzt ein etwas seltsames Problem:

    Wenn ich die main.xml vom Buch abschreibe, wird der Spinner nach der RadioGroup nich angezeigt, sondern nur die zwei RadioButtons ...


    <?xml version="1.0" encoding="utf-8"?>
    <LinearLayout xmlns:android="http://schemas.android.com/
    apk/res/android"
    android: orientation="vertical"
    android:layout_width="fill_parent"
    android:layout_height="fill_parent">

    <TextView

    android:layout_width="fill_parent"
    android:layout_height="wrap_content"
    android:text="@string/hello" />

    <RadioGroup android:id="@+id/position"

    android:layout_width="fill_parent"
    android:layout_height="wrap_content"
    android: orientation="vertical">

    <RadioButton android:id="@+id/stauAnfang"

    android:layout_width="wrap_content"
    android:layout_height="wrap_content"
    android:text="Stauanfang" />
    <RadioButton android:id="@+id/stauEnde"
    android:layout_width="wrap_content"
    android:layout_height="wrap_content"
    android:text="Stauende" />

    </RadioGroup>


    <Spinner android:id="@+id/stauUrsache"

    android:layout_width="fill_parent"
    android:layout_height="wrap_content"
    android:drawSelectorOnTop="true" />
    </LinearLayout>




    Wenn ich jedoch den Spinner vor der RadioGroup definiere wird alles korrekt angezeigt!?


    Wenn mir jemand erklären könnte, was da nicht stimmt, wäre ich sehr dankbar :)

    lg oliver
     
  2. ktt, 09.12.2010 #2
    ktt

    ktt Android-Hilfe.de Mitglied

    Hi Oliver,

    also ich habe gerade dein Layout kopiert außer das 2 leerzeichen anstellen waren wo keine sein sollen konnte ich nix feststellen und er zeigt bei mir auch alles an.

    Gruß Kevin
     
  3. oliver.s, 09.12.2010 #3
    oliver.s

    oliver.s Threadstarter Neuer Benutzer

    Hmmm ... ich habe jetzt ein neues Projekt erstellt, bei dem die Reihenfolge wieder, zuerst RadioGroup dann Spinner ist und der Spinner wird wieder nicht angezeigt.

    Gleich wie beim Alten funktioniert das Ganze wenn ich die Spinner und RadioGroup vertausche ...

    das ist irgendwie seltsam!?
     
  4. ktt, 09.12.2010 #4
    ktt

    ktt Android-Hilfe.de Mitglied

    Hi,

    welches Api Level hast du denn eingestellt und hast du sonst noch was verändert außer die main.xml ?

    Testest du im Emulator oder auf einem Handy ?

    Gudde
     
Die Seite wird geladen...
Ähnliche Themen Forum Datum
[OFFEN] Problem mit meiner Login App Android App Entwicklung 10.06.2017
[OFFEN] git-Problem in Android Studio (Windows) Android App Entwicklung 24.05.2017
[ERLEDIGT] put in HashMap bringt App zum abstürzen Android App Entwicklung 22.05.2017
[ERLEDIGT] Problem mit Async Task und auszuführender Aufgabe Android App Entwicklung 02.05.2017
[ERLEDIGT] Spinner feste double Werte zuordnen Android App Entwicklung 24.04.2017
[ERLEDIGT] Problem beim Starten einer neuen Activity Android App Entwicklung 21.03.2017
Excel Dokument mithilfe von JExcelAPI auslesen funktioniert nicht :/ Android App Entwicklung 02.03.2017
Notizen App problem Android App Entwicklung 11.01.2017
Problematik mit der Ausgabe von SQL Inhalten (ljava.lang) Android App Entwicklung 23.11.2016
Text View erzeugt rendering Problem Android App Entwicklung 18.11.2016
Du betrachtest das Thema "Spinner Problem" im Forum "Android App Entwicklung",