1. Möchtest Du unser Team im Android OS-Bereich unterstützen? Details dazu findest du hier!
  2. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

3CX-Phone mit DynDns und Fritzbox

Dieses Thema im Forum "Sonstige Apps & Widgets" wurde erstellt von trouper, 12.07.2010.

  1. trouper, 12.07.2010 #1
    trouper

    trouper Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    80
    Erhaltene Danke:
    17
    Registriert seit:
    12.07.2010
    Hallo ich bin inzwischen stolzer Besitzer eines Nexus One und habe versucht mich auf meiner Fritzbox 7270 mit aktueller Firmware per Dyndns anzumelden und es klappt nicht. Lokal anmelden funktioniert. Hat es schon jemand geschafft und was muss ich dann einstellen damit es funktioniert?
     
  2. FaceOfIngo, 15.07.2010 #2
    FaceOfIngo

    FaceOfIngo Erfahrener Benutzer

    Beiträge:
    218
    Erhaltene Danke:
    17
    Registriert seit:
    28.04.2010
    meinst Du die fritz.box Seite zum administrieren deiner Fritz Box, oder meinst Du eine Freigabe o.ä. welches von der Fritz Box bereitgestellt wird?
     
  3. trouper, 15.07.2010 #3
    trouper

    trouper Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    80
    Erhaltene Danke:
    17
    Registriert seit:
    12.07.2010
    Ich möchte mit 3CX-Phone VOIP von extern über Dyndns betreiben. Leider bekomme ich das nicht eingestellt. Ich habe es aber heute mit SipDroid versucht und da funktioniert es. Allerdings nur wenn ich die IP welche bei Dyndns angemeldet ist direkt eingebe. Aber das Problem liegt irgendwo bei Dyndns. Vielleicht muss man da spezielle Einstellungen für VoIP machen.
     
  4. ulli01, 20.07.2010 #4
    ulli01

    ulli01 Android-Hilfe.de Mitglied

    Beiträge:
    66
    Erhaltene Danke:
    6
    Registriert seit:
    24.06.2010
    DynDNS hat mit Ports nichts am Hut.

    Ulli
     
  5. trouper, 06.08.2010 #5
    trouper

    trouper Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    80
    Erhaltene Danke:
    17
    Registriert seit:
    12.07.2010
    VOIP Dyndns mit Sipdroid funktioniert. Mein Problem das die App den Dyndns Namen nicht aktzeptierte lag daran das mich mich vom internen WLAN auf der Fritzbox anmelden wollte von extern funktioniert es einwandfrei.
     
  6. Alsa, 23.09.2010 #6
    Alsa

    Alsa Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    23.09.2010
    Ich würde auch gerne mit Sipdroid über Dyndns und Fritzbox benutzen.

    Wie wird Sipdroid und Fritbox konfiguriert?

    Carsten
     
  7. trouper, 23.09.2010 #7
    trouper

    trouper Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    80
    Erhaltene Danke:
    17
    Registriert seit:
    12.07.2010
    Ich habe die Fritzbox für zwei Dyndns-Accounts konfiguriert. Einen für die Fernwartung und einen für die Sprache. Näheres dazu findest du im IP-Phone-Forum. Falls du nicht so fit bist in der Fritzbox machst du das am besten mit dem Fritzbox Editor ich habe dazu den FBEditor-0.5.2beta2 genommen.

    Hier meine Beispielkonfig für die Fritzbox:
    ddns {
    accounts {
    enabled = yes;
    domain = "fernwartung.dyndns.org";
    iface = 0;
    username = "username";
    passwd = "passwd ;
    ddnsprovider = "dyndns.org";
    } {
    enabled = yes;
    domain = "sprache.dyndns.org";
    iface = 1;
    username = "username";
    passwd = "passwd ;
    ddnsprovider = "dyndns.org";
    }

    Du kannst alles im Klartext reinschreiben die Fritzbox macht den rest.

    Dann mußt du auch noch ein Telefon für VOIP einrichten das habe ich per GUI gemacht. Danach mußt du dann nochmal per Fritzbox-Editor ran um es für den Fernzugang zu aktivieren (reg_from_outside).

    Hier wieder meine Beispielkonfig.

    voip_assi_enabled = yes;
    extensions {
    enabled = yes;
    username = "name";
    authname = "";
    passwd = "passwort";
    extension_number = 620;
    reg_from_outside = yes;
    tx_packetsize_in_ms = 0;
    }

    Dann kannst du Sipdroid einrichten:

    Zugangsdaten
    Authentifizierungsname: 620
    Server oder Proxy: sprache.dyndns.org
    Domäne: fritz.box
    Port: 5060
    Protokoll: UDP

    Erweiterte Einstellungen:
    Use STUN Server: aktivieren
    STUN Server name stun.deinprovider.de
    STUN Server port 3478

    Evtl. funktioniert es auch ohne einen STUN Server habs noch nicht probiert.
    Das ganze funktioniert aber nur wenn du dich NICHT im Heimnetzwerk befindest.

    Ich hoffe dir damit geholfen zu haben.
     
    Longshine bedankt sich.
  8. Alsa, 27.09.2010 #8
    Alsa

    Alsa Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    23.09.2010
    hallo trouper,

    vielen dank für Deine Beschreibung.

    Die Konfiguration habe ich entsprechend vorgenommen,
    jedoch habe ich über Sipdroid keine Verbindung.



    Meine Konfiguration an der FRITZ.Box Fon WLAN 7270 v2 (UI) 54.04.86


    1)
    fernwartung.homedns.org wird bereits verwendet.
    sprache.dyndns.org ist neu.

    Bei dyndns.org habe ich unter meinem bestehendem Account die sprache.dyndns.org eingerichtet.


    2) mit FBEditor-0.5.2beta2 habe ich FB wie folgt konfiguriert
    :


    ddns {
    accounts {
    enabled = yes;
    domain = "fernwartung.homends.org";
    iface = 0;
    username = "dyndns user";
    passwd = "dyndns kennwort";
    ddnsprovider = "dyndns.org";
    } {
    enabled = yes;
    domain = "sprache.dyndns.org";
    iface = 1;
    username = dyndns user";
    passwd = "dyndns kennwort";
    ddnsprovider = "dyndns.org";
    }





    voip_assi_enabled = yes;
    extensions {
    enabled = yes;
    username = "620";
    authname = "";
    passwd = "620";
    extension_number = 620;
    reg_from_outside = yes;
    gsm_tethering = no;
    tx_packetsize_in_ms = 0;
    }
    }




    3)SipDroid

    Authentifizierungsname: 620
    Passwort: 620
    Server oder Proxy: sprache.dyndns.org
    Domäne: fritz.box
    Port: 5060
    Protokoll: UDP

    Erweiterte Einstellungen:
    Use STUN Server: aktivieren
    STUN Server name: stun.1und1.de
    STUN Server port 3478



    Der Fehler liegt vermutlich an der sprache.dyndns.org.
    Diese Seite existiert nicht, wenn ich sie über den Browser anspreche.
    Wennn die FB gebootet wird, wird in der Ergeignisanzeige angezeigt,
    dass zwei DNS IPs vergeben worden sind.

    Auf DynDNS wird jedoch nur die IP von fernwartung.homends.org aktualisiert,
    jedoch nicht von sprache.dyndns.org.

    Und noch was: Die FB rebootet jetzt nicht mehr.
    Man muss sie stromlos schalten. Dann bootet sie wieder.
    Dies wird durch die Konfiguration sprache.dyndns.org hervorgerufen.

    Gibt es eine Möglichkeit das Problem mit sprache.dyndns.org zu beheben?


    Gruß
    Carsten
     
  9. trouper, 28.09.2010 #9
    trouper

    trouper Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    80
    Erhaltene Danke:
    17
    Registriert seit:
    12.07.2010
    Hallo Carsten,

    das Problem mit dem rebooten kenne ich nicht.

    Ich habe für die sprache.dyndns.org einen extra Account eingerichtet. Zum testen ob die Umleitung funktioniert kannst du ja einfach einen Ping auf die dyndns Adresse durchführen.
    Die Sipdroidkonfiguration kannst du auch testen indem du die aktuelle IP für die Sprache eingibts.
    So habe ich es auch gemacht um die Fehlerquelle einzugrenzen da ich auch eine weile gebraucht hatte bis alles lief.
     
  10. Alsa, 02.10.2010 #10
    Alsa

    Alsa Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    23.09.2010
    Hallo trouper,

    nun kann ich an sprache.dyndns.org erfolgreich einen Ping absetzten.

    Die Anmeldung über Sipdroid gelingt mir nicht, auch wenn ich die IP-Adresse verwende.

    An dieser Stelle frage ich mich, mit welcher Anmeldung bzw. Anmeldungen ich von sprache.dyndns.org zum SIP-Telefoniegerät komme.

    Wenn ich per Fernwartung auf die FB gehe, wird nach Benutzername und Kennwort für den Remote-Zugang gefragt.
    Anschließend wird das Kennwort für die FB abgefragt.
    Jetzt bin ich erst auf der FB.
    Dann soll das Telefongerät 620 verwendet werden,
    welches auch ein Kennwort besitzt.

    Meines Erachtens reicht die Angabe von Benutzername und Kennwort des Telefongerätes 620 nicht aus, um eine Verbindung herzustellen.

    Kannst Du mir weiterhelfen, damit ich hier das richtige Verständnis aufbauen kann?

    Gruss
    Carsten
     
  11. trouper, 03.10.2010 #11
    trouper

    trouper Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    80
    Erhaltene Danke:
    17
    Registriert seit:
    12.07.2010
    Hallo Carsten,

    der Benutzername und das Passwort für Telefon 620 reicht völlig aus. Daran kanns nicht liegen.
    Hast du dich auch von einem externen WLAN angemeldet den vom eigenen funktioniert es nicht über Dyndns?
    Ich würde aber auch einmal ausprobieren mich intern an der SIP-Nr. anzumelden also mit Telefonname (620), Kennwort, und interne Fritz-IP.

    Sehr einfach geht die interne Anmeldung mit der Fritz-App falls du mal andere Apps testen willst. Die 3CX-Phone App kan man auch für intern verwenden per Dyndns hab ich diese nicht zum laufen bekommen.
    Für den PC gibts noch Phoner oder PhonerLite um die Konfiguration des IP-Telefons und Dyndns zu testen. Dann weißt du vielleicht woran der Fehler liegt App, Dyndns oder IP-Telefon konfig. Falls du nicht zum laufen bekommst einfach noch mal melden.
     
  12. tuanhasdone, 28.01.2011 #12
    tuanhasdone

    tuanhasdone Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    0
    Registriert seit:
    06.10.2009
    Hi, Ich habe auch das Problem. hat jemand von euch inzwischen schon ne Lösung gefunden. Ich benutze sipdroid und Fritz!box 7270 Firmware-Version 54.04.88. Vielen Dank
     
  13. trouper, 30.01.2011 #13
    trouper

    trouper Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    80
    Erhaltene Danke:
    17
    Registriert seit:
    12.07.2010
    Hallo,

    bei mir hat das ganze funktioniert mit den Einstellungen die ich schon beschrieben hatte. Ich war damals noch bei 1&1 inzwischen habe ich zu KabelBW gewechselt und dort habe ich es auch noch nicht zu laufen bekommen.
    Fall ich dir weiterhelfen soll mußt du aber schon etwas konkreter werden z.B. wie deine Einstellungen sind und wo du gerade hängst. Ich kann dir aber auch noch das ippf empfehlen dort sitzen die Experten was was das Thema "SIP mit Dyndns und reg_from_ouside" angeht.
     
  14. tuanhasdone, 30.01.2011 #14
    tuanhasdone

    tuanhasdone Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    0
    Registriert seit:
    06.10.2009
    Hallo,
    die Hardware bei mir sind Fritzbox 7270 v2(Firmware-Version*54.04.88 ) und Androide 2.1 mit Sipdroid. ich habe bei mir Folgendes gemacht:
    1.IP-Telefon (620) mit Passwort hinzugefügt.
    2.Die Config von Fritzbox exportieren.
    3.Ändere reg_from_outside auf yes
    4.ganz oben nter der Zeile Language=de eine neue Zeile: NoChecks=yes hinzugefügt
    5.Die Config wieder in den Box eingespielt.
    Die meinname.dyndns.org wurde bei mit Fernwartung immer aktiviert. Durch pingen wurde immer die richtige IP-add rausgegeben.

    6.Auf Sipdroid unter Zugangsdaten: Authentifizierungsname: 620
    Passwort: IP-Telefon - password
    Server oder Proxy: meinname.dyndns.org
    Domain: fritz.box
    Benutzername: --- leer--------

    7.Unter In den erweiterten Einstellungen: Use STUN Server aktivieren
    STUN Server name: stun1.sipgate.net
    STUN Server port: 10000

    Ich habe außerdem auch statt meinname.dyndns.org meine richtige temporäre IP-Adresse unter den Zugangensdaten eingegeben. Die ippf mit ihren langen Theras habe ich davor auch schon mal durchgelesen. Es half mir leider recht wenig. Aber das ganze hat nie funktioniert. Könntest du bitte mir zeigen, wo ich eventuell falsch gemacht habe?. Vielen Dank
     
  15. trouper, 30.01.2011 #15
    trouper

    trouper Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    80
    Erhaltene Danke:
    17
    Registriert seit:
    12.07.2010
    Es gibt einige Provider wie z.B. 1&1 die zwei IP verwenden. Eine für den Webzugang (z.B. Fernwartung) und eine für die Sprache. Dann muss man die ddns Konfiguration wie in Post #7 von mir beschrieben vornehmen.

    Ich würde aber auf alle Fälle mal überprüfen ob du intern telefonieren kannst. Wenn es mit Sipdroid nicht geht dann installiere dir mal die FritzApp mit der sollte es zumindest intern funktionieren.
     
  16. Longshine, 10.10.2011 #16
    Longshine

    Longshine Neuer Benutzer

    Beiträge:
    1
    Erhaltene Danke:
    0
    Registriert seit:
    10.10.2011
    Danke dir vielmals trouper!
    nach ewigen Suchen hab ich es nun auch dank deinem Post #7 geschafft von extern zu telefonieren.
    erstmal hat er mir aber immer wieder die Fritzbox-Einstellungen auf Werkseinstellungen zurückgesetzt nachdem ich deine Configs per FBEditor einspielen wollte - bis ich merkte, dass in deinem Beispiel hinter [passwd = "passwd] noch einmal Anführungszeichen gefehlt haben. vielleicht editierst du das mal noch?
    naja, jetzt funktioniert es aber per Sipdroid. leider is da die Qualität bei mir aber bescheiden. in 3CXPhone ist sie um Welten besser. wenn ich dort aber die dyndns-Adresse eingebe kann er sich nicht verbinden. gebe ich allerdings die bei der dyndns-Adresse aktuell hinterlegte IP manuell ein funktioniert es. kann mir jemand sagen wieso?
     

Diese Seite empfehlen