1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

3g Hotspot Problem

Dieses Thema im Forum "Motorola Defy Forum" wurde erstellt von A190, 14.10.2011.

  1. A190, 14.10.2011 #1
    A190

    A190 Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    4
    Registriert seit:
    04.08.2011
    Hallo,

    ich habe schon ein wenig rumgesucht, aber finde nirgendwo eine Lösung.

    Es geht um folgendes:

    Ich habe ein Defy in (noch) komplett originalem Zustand und Froyo.

    Jetzt kann man ja einen 3g wireless Hotspot damit eröffnen.
    Dieses Feature würde ich gerne mit meinem Lenovo Thinkpad Edge und Ubuntu 11.04 nutzen. WLAN Hardware ist ein Realtek 8188.
    Treiber habe ich die aktuellsten von Realtek kompiliert.

    Ich erstelle also einen Hotspot (z.B. SSID DEFY-A190 mit WPA2 Verschlüsselung Passwort: testtest)

    Ich kann mit meinem Lenovo nicht mit dem Defy verbinden. Die SSID wird gefunden, aber die Verbindung wird nicht hergestellt.
    Auch ohne Verschlüsselung oder mit WEP oder WPA geht nichts.

    Das Notebook meiner Frau (Dell Inspiron 6400n, Ubuntu 10.10) wiederrum verbindet sich mit dem Defy.. und alles funktioniert.

    Heute war ein Kollege da mit einem Samsung Galaxy S i9100 und dessen Hotspot funktioniert auch problemlos mit meinem Lenovo.

    Ich habe auch schon ein anderes Defy , auch 2.2 probiert.. da ist es das selbe Problem. Lenovo verbindet sich nicht.

    Also es liegt definitiv am DEFY... hat jemand eine Idee ??

    Ich tippe auf IEEE802.11n ..
     
  2. crobe, 15.10.2011 #2
    crobe

    crobe Android-Experte

    Beiträge:
    503
    Erhaltene Danke:
    60
    Registriert seit:
    17.03.2011
    Moin, ich hab ebenfalls proble mot dm Hotspot. Bei mir verbindet er sich nicht und bekommt auch keine IP, weder mit linux noxh mit windows 7. Hab die Nordic ROM drauf. Mit Eclair ging es noch.

    Habe mich daraufhin mit Bluetooth tethering beschäftigt, damit get es sehr gut.

    Kable tethering funktioniert seit Froyo auchnicht mehr, danke Moto.

    Sorry für die Rechtschreibung, ist vom Defy.
     
    A190 bedankt sich.
  3. A190, 16.10.2011 #3
    A190

    A190 Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    4
    Registriert seit:
    04.08.2011
    Hi crobe,

    Bluetooth, denke ich, würde ich zum laufen bekommen, aber meine "Killerapplikation" ist das Handy per W-Lan mit HSDPA (weil drinnen nur EDGE) auf der Terrasse unserer Ferienwohnung liegen haben und Laptop gemütlich drinnen.

    Gerade vorige Woche, als wir dort waren, wurde es abends schon recht ungemütlich, so dass man schon gerne drinnen war..

    Mich stört ungemein, die Tatsache, dass das Notebook meiner Frau mit dem DEFY geht und mein Notebook nicht...

    Mein aktueler Versuch wäre nun.. rooten und erstmal 802.11n versuchen zu deaktivieren.. und ich wollte mal alternative W-Lan Hotspot Apps probieren..
    z.B. Open Garden oder Wifi hotspot Lite

    Da Du ja wohl schon gerootet hast (Nordic ROM ) könntest Du ja mal eine dieser Apps testen.. die wollen root-Rechte.
     
    crobe bedankt sich.
  4. crobe, 16.10.2011 #4
    crobe

    crobe Android-Experte

    Beiträge:
    503
    Erhaltene Danke:
    60
    Registriert seit:
    17.03.2011
    Hallo,

    ich hatte android-wifi-tether bereits getestet, könnte Open Garden nochmal probieren.

    Habe mir heute Cyanogenmod 7.1 draufgemacht ( genial! ), damit habe ich immernoch keine Verbindung. Es liegt also wahrscheinlich am Kernel/Wlan System. Mal sehen, ob man Draft-N ausschalten kann.

    Jetzt im Winter wird es ganz schön gemein das Defy auf die Terasse zu legen ;)

    Gruß Rob
     
  5. Jukah, 16.10.2011 #5
    Jukah

    Jukah Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    1
    Registriert seit:
    16.10.2011
    Hab des gleiche Problem mit Defy Plus (Android 2.3.4/Kernel 2.6.32.9(Auslieferungszustand)) und Ubuntu 11.04 (WiFi Controller: AR9285 [kann"n"])
    Aufm alten Laptop mit Win7 (WiFi Controller: Intel 3945ABG [kann kein"n"]) gehts :(

    Werd mal Win7 auf gleicher Hardware testen, und demnächst mal auf 11.10 updaten, we will see...

    Würd mich mal interessieren wieviel % der User/Hardware betroffen sind, aber selten scheints nicht zu sein, da sollte man sich als Entwickler doch gedanken machen...

    EDIT: "Hot" Gleiche Hardware, aber Win7 geht o_O
    Mal des update auf 11.10 abwarten, und sonst vielleicht mal Ndiswrapper?!

    Edit: 11.10 bringt wie zu erwarten war nichts, werd jetzt mal ndiswrapper checken, bzw. (zumindest für mein Atheros-Chip evtl. eleganter "The Mad-WiFi-Project" hört sich mal recht vielversprechend an...)
     
    Zuletzt bearbeitet: 16.10.2011
  6. Phate1177, 17.10.2011 #6
    Phate1177

    Phate1177 Gast

    Also bei mir läuft der Hotspot super. Egal mit welchem Gerät ich mich verbinden will, es geht. Getestet hab ich es bis jetzt mit meinem Lappi (Packard Bell+Win 7 64Bit), meinem Compi (WLAN= DLINK G510+; Win Vista 32bit) nem Lenovo T510 Lappi (Win XP) und nem HP Lappi (Win7 64bit). Hatte bisher wirklich noch keine Probleme!

    Defy ist gerooted und hat Froyo drauf.
     
  7. Jukah, 17.10.2011 #7
    Jukah

    Jukah Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    1
    Registriert seit:
    16.10.2011
    Hmm, evtl. liegts (zumindest in meinem Fall) doch an den Ubuntu-Treibern...

    -Ndiswrapper krieg ich nicht zum laufen, der sagt bei mir immer die .inf is defekt...
    -MadWifi muss ich nochmal anschauen...

    evtl. hilfts ja auch einfach 802.11n im Defy abzuschalten?!? Lösung für abbrechende WLAN Verbindung mit Defy » » dev-eth0.de

    kann ja sein, dass linux nicht damit klar kommt, also praktisch genauso wie die fritz-boxen (sind schließlich auch linux kisten)

    Will eigentlich das Defy erstmal nicht rooten (Neu-Schön-Angst)
    Muss mal versuchen "n" auf meim Ubunto Laptop zu deaktivieren, vielleicht reicht des ja auch schon...
     
  8. A190, 17.10.2011 #8
    A190

    A190 Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    4
    Registriert seit:
    04.08.2011
    11.10 habe ich gestern auch erfolglos getestet.
    Hatte aber auch schon auf dem 11.04 die allerneuesten Treiber von Realtek installiert.

    Wenn ich das so lese, werde ich auch diese Woche mal abends in ner ruhigen Stunde das Telefon rooten und "n-Draft" deaktivieren.
    Es MUSS doch am n-Draft liegen...

    Ich habe folgendes probiert:

    sudo iwconfig wlan0 rate 54M fixed

    oder

    sudo iwconfig wlan0 rate 11M fixed

    Hat beides wie gewünscht funktioniert, aber so wie ich den Befehl verstehe, macht er das erst NACH der Verbindung mit dem AP.. ich weiss jetzt nicht, wie man unter Linux anders ne W-LAN Karte drosseln kann.


    Ist doch ein Outdoor Schmiertelefon .... ;)
    Ausserdem bleibts dann schön kühl...
    Werde ihm ne Decke als Unterlage spendieren.

    @ Phate 1777

    ist denn eines der Geräte, mit denen Du verbindest
    n-Draft/ 300Mbit/sec/ 802.11n fähig ?
     
    Jukah bedankt sich.
  9. Jukah, 17.10.2011 #9
    Jukah

    Jukah Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    1
    Registriert seit:
    16.10.2011
    @A190

    An den Geräten die Verbinden liegts nur teilweise:

    Habs ja zweimal getestet, ASUS UL30VT mit n-fähigem WiFi Controller: AR9285
    unter Win7 läufts
    unter Ubuntu läufts nicht

    also trifft Linux wohl zumindest ne Teilschuld

    Hatte auf meinem alten Nokia "JoikuSpot" zum WifiTethering, der kam mit dem AR9285 und Ubuntu aber klar... (Hmm is vermutlich unerheblich, aber das Nokia konnte natürlich kein n)
     
  10. crobe, 18.10.2011 #10
    crobe

    crobe Android-Experte

    Beiträge:
    503
    Erhaltene Danke:
    60
    Registriert seit:
    17.03.2011
    Moin,

    hab mal versucht im Defy das N zu deaktivieren, hat allerdings keine Besserung gebracht, weder mit WPA noch ohne Verschlüsselung.

    Auf dem "Problemlaptop" hab ich nen iwl3945 chipsatz, was habt ihr so?

    -rob
     
  11. A190, 18.10.2011 #11
    A190

    A190 Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    4
    Registriert seit:
    04.08.2011
    Wie gesagt:

    Realtek 8188CE und Ubuntu 11.10,11.04 gehen nicht.
    Intel 2200bg und Ubuntu 10.10 geht.

    Dass es nach Deaktivierung von "n" am DEFY immer noch nicht geht, macht mich fertig. :sad:
     
  12. Jukah, 19.10.2011 #12
    Jukah

    Jukah Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    1
    Registriert seit:
    16.10.2011
    @crobe

    bin jetzt nicht so der checker, aber vielleicht steh ich aufm schlauch...

    ich hab (glaub ich) den gleichen controller wie du (siehe post nr. 5)

    if 3945abg = iwl3945

    was hast du für n system? unter Win7Pro (glaub 32bit) funktioniert der nämlich super o_O

    muss bei gelegenheit mal schauen was ich da für treiber verwendet hab, vielleicht hilft dir der zumindest für windows?

    @A190
    deprimiert mich auch, n deaktivieren wäre ne noch anzunehmende lösung für unser problem gewesen...
     
    Zuletzt bearbeitet: 19.10.2011
    crobe bedankt sich.
  13. crobe, 19.10.2011 #13
    crobe

    crobe Android-Experte

    Beiträge:
    503
    Erhaltene Danke:
    60
    Registriert seit:
    17.03.2011
    Moin,

    ja, die beiden Chipsätze sind identisch.
    Da ich aber kein Windows verwende, bringt mir diese Lösung leider nichts. Aber danke.
     
  14. Jukah, 19.10.2011 #14
    Jukah

    Jukah Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    1
    Registriert seit:
    16.10.2011
    kannst du dann vielleicht mal den ndiswrapper probieren und die win treiber installieren?
    bei mir hats leider nicht funktioniert, vielleicht schaffst dus ja, dann wüssten wir mal ob des ne lösungsmöglichkeit is...
     
  15. A190, 30.10.2011 #15
    A190

    A190 Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    4
    Registriert seit:
    04.08.2011
    kernelport und crobe haben sich bedankt.
  16. crobe, 08.11.2011 #16
    crobe

    crobe Android-Experte

    Beiträge:
    503
    Erhaltene Danke:
    60
    Registriert seit:
    17.03.2011
    Hatte gerade ein bisschen Muße und muß sagen: Es funktioniert XD

    Habe unter Archlinux jetzt kernel26-lts ( 2.6.32 ) installiert und es rennt wie gewohnt.
     
  17. kernelport, 22.12.2011 #17
    kernelport

    kernelport Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    2
    Registriert seit:
    22.12.2011
    Hallo,
    ich hatte das gleiche Problem und habe für meinen Chipsatz iwl3945 im T60p ThinkPad die Lösung gefunden.

    sudo rmmod iwl3945
    sudo modprobe iwl3945 disable_hw_scan=0

    Seit diesem Commit im Linux Kernel ist der hw_scan per default aus. Damit begannen die Probleme bei Nutzern mit diesem Chipsatz.

    commit 7a2ee4d9621e2ebe4b181b484a2919c784c4e36d
    Author: Stanislaw Gruszka <sgruszka@redhat.com>
    Date: Tue Mar 29 11:24:21 2011 +0200

    iwl3945: disable hw scan by default

    BugLink: http://bugs.launchpad.net/bugs/775809

    commit 0263aa45293838b514b8af674a03faf040991a90 upstream.

    After new NetworkManager 0.8.996 changes, hardware scanning is causing
    microcode errors as reported here:
    https://bugzilla.redhat.com/show_bug.cgi?id=683571
    and sometimes kernel crashes:
    https://bugzilla.redhat.com/show_bug.cgi?id=688252

    Also with hw scan there are very bad performance on some systems
    as reported here:
    https://bugzilla.redhat.com/show_bug.cgi?id=671366

    Since Intel no longer supports 3945, there is no chance to get proper
    firmware fixes, we need workaround problems by disable hardware scanning
    by default.

    Signed-off-by: Stanislaw Gruszka <sgruszka@redhat.com>
    Signed-off-by: John W. Linville <linville@tuxdriver.com>
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
    Signed-off-by: Tim Gardner <tim.gardner@canonical.com>

    Bis dann,
    fn
     
    A190 und crobe haben sich bedankt.
  18. Phate1177, 23.12.2011 #18
    Phate1177

    Phate1177 Gast

    Jupp, mein Lappi und der HP.
     
  19. A190, 29.12.2011 #19
    A190

    A190 Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    4
    Registriert seit:
    04.08.2011
    @ Kernelport

    ich muss zugeben, dass ich gerade auf dem Schlauch stehe und Deine Lösung nicht verstehe.

    Ich verstehe das so, dass hw_scan seit dem commit per default ausgeschaltet ist.

    Dein Modprobe Befehl disablet aber doch auch ??

    Hol mich mal vom Schlauch runter...
     
  20. kernelport, 30.12.2011 #20
    kernelport

    kernelport Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    2
    Registriert seit:
    22.12.2011
    Hallo A190,

    Nein, disable_hw_scan=0 disabled eben nicht!
    Wenn es 1 also wahr wäre dann ist es disabled. Also doppelte Verneinung.

    Unter Ubuntu könnte man das permanent als Modulparameter beim Systemstart
    übergeben wenn man eine Datei /etc/modprobe.d/wlan.conf mit folgendem Inhalt anlegt:

    # enable wifi tethering with motorola defy
    options iwl3945 disable_hw_scan=0

    Bis dann,
    fn
     

Diese Seite empfehlen