1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Akku und Mediaserver (Oder: 1S mein Taschenwärmer)

Dieses Thema im Forum "HTC One S Forum" wurde erstellt von crackmaniac, 29.05.2012.

  1. crackmaniac, 29.05.2012 #1
    crackmaniac

    crackmaniac Threadstarter Erfahrener Benutzer

    Beiträge:
    230
    Erhaltene Danke:
    6
    Registriert seit:
    07.04.2010
    Phone:
    HTC One S
    Tablet:
    Sony Xperia Tablet Z
    Hallo zusammen,

    bei mir ist der Akkuverbrauch echt nicht mehr schön.
    Gerade der Medien Server zieht mir richtig den Akku leer und ich weiß echt nicht wieso.
    Abgesehen von der Entladung wird das Gerät auch ziemlich warm.
    Habe gerade mal 3 Alben auf dem One S und das sind im gesamten 60 mp3s (die sind auch schon länger drauf). Also kann es eigentlich nicht an der Indizierung liegen, dass der MediaServer so viel CPU zeit und Akku verbraucht.

    Kann ich das sch*** dingen irgendwie unterdrücken?
    Zur Zeit betreibe ich Trickdroid 4.1 auf meinem 1S.

    MfG
    Crackmaniac
     

    Anhänge:

  2. crackmaniac, 29.05.2012 #2
    crackmaniac

    crackmaniac Threadstarter Erfahrener Benutzer

    Beiträge:
    230
    Erhaltene Danke:
    6
    Registriert seit:
    07.04.2010
    Phone:
    HTC One S
    Tablet:
    Sony Xperia Tablet Z
    Gute drei stunden Später:

    Das ist doch nicht normal...:thumbdn:
     

    Anhänge:

  3. mickk, 29.05.2012 #3
    mickk

    mickk Android-Experte

    Beiträge:
    587
    Erhaltene Danke:
    122
    Registriert seit:
    08.03.2012
  4. crackmaniac, 30.05.2012 #4
    crackmaniac

    crackmaniac Threadstarter Erfahrener Benutzer

    Beiträge:
    230
    Erhaltene Danke:
    6
    Registriert seit:
    07.04.2010
    Phone:
    HTC One S
    Tablet:
    Sony Xperia Tablet Z
    Danke für den Link. Aber das ist alles ziemlich unbefriedigend. Heute morgen waren es nur noch 50% Akku, und das wieder nach 7 Stunden Standby....
    Da sollte wenn ich es richtig verstanden habe Google mal schnellstens was dran ändern.
     
  5. FelixL, 30.05.2012 #5
    FelixL

    FelixL Ehrenmitglied

    Beiträge:
    4,855
    Erhaltene Danke:
    754
    Registriert seit:
    26.11.2009
    Phone:
    Wileyfox Swift, HTC One M8
    Hast du mal per adb gesucht, ob da was auffälliges auftaucht? Oder einen Factory Reset gemacht?
     
  6. crackmaniac, 30.05.2012 #6
    crackmaniac

    crackmaniac Threadstarter Erfahrener Benutzer

    Beiträge:
    230
    Erhaltene Danke:
    6
    Registriert seit:
    07.04.2010
    Phone:
    HTC One S
    Tablet:
    Sony Xperia Tablet Z
    Also FactoryReset hatte ich schon öfter gemacht, das Problem taucht immer wieder auf.
    der steht gerade auch wieder an... :-S

    was soll ich denn mit adb suchen?
     
  7. mickk, 30.05.2012 #7
    mickk

    mickk Android-Experte

    Beiträge:
    587
    Erhaltene Danke:
    122
    Registriert seit:
    08.03.2012
    Ich habe locker 48h Standby, also muss Google erstmal gar nichts machen ;)

    Hast du die Ideen aus dem Link schon alle ausprobiert?

    Probleme beim Medienscanner können auch an defekten Sektoren (Ausschalten/Crash während Schreibvorgang) auf der "SD-Karte" mit den MP3s liegen. Dazu das One S mal an den PC hängen und als "Laufwerk" aktivieren, dann den Speicher mit PC-Bordmitteln auf Fehler überprüfen und alle Fehler automatisch korrigieren lassen.

    Ansonsten: Factory Reset + SD-Karten Wipe dürften den Fehler beheben (vorsichtshalber vorher mit adb ein Backup machen).

    Der ursprüngliche Beitrag von 11:20 Uhr wurde um 11:23 Uhr ergänzt:

    Auch ein "SD-Karten"-Wipe (kannst die Daten ja später wieder vom PC zurückspielen)? Wenns defekte Sektoren auf der Karte sind, bleiben die Fehler auch bei einem Factory Reset sonst einfach erhalten...

    Ansonsten mal noch mit anderen Mediendateien probieren, vllt. haben deine einen fehlerhaften Header, an denen sich der Medienscanner totscannt.

    Gruß

    Mick
     
  8. crackmaniac, 30.05.2012 #8
    crackmaniac

    crackmaniac Threadstarter Erfahrener Benutzer

    Beiträge:
    230
    Erhaltene Danke:
    6
    Registriert seit:
    07.04.2010
    Phone:
    HTC One S
    Tablet:
    Sony Xperia Tablet Z
    So wie ich es gelesen haben, kann es sein, dass sich der Mediaserver in einer Loop festfährt, wenn er defekte Dateien scant.
    Da wurde dann ein Fehler bei der Programmierung gemacht, und da muss Google durchaus etwas machen. Eine sollche Schleife sollte nicht passieren, da fehlt eine Ausnahmebehandlung.

    Aber dein Statement kommt mir bekannt anderen Softwareentwicklern bekannt vor:
    Nur weil mein einen Fehler beim test nicht findet, heißt es jedoch nicht, dass die Software fehlerfrei ist.

    Werde aber mal den Speicher frei räumen, alles formatieren und dann nochmal schauen wie es sich verhält.
     
  9. mickk, 30.05.2012 #9
    mickk

    mickk Android-Experte

    Beiträge:
    587
    Erhaltene Danke:
    122
    Registriert seit:
    08.03.2012
    Den Zwinker in meinem Beitrag haste aber schon gesehen, oder?
     
  10. enhale, 02.06.2012 #10
    enhale

    enhale Erfahrener Benutzer

    Beiträge:
    191
    Erhaltene Danke:
    9
    Registriert seit:
    21.06.2010
    selbes problem bei mir nun aufgetaucht... bin darauf gestoßen, da ich keien youtubevideos mehr abspielen kann.

    mediaserver 39%...
     
  11. crackmaniac, 05.06.2012 #11
    crackmaniac

    crackmaniac Threadstarter Erfahrener Benutzer

    Beiträge:
    230
    Erhaltene Danke:
    6
    Registriert seit:
    07.04.2010
    Phone:
    HTC One S
    Tablet:
    Sony Xperia Tablet Z
    So hatte nun ein paar Tage Ruhe, nachdem ich wirklich alles gewipet hatte.
    Auch die "SD-Karte" war jungfräulich.
    Gestern waren wir jedoch im AquaZoo und ich habe einige Fotos und Videos gemacht. Diese habe ich Abends direkt auf den Rechner gezogen und vom Handy gelöscht. Danach kam es an das Ladegerät.
    Vollgeladen lag es dann die Nacht einfach nur rum.

    Das ist echt nicht mehr normal. Wäre ich mal bei meinem Desire geblieben :-S
     

    Anhänge:

  12. crackmaniac, 27.06.2012 #12
    crackmaniac

    crackmaniac Threadstarter Erfahrener Benutzer

    Beiträge:
    230
    Erhaltene Danke:
    6
    Registriert seit:
    07.04.2010
    Phone:
    HTC One S
    Tablet:
    Sony Xperia Tablet Z
    Gibt es hier irgendwelche neuen Erkenntnisse?
     
  13. ziemlich_hilflos, 31.07.2012 #13
    ziemlich_hilflos

    ziemlich_hilflos Junior Mitglied

    Beiträge:
    40
    Erhaltene Danke:
    1
    Registriert seit:
    22.07.2012
    Auch wenn es hier um das HTC One S geht, an diesen neuen Erkenntnissen wäre ich ebenfalls interessiert, da auch bei mir der Medienserver innerhalb von 2 Stunden gut 15% Akku benötigt hat. Die Laufzeit meines Nexus S war ja noch nie wirklich gut, aber jedesmal wenn es eine neue Android-Version gibt, ist es eine Katastrophe (4.0.3 war über und nun Jelly Bean). Ich muss schon zum 2. Mal innerhalb einer Woche den Akku rausnehmen.
     
  14. Shaft13, 16.11.2012 #14
    Shaft13

    Shaft13 Fortgeschrittenes Mitglied

    Beiträge:
    253
    Erhaltene Danke:
    32
    Registriert seit:
    09.04.2012
    Phone:
    Samsung Galaxy Note 4
    Habe beim Note 2 das gleiche Problem. Zieht mir in 8 Stunden das Gerät von 100 auf 10% runter und das Gerät ist nicht einmal angewesen.

    Aber Medienserver ist bei 86%.
     
  15. Queeky, 18.11.2012 #15
    Queeky

    Queeky Android-Guru

    Beiträge:
    2,320
    Erhaltene Danke:
    756
    Registriert seit:
    07.02.2011
    Phone:
    Huawei P9 Plus
    Beim Stock-Musikplayer (der, der von Haus aus drauf ist) gibt's unter Menü in den Einstellungen den Punkt "Medienserver".
    Hier mal nachgeschaut, ob der evtl. ständig versucht, mit dem Heimnetzwerk Verbindung aufzunehmen? Oder gar Verbindung hat?
    Vielleicht kann man da was abschalten.
    Anbei ein Bild, was ich meine.
     

    Anhänge:

  16. Cari.Core, 22.02.2013 #16
    Cari.Core

    Cari.Core Neuer Benutzer

    Beiträge:
    1
    Erhaltene Danke:
    0
    Registriert seit:
    20.02.2013
    [​IMG]

    Hab alles versucht, was es so gibt. Kann und möchte auf Spotify aber nicht verzichten.

    Gibt es denn inzwischen eine wirkliche Lösung für das Problem?

    Nexus 4 mit cm10.1
     

Diese Seite empfehlen