Anzeigefehler oder Bug? Wifi bei Bildschirmlock weg

Dieses Thema im Forum "T-Mobile G1 Forum" wurde erstellt von magnummandel, 06.02.2009.

  1. magnummandel, 06.02.2009 #1
    magnummandel

    magnummandel Threadstarter Android-Experte

    Beiträge:
    735
    Erhaltene Danke:
    46
    Registriert seit:
    05.02.2009
    Hallo ihr, ich habe ein seltsames Problem. Meine wlans zu Hause und an der Uni findet mein G1 Problemlos. Allerdings habe ich folgendes Problem wenn das Gerät den Bildschirm abschaltet. Wenn ich den Bildschirm wieder unlocke sehe ich für 1 Sekunde noch das 3g Symbol blinken, das sich dann sofort wieder in das wifi Symbol ändert. Es sieht so aus als ob das G1 im gelockten Zustand das wlan ignoriert.
    Frage: Habt ihr das auch? Wenn ja: Eher bug, Anzeigefehler oder doch ein Feature dessen Sinn ich noch nicht sehe?

    MM

    P.S.: Netzt ist definitiv da, an beiden Plätzen ist der Accesspoint jeweils im selben Raum wie das Telefon.
     
  2. enjoy_android, 06.02.2009 #2
    enjoy_android

    enjoy_android Android-Lexikon

    Beiträge:
    1,258
    Erhaltene Danke:
    390
    Registriert seit:
    10.12.2008
    Kein Bug, Feature. ;) Wenn der Bildschirm aus ist wird Wlan abgeschalten um Strom zu sparen. Die Verbindungen finden aber trotzdem über Wlan statt. (also sollte was gezogen werden wird es aktiviert)
     
  3. magnummandel, 06.02.2009 #3
    magnummandel

    magnummandel Threadstarter Android-Experte

    Beiträge:
    735
    Erhaltene Danke:
    46
    Registriert seit:
    05.02.2009
    danke für die (extrem) flotte Antwort :D
     
  4. macgoff, 07.02.2009 #4
    macgoff

    macgoff Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    2
    Registriert seit:
    03.02.2009
    Dazu hätte ich noch eine Frage.
    Mir ist auch aufgefallen, dass das Gerät bei jedem abschalten des Bildschirms auf das Edge bzw. 3G Symbol wechselt. Nun habe ich testweise die APN Einstellungen mit APNdroid deaktiviert. Wenn das Gerät nun einschläft, verliere ich die InstantMessenger-Verbindung. Ohne APNdroid nicht. Heißt doch, dass das Gerät dann via Edge oder 3G verbunden ist. Also wechselt die Verbindung bei jedem einschlafen des Gerätes von Wifi/Wlan auf Mobil. Und wenn ich es aufwecke wechselt es zurück, sonst würden neue Mails ja nicht zugestellt.
    Das würde aber bedeuten, dass ich aufgrund der ungünstigen Abrechnung von 100kb Blöcken im Complete XS die WLAN-verbindung am Besten nicht aktiviere.
    Denn sonst wird bei jedem aktivieren des Gerätes zuhause eine Edge/G3 Verbindung geschlossen und eine Wifi-Verbindung aufgebaut und beim einschlafen des Gerätes umgekehrt, was über den Tag rund 20 mal 100kb ergibt, selbst wenn das Gerät im Ruhezustand nur 1kb (z.b. Steuerung von Pushmail) mit dem Mobilnetz austauscht.
    Sehe ich das richtig?
    Also wer Pushmail oder IM offen hat sollte vorsichtig sein, wenn er dauerhaft Zuhause oder im Büro/Uni im Wifi hängt, weil zwischendrin immer Mobilverbindungen aufgebaut werden?
    Kann das jemand bestätigen?

    Viele Grüße
    Macgoff
     
  5. magnummandel, 07.02.2009 #5
    magnummandel

    magnummandel Threadstarter Android-Experte

    Beiträge:
    735
    Erhaltene Danke:
    46
    Registriert seit:
    05.02.2009
    Ja kann ich, gleiches Problem hier. Denn im gegensatz zur AUssage oben ist wlan tatschlich dauerhaft aus, wenn der bildschirm geblankt ist. Kann man auch mit NetCounter nachvollziehen. Obwohl das Gerät nachweislich in WLAN Reichweite liegt, wird Traffic über 3g/2g/edge abgewickelt.

    Kann man dem G1 irgendwie abgewöhnen wifi beim sleepen abzuschalten? Das wäre zwar Akkutechnisch doof, aber irgendwie nur konsistent. Denn laut manual soll das Gerät ja über WLAN kommunizieren, wenn es in Reichweite ist.

    MM
     
  6. Mr_Unknow, 28.03.2009 #6
    Mr_Unknow

    Mr_Unknow Android-Hilfe.de Mitglied

    Beiträge:
    143
    Erhaltene Danke:
    5
    Registriert seit:
    02.03.2009
    Ist dieses Problem auch bei den der FW von JF?
    Weil ich finde das echt störend.
    Kann man irgendwo Bugs an Google melden?
    Oder gibt es dafür irgendwo eine Einstellung die ich übersehen habe?
     
  7. magnummandel, 28.03.2009 #7
    magnummandel

    magnummandel Threadstarter Android-Experte

    Beiträge:
    735
    Erhaltene Danke:
    46
    Registriert seit:
    05.02.2009
    Huch? Da hat aber jemand einen uralten Thread ausgegraben :)

    It's not a bug, it's a feature.

    Es gibt mitlerweile einige Apps die das umgehen. Wi-Fi Lock finde ich persönlich ganz nett. Einmal aktiviert, wird wifi auch im idle nicht mehr abgeschaltet.
     
  8. Mr_Unknow, 28.03.2009 #8
    Mr_Unknow

    Mr_Unknow Android-Hilfe.de Mitglied

    Beiträge:
    143
    Erhaltene Danke:
    5
    Registriert seit:
    02.03.2009
  9. Autarkis, 28.03.2009 #9
    Autarkis

    Autarkis Android-Lexikon

    Beiträge:
    1,016
    Erhaltene Danke:
    49
    Registriert seit:
    28.02.2009
    Ich hab auch WiFi-Lock, funktioniert prächtig.

    Ich hatte auch schon festgestellt, dass man wenn man

    1.) WiFi eingeschaltet hat
    2.) den Bildschirm dunkel macht
    3.) das WiFi aus geht
    4.) das EDGE/3G an geht
    5.) und bestehende Internetverbindungen weiter da rüber abgewickelt werden.

    Mit geschickter Anwendung von APNDroid und WiFi-Lock kann man jede dieser Hürden leicht bewältigen.
     
  10. Pyrazol, 29.03.2009 #10
    Pyrazol

    Pyrazol Android-Guru

    Beiträge:
    3,250
    Erhaltene Danke:
    366
    Registriert seit:
    20.02.2009
    Phone:
    Nexus 6
    Tablet:
    Nexus 7 (2013)
    Wearable:
    Moto 360 / Sony Smartwatch 3
    Also ich hatte zu Beginn auch das "Problem", dass Wlan immer weg war, bei ausgeschaltetem Bildschirm. Hat mich nicht sonderlich gestört, weil ich Wlan eigtl. so gut wie immer aus lassen möchte, wegen Batterie.

    Seitdem ich aber Useful Switchers benutze, verhält sich das ganze etwas anders.
    Normalerweise hat man das eigenmächtige Ausgehen vom Wlan ja daran bemerkt, dass nach dem Reaktivieren des Bildschirms das Wlan-Symbol erst nach kurzer Zeit wieder erscheint.
    Seitdem ich Wlan über Useful Switchers aktiviere, ist das irgendwie nicht mehr so. Ich weiß jetzt natürlich nicht, ob Wlan wirklich an bleibt, oder was sonst genau der grund dafür sein könnte... es war auch irgendwie etwas undurchsichtig, weil teilweise Wlan dann nach einiger Zeit komplett weg (= deaktiviert) war... aber wenn sich jemand dafür interessiert, kann er ja mal damit rumprobieren.
     
  11. Autarkis, 29.03.2009 #11
    Autarkis

    Autarkis Android-Lexikon

    Beiträge:
    1,016
    Erhaltene Danke:
    49
    Registriert seit:
    28.02.2009
    Auch wenn man mit Schwimmer's WiFi Switch (oder wie das Ding genau hiess) die WiFi-Funktion ausschaltete, war das so der Fall.

    Das WiFi wird eingeschaltet, aber bei der Anmeldung an den AP bekommt man dann einen Connection Error.

    Wahrscheinlich werden beim Einschalten über das Original-Menü (in Settings) noch weiter Initialisierungen oder Fehlerprüfungen gemacht.

    Inzwischen habe ich auch Useful Switchers. Für eventuelle WiFi-Änderungen gehe ich in die Original-Einstellungen.
     

Diese Seite empfehlen