1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

App wird nicht neu installiert

Dieses Thema im Forum "Android App Entwicklung" wurde erstellt von Gastonet, 13.11.2011.

  1. Gastonet, 13.11.2011 #1
    Gastonet

    Gastonet Threadstarter Erfahrener Benutzer

    Beiträge:
    203
    Erhaltene Danke:
    22
    Registriert seit:
    05.08.2010
    Immer wieder verweigert Eclipse mir den Dienst. Wenn ich beispielsweise eine Grafik austausche und dann die Anwendung neu installieren möchte, dann tut sich einfach nichts.

    In der Konsole steht folgendes:

    Code:
    [2011-11-13 14:38:55 - PROJEKTNAME] ------------------------------
    [2011-11-13 14:38:55 - PROJEKTNAME] Android Launch!
    [2011-11-13 14:38:55 - PROJEKTNAME] adb is running normally.
    [2011-11-13 14:38:55 - PROJEKTNAME] Performing eu.projekt.Main activity launch
    [2011-11-13 14:38:55 - PROJEKTNAME] Automatic Target Mode: Unable to detect device compatibility. Please select a target device.
    [2011-11-13 14:38:56 - PROJEKTNAME] Uploading PROJEKT.apk onto device 'SH161V800442'
    [2011-11-13 14:38:56 - PROJEKTNAME] Installing PROJEKT.apk...
    [2011-11-13 14:38:59 - PROJEKTNAME] Success!
    [2011-11-13 14:38:59 - PROJEKTNAME] Starting activity eu.projekt.Main on device SH161V800442
    [2011-11-13 14:38:59 - PROJEKTNAME] ActivityManager: Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] cmp=eu.projekt/.Main }
    Weiß jemand abhilfe oder hat einen Rat?
     
  2. swordi, 13.11.2011 #2
    swordi

    swordi Gewerbliches Mitglied

    Beiträge:
    3,389
    Erhaltene Danke:
    441
    Registriert seit:
    09.05.2009
    hmm da steht installing - dann success

    das ist ein ganz normaler output, wenn alles passt. wo liegt dann das problem ?
     
  3. Gastonet, 13.11.2011 #3
    Gastonet

    Gastonet Threadstarter Erfahrener Benutzer

    Beiträge:
    203
    Erhaltene Danke:
    22
    Registriert seit:
    05.08.2010
    Ich bin gerade dabei meine App optisch anzupassen mit Grafiken. Deshalb tausch ich einzelne Grafiken oft aus. Allerdings sehe ich auf dem Gerät immer noch die alte Grafik. Hab auch mehrfach kontrolliert ob alles im richtigen Ordner ist.

    Edit: Nach dem 7. Neustart von Eclipse funktioniert das neuinstallieren wieder
    Komisch...
     
    Zuletzt bearbeitet: 13.11.2011
  4. MichaelS, 13.11.2011 #4
    MichaelS

    MichaelS Fortgeschrittenes Mitglied

    Beiträge:
    370
    Erhaltene Danke:
    51
    Registriert seit:
    14.08.2009
    Eclipse baut nicht immer das Prjekt neu! Nur wenn du eine Code-Zeile in XML oder Java Dateien änderst. Sprich wenn du eine Grafik austauscht, wird es nicht automatisch neu gebaut. du müsstest ein manuellen clean machen und neu bauen manuell :)

    Einfacher Trick: In einer Java Datei nen Leerzeichen oder was auch immer entfernen und speichern :) Eclipse baut dein Projekt dann neu.
     
    Gastonet bedankt sich.

Diese Seite empfehlen