1. Hast Du Lust, bei uns mitzuarbeiten und das AH-Team zu verstärken? Alle Details zu dieser aktuellen Herausforderung findest Du hier.
  1. Gastonet, 13.11.2011 #1
    Gastonet

    Gastonet Threadstarter Erfahrener Benutzer

    Immer wieder verweigert Eclipse mir den Dienst. Wenn ich beispielsweise eine Grafik austausche und dann die Anwendung neu installieren möchte, dann tut sich einfach nichts.

    In der Konsole steht folgendes:

    Code:
    [2011-11-13 14:38:55 - PROJEKTNAME] ------------------------------
    [2011-11-13 14:38:55 - PROJEKTNAME] Android Launch!
    [2011-11-13 14:38:55 - PROJEKTNAME] adb is running normally.
    [2011-11-13 14:38:55 - PROJEKTNAME] Performing eu.projekt.Main activity launch
    [2011-11-13 14:38:55 - PROJEKTNAME] Automatic Target Mode: Unable to detect device compatibility. Please select a target device.
    [2011-11-13 14:38:56 - PROJEKTNAME] Uploading PROJEKT.apk onto device 'SH161V800442'
    [2011-11-13 14:38:56 - PROJEKTNAME] Installing PROJEKT.apk...
    [2011-11-13 14:38:59 - PROJEKTNAME] Success!
    [2011-11-13 14:38:59 - PROJEKTNAME] Starting activity eu.projekt.Main on device SH161V800442
    [2011-11-13 14:38:59 - PROJEKTNAME] ActivityManager: Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] cmp=eu.projekt/.Main }
    Weiß jemand abhilfe oder hat einen Rat?
     
  2. swordi, 13.11.2011 #2
    swordi

    swordi Gewerbliches Mitglied

    hmm da steht installing - dann success

    das ist ein ganz normaler output, wenn alles passt. wo liegt dann das problem ?
     
  3. Gastonet, 13.11.2011 #3
    Gastonet

    Gastonet Threadstarter Erfahrener Benutzer

    Ich bin gerade dabei meine App optisch anzupassen mit Grafiken. Deshalb tausch ich einzelne Grafiken oft aus. Allerdings sehe ich auf dem Gerät immer noch die alte Grafik. Hab auch mehrfach kontrolliert ob alles im richtigen Ordner ist.

    Edit: Nach dem 7. Neustart von Eclipse funktioniert das neuinstallieren wieder
    Komisch...
     
    Zuletzt bearbeitet: 13.11.2011
  4. MichaelS, 13.11.2011 #4
    MichaelS

    MichaelS Fortgeschrittenes Mitglied

    Eclipse baut nicht immer das Prjekt neu! Nur wenn du eine Code-Zeile in XML oder Java Dateien änderst. Sprich wenn du eine Grafik austauscht, wird es nicht automatisch neu gebaut. du müsstest ein manuellen clean machen und neu bauen manuell :)

    Einfacher Trick: In einer Java Datei nen Leerzeichen oder was auch immer entfernen und speichern :) Eclipse baut dein Projekt dann neu.
     
    Gastonet gefällt das.
Die Seite wird geladen...
Ähnliche Themen Forum Datum
[OFFEN] Android app selber entwickeln mit Bluetooth Android App Entwicklung Freitag um 12:01 Uhr
[ERLEDIGET] App über href starten Android App Entwicklung 28.09.2017
[OFFEN] Kostenpflichtige App für Beta-Test hochladen Android App Entwicklung 13.09.2017
[OFFEN] App startet nicht... Android App Entwicklung 10.09.2017
[OFFEN] Sind Notifications in einer Webview App möglich? Android App Entwicklung 10.09.2017
[OFFEN] Möchte eine App für Entrümpelungen entwickeln. Android App Entwicklung 08.09.2017
[ERLEDIGT] Alpha-Version meiner App nicht mit S8 kompatibel Android App Entwicklung 06.09.2017
[ERLEDIGT] Verbindung zu MS SQL DB von App aus möglich? Android App Entwicklung 05.09.2017
[OFFEN] App schließt nach Öffnen sofort Android App Entwicklung 04.09.2017
[ERLEDIGT] MIT APP Inventor paralleler Tastendruck Android App Entwicklung 23.08.2017
Du betrachtest das Thema "App wird nicht neu installiert" im Forum "Android App Entwicklung",