1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Apps nach Neustart alle weg .. Froyo by Laszlo 4-QF1

Dieses Thema im Forum "Root / Hacking / Modding für T-Mobile G1" wurde erstellt von znas, 18.02.2011.

  1. znas, 18.02.2011 #1
    znas

    znas Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    18.02.2011
    Liebe Community,

    ich hab nach mehreren Stunden es endlich hinbekommen, dieses ROM von Froyo zu installieren: [ROM] [FEB 12 2011] Froyo by Laszlo - Just Another Awesome Rom 4-QF1 - xda-developers

    Klappt auch alles - ist super schnell, bin echt glücklich.

    Dann hab ich alle Apps installiert die ich so brauche, einmal neu gestartet, alle Apps weg !

    Nun hab ich ein bisschen was ausprobiert.
    Man kann ja unter CygonMod einstellen...

    Folgendes hab ich eingestellt:

    Verschieben an und aus
    installationsort: Automatisch, sd-ext

    Ich werd nun noch probieren, Intern/Extern auszuwählen, aber ich bezweifle sehr stark das es dann klappt...

    Hat jemand Ideen? :( Ohne Apps macht das irgendwie kein Sinn..

    Liebe Grüße,
    znas
     
  2. Steppo, 18.02.2011 #2
    Steppo

    Steppo Android-Lexikon

    Beiträge:
    1,894
    Erhaltene Danke:
    247
    Registriert seit:
    19.02.2010
    Also du hast Verschieben auf JA & den Installationsort auf SD-ext? Du hast da zwei Optionen immer hingeschrieben.

    Ansonsten würde ich sagen du hast keine ext-Partition auf deiner SD angelegt. So hat er sie wohl ins 'Nichts' installiert. Überprüfe nochmals die Partitionierung deiner Karte. Stichwort Ext4...
     
  3. znas, 18.02.2011 #3
    znas

    znas Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    18.02.2011
    Ich war mir so sicher,..

    Ich geh in Recovery rein, partition sdkarte, und repair, ext2->ext3 und ext3->ext4 , kommt immer, erfolgreich, dann steck ich die sdkarte an pc, ganz normale fat32 partition... viellicht ne idee was ich noch falsch mache? bzw, wie bringt ihr die sdkarte auf ext4? Ohne jetzt hier groß ne LiveCD zu brennen usw, hab nur nen Netbook ohne CDlaufwerk, liebe grüße,
    saNz
     
  4. meckergecko, 18.02.2011 #4
    meckergecko

    meckergecko Android-Experte

    Beiträge:
    802
    Erhaltene Danke:
    116
    Registriert seit:
    09.06.2010
    Wenns am CD-LW scheitert, nimm nen USB-Stick. Das Tool "unetbootin" baut dir den.
     
  5. znas, 18.02.2011 #5
    znas

    znas Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    18.02.2011
    Also...

    ich habe nun EXT4 Formatierung hinbekommen, eine Partition.
    Aber, wenn ich über Einstellungen Telefonspeicher und SD-Speicherkarte usw mir anzeigen lasse, steht dort:

    Gesamtspeicher
    Nicht verfügbar

    Verfügbarer speicher
    Nicht verfügbar

    bereitstellen und formatieren geht auch nicht.

    Steckt aber drin!

    Wenn ich Sie rausziehe, sagt er auch, SD Karte entfernt bitte neue einlegen.
    Mache ich noch was falsch?:/

    Liebe Grüße,
    znas


    Nachtrag:

    Über File Experts kom ich auf sd-ext und sdcard auch nicht rauf "can not access this folder" :/
     
    Zuletzt bearbeitet: 18.02.2011
  6. winne, 18.02.2011 #6
    winne

    winne Android-Guru

    Beiträge:
    3,788
    Erhaltene Danke:
    644
    Registriert seit:
    09.05.2009
    Phone:
    S60
    Wearable:
    Pebble schwarz
    Das ist logisch, da dir Windows nur die Fat32 Partition anzeigt und der Rest der Sdcard wird nunmal für die Daten als Fat32 formatiert. Es sind mehrere Partitionen auf deiner Sdcard und Windows zeigt dir nur die eine !

    Beispiel : 8GB Sdcard > partitionieren 500MB swap und 500MB ext > 7 GB Fat32 ! Klar ? :winki:

    siehe auch hier : http://android-faq.de/faq09.html
     
    Zuletzt bearbeitet: 18.02.2011
  7. meckergecko, 18.02.2011 #7
    meckergecko

    meckergecko Android-Experte

    Beiträge:
    802
    Erhaltene Danke:
    116
    Registriert seit:
    09.06.2010
    Haste auch die richtige Reihenfolge bei den Partitionen? (1. fat32,2. ext,3. swap) Ansonsten einfach mal alle Partitionen löschen und neu machen. Mit welchem Tool hast du die Partitionierung gemacht? Recovery oder am PC?
     
  8. Steinhund, 19.02.2011 #8
    Steinhund

    Steinhund Android-Hilfe.de Mitglied

    Beiträge:
    94
    Erhaltene Danke:
    12
    Registriert seit:
    10.11.2010
    Scheint aber ein grundsätzliches Problem im ROM zu sein. Ich hab das ausprobiert, und die Apps sind eigentlich alle im internen Speicher. Allerdings habe ich die EInstellungen für den Installationsort auf "Automatisch" gelassen. Ich spekuliere mal das die Apps nach dem ersten Neustart auf die ext4-Partition geschoben werden, die aber anschließend nicht richtig gemounted wird.

    Erstaunlicherweise sind auch nicht alle Apps weg. Ich dachte zuerst das nur die automatisch wiederhergestellen Apps weg sind, und alle mit Titanium gesicherten nicht, aber dem ist nicht so. Photoshop, Quicksettings, Twitter, MyPhoneExplorer und einige andere wurden nach dem Flash direkt vom Market zurückgespielt. Und sind nach wie vor vorhanden, andere Apps hingegen nicht. Bis jetzt kann ich leider noch kein Muster erkennen, das dahinter steckt.

    Die FAT32 Partition wird normal gemounted, mit dem nativen Froyo Apps2SD wurden keine Apps verschoben.

    Ich guck mal weiter, woran es liegen könnte.

    Nick

    Nachtrag:

    Ich hab jetzt nochmal den ganzen Thread bei XDA durchgelesen - konnte aber diesbezüglich nichts finden. Und da ich ein Spielkind bin hab ich einfach den Quickfix noch mal geflasht - und siehe da, alles wieder da. Warum und weshalb sind mir noch nicht klar, aber ich spekuliere immer noch auf einen Fehler beim Mounten der EXT4 Partition
     
    Zuletzt bearbeitet: 19.02.2011
  9. znas, 19.02.2011 #9
    znas

    znas Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    18.02.2011
    Hey, also gegen Ende hin, scheint der BUg bekannt zu sein bei xda:

    Aber was meinst du mit Quickfix, geht das dann? Woher kriegt man das, und wie kann man das raufflashen? danke schonmal!

    Liebe Grüße,
    saNz
     
  10. Denowa, 19.02.2011 #10
    Denowa

    Denowa Android-Guru

    Beiträge:
    2,872
    Erhaltene Danke:
    565
    Registriert seit:
    21.08.2009
    Phone:
    OnePlus One, OnePlus Two, ZTE Axon 7
    Wearable:
    Pebble
    Steht alles im ersten Post, unter Downloadlink, in der Box. :D

    Hab den Link mal kopiert:
    QuickFix-1: http://l-rom.googlecode.com/files/FBL4-QF1FR.zip
     
  11. znas, 19.02.2011 #11
    znas

    znas Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    18.02.2011
    Sorry, aber flash ich das nun einfach drüber oder wie? :/
     
  12. znas, 19.02.2011 #12
    znas

    znas Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    18.02.2011
    ok - einfach drüber flashen.

    So, und was genau funktioniert jetzt?
    Hab eben ne App auf SD verschieben lassen, neu starten lassen, weg war sei wieder.

    Welche Einstellung muss ich machen?

    Automatisch
    Intern
    Extern
    SD-EXT

    damit er das ordentlich auf die sd karte installiert?
    Magpie, kann man vllt gar keine apps auf die sd verschieben?
    Sieht es vielleicht einfach nur so aus, als ob es auf dem internet Speicher ist, dabei ist es aber auf der SD Karte?

    Ich begreif es einfach nicht :/#

    Weil ich hab nu SD-EXT drin, Paper Toss runtergeladen.
    Vorher hatte ich 30,84MB internen Speicher frei, nun 29,9MB
    Paper Toss ist aber fast 7MB groß, also klappt es doch?
     
  13. Steinhund, 20.02.2011 #13
    Steinhund

    Steinhund Android-Hilfe.de Mitglied

    Beiträge:
    94
    Erhaltene Danke:
    12
    Registriert seit:
    10.11.2010
    Einige Apps werden offensichtlich direkt auf SD-EXT installiert. Ich hab noch kein System dahinter finden können welche und warum. Zumindest sind nach einem Neustart alle Apps weg, die auf SD-EXT liegen.

    Der Flash nach einem Neustart ist zwar ein bißchen nervig, aber zumindest funktioniert es :)

    Mal abgesehen davon finde ich das ROM einfach klasse.

    Wenn ich mehr Zeit hab schau ich mir das mit dem Mounten der EXT4 Partition nochmal genauer an, vielleicht findet sich ja ne Lösung..

    nachtrag: Version 5 ist draußen und scheint das Problem nicht mehr zu haben. Einfach drüber flashen ohne wipe. Und danach die übliche Geduld, der erste Neustart dauert ein wenig. Bis jetzt sind alle Apps vorhanden und funktionieren tadellos.

    http://forum.xda-developers.com/showthread.php?t=929678#

     
    Zuletzt bearbeitet: 20.02.2011

Diese Seite empfehlen