1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Bootschleife nach nandroid Backup

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone" wurde erstellt von frY, 23.03.2010.

  1. frY, 23.03.2010 #1
    frY

    frY Threadstarter Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    1
    Registriert seit:
    23.03.2010
    Hi ihr,
    ich wollte mir gestern mal 2.1 auf meinen Stein spielen.
    Vorher noch schön ein Nandroid Backup gemacht, damit meine Daten gesichert sind und ich später wieder zurück kann.

    Soweit so gut, 2.1 ein bisschen getestet.
    Jetzt mein Problem, ich wollte dann mein nandroid Backup zurück spielen, was soweit auch geklappt hat, jedoch hängt mein Handy jetzt in einer Boot-Schleife. Das Android Logo wird ständig wieder aufs neue angezeigt.
    Habt ihr irgendwelche Ideen und Lösungsvorschläge? :(

    Danke schonmal!
     
  2. frY, 23.03.2010 #2
    frY

    frY Threadstarter Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    1
    Registriert seit:
    23.03.2010
    Ich hab schon so viele Möglichkeiten durchprobiert, nur mit meinem nandroid Backup immer die Bootschleife :(
    Wär ja alles halb so wild, nur würde ich halt gerne wieder an meine Daten kommen. Wobei ich mich von der Vorstellung schon langsam verabschiedet habe.
     
  3. Lowbyte, 23.03.2010 #3
    Lowbyte

    Lowbyte Android-Lexikon

    Beiträge:
    991
    Erhaltene Danke:
    484
    Registriert seit:
    20.03.2009
    Welches system hatte dein Stein denn als du das Nandroid erstellt hattest?
    Ansonsten passende SBF flashen und dann nochmal versuchen
     
  4. DennisG1, 23.03.2010 #4
    DennisG1

    DennisG1 Android-Experte

    Beiträge:
    515
    Erhaltene Danke:
    51
    Registriert seit:
    05.01.2010
    Flash dir wie lowbyte deine korreke 2.0.1 mit rsd. Wenns dann klappt gut, wenn nicht musst du wohl einen wipe machen. Deine daten sind dann, sofern nicht auf sdkarte gespeichert leider weg.
     
  5. frY, 23.03.2010 #5
    frY

    frY Threadstarter Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    1
    Registriert seit:
    23.03.2010
    Kann man vielleicht irgendwie feststellen was die Bootschleife verursacht?
    Durch irgendwelche Log-Dateien?

    Ich verstehs einfach nicht, ich habe ein komplettes Nandroid Backup gemacht, und davor lief ja alles 1a und wenn ich das komplette Backup nun wieder zurück spiele gehts nicht mehr, auch wenn ich vorher die alte sbf flashe. :(
     
  6. Lowbyte, 23.03.2010 #6
    Lowbyte

    Lowbyte Android-Lexikon

    Beiträge:
    991
    Erhaltene Danke:
    484
    Registriert seit:
    20.03.2009
    Ich tippe darauf das vorher schon was im argen war!
     
  7. frY, 23.03.2010 #7
    frY

    frY Threadstarter Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    1
    Registriert seit:
    23.03.2010
    Es war halt das 2.0.1 HK das es damals zum falshen gab drauf.
    Dann noch die Launcher2 nachinstalliert und mehr wurde eigentlich nicht gemacht. Bis dato lief das Handy ja auch fast 3 Monate ohne Probleme.

    Aber wie gesagt hab mich schon damit abgefunden dass meine Daten wohl futsch sind. Wollte nur mal sehen ob hier noch jemand evtl eine Idee hat woran es liegen könnte.
     
  8. KisteBier, 23.03.2010 #8
    KisteBier

    KisteBier Android-Lexikon

    Beiträge:
    1,591
    Erhaltene Danke:
    314
    Registriert seit:
    30.11.2009
    Phone:
    Huawei P9 EVA-L19
    ich würde mal tippen, daß beim update auf 2.1 recovery mit der von 2.1 überschrieben wurde; damit funktioniert nandroid erstmal nicht. du mußt mit der recovery.sbf erst die alte recovery wiederherstellen, da hier die lücke für root (und auch nandroid) liegt.
    nachdem´s dazu vermutlich zu spät ist, nimm eine 2.0.1 FULL-sbf, mit rsd lite flashen, danach hast du zumindest zugriff auf die daten und kannst dir aussuchen, ob du 2.1 nochmal drübernudeln willst.

    edit:
    wobei du ja schreibst, daß das restoring des backups funktionierte.. dann muß da schon vorher irgendwas probleme verursacht haben, schätz ich..
    flash mit der 2.0.1 FULL-sbf sollte dem jedenfalls abhelfen.
     
  9. frY, 23.03.2010 #9
    frY

    frY Threadstarter Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    1
    Registriert seit:
    23.03.2010
    Hi again!
    Ich weiß jetzt wo das Problem liegt!
    Jedoch weiß ich nicht wie ich das beheben kann.
    Und zwar ist meine /data Partition zu klein.
    /data hat eine Größe von 196MB
    das data.img allein hat aber schon 202,9MB und im "entpackten" Zustand dann 273,3MB.

    Kann mir mit dieser neuen Erkenntnis evtl jemand weiterhelfen?
     
  10. Klodeckel, 23.03.2010 #10
    Klodeckel

    Klodeckel Fortgeschrittenes Mitglied

    Beiträge:
    257
    Erhaltene Danke:
    62
    Registriert seit:
    26.12.2009
    Phone:
    Motorola Milestone
    Nimm doch den Weg der schon beschreiben wurde. Einfach nochmal eine 2.0.1er sbf flashen und gut ist. Somit bleibt deine data Partition unberührt
     
  11. frY

    frY Threadstarter Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    1
    Registriert seit:
    23.03.2010
    Die /data Partition hatte ich zwischendurch ja schon mal gewiped.
    Aber habe es gerade geschafft sie wiederherzustellen. Der hat Unmengen an Cache Dateien immer mit auf /data klatschen wollen. Die hab ich jetzt beim wiederherstellen gleich gelöscht, dann hatte er auch genug Platz um die wichtigen Daten mit auf die Partition zu schreiben.

    D.h. hab jetzt meine Daten wieder und der Stein rennt :)
     
  12. Klodeckel, 23.03.2010 #12
    Klodeckel

    Klodeckel Fortgeschrittenes Mitglied

    Beiträge:
    257
    Erhaltene Danke:
    62
    Registriert seit:
    26.12.2009
    Phone:
    Motorola Milestone
    Schön das zu hören ;)
     
  13. KisteBier, 24.03.2010 #13
    KisteBier

    KisteBier Android-Lexikon

    Beiträge:
    1,591
    Erhaltene Danke:
    314
    Registriert seit:
    30.11.2009
    Phone:
    Huawei P9 EVA-L19
    @fry
    hast du den memhack gemacht, der den dalvik-cache auf /data verschiebt...?
    dann wäre das eine unangenehme nebenwirkung des hacks....
     
  14. frY

    frY Threadstarter Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    1
    Registriert seit:
    23.03.2010
    Nein eigentlich nicht...
    das Einzige was ich damals gemacht hatte war, HK Version von 2.0.1. Root und Launcher2.

    Aber genau wie du sagst war unter anderem auch dieser Ordner einer der Übeltäter! Ein weiterer war der Browser Cache.
     

Diese Seite empfehlen