Bootschleife nach nandroid Backup

F

frY

Neues Mitglied
Threadstarter
Hi ihr,
ich wollte mir gestern mal 2.1 auf meinen Stein spielen.
Vorher noch schön ein Nandroid Backup gemacht, damit meine Daten gesichert sind und ich später wieder zurück kann.

Soweit so gut, 2.1 ein bisschen getestet.
Jetzt mein Problem, ich wollte dann mein nandroid Backup zurück spielen, was soweit auch geklappt hat, jedoch hängt mein Handy jetzt in einer Boot-Schleife. Das Android Logo wird ständig wieder aufs neue angezeigt.
Habt ihr irgendwelche Ideen und Lösungsvorschläge? :(

Danke schonmal!
 
F

frY

Neues Mitglied
Threadstarter
Ich hab schon so viele Möglichkeiten durchprobiert, nur mit meinem nandroid Backup immer die Bootschleife :(
Wär ja alles halb so wild, nur würde ich halt gerne wieder an meine Daten kommen. Wobei ich mich von der Vorstellung schon langsam verabschiedet habe.
 
Lowbyte

Lowbyte

Experte
Welches system hatte dein Stein denn als du das Nandroid erstellt hattest?
Ansonsten passende SBF flashen und dann nochmal versuchen
 
DennisG1

DennisG1

Stammgast
Flash dir wie lowbyte deine korreke 2.0.1 mit rsd. Wenns dann klappt gut, wenn nicht musst du wohl einen wipe machen. Deine daten sind dann, sofern nicht auf sdkarte gespeichert leider weg.
 
F

frY

Neues Mitglied
Threadstarter
Kann man vielleicht irgendwie feststellen was die Bootschleife verursacht?
Durch irgendwelche Log-Dateien?

Ich verstehs einfach nicht, ich habe ein komplettes Nandroid Backup gemacht, und davor lief ja alles 1a und wenn ich das komplette Backup nun wieder zurück spiele gehts nicht mehr, auch wenn ich vorher die alte sbf flashe. :(
 
Lowbyte

Lowbyte

Experte
Ich tippe darauf das vorher schon was im argen war!
 
F

frY

Neues Mitglied
Threadstarter
Es war halt das 2.0.1 HK das es damals zum falshen gab drauf.
Dann noch die Launcher2 nachinstalliert und mehr wurde eigentlich nicht gemacht. Bis dato lief das Handy ja auch fast 3 Monate ohne Probleme.

Aber wie gesagt hab mich schon damit abgefunden dass meine Daten wohl futsch sind. Wollte nur mal sehen ob hier noch jemand evtl eine Idee hat woran es liegen könnte.
 
KisteBier

KisteBier

Experte
ich würde mal tippen, daß beim update auf 2.1 recovery mit der von 2.1 überschrieben wurde; damit funktioniert nandroid erstmal nicht. du mußt mit der recovery.sbf erst die alte recovery wiederherstellen, da hier die lücke für root (und auch nandroid) liegt.
nachdem´s dazu vermutlich zu spät ist, nimm eine 2.0.1 FULL-sbf, mit rsd lite flashen, danach hast du zumindest zugriff auf die daten und kannst dir aussuchen, ob du 2.1 nochmal drübernudeln willst.

edit:
wobei du ja schreibst, daß das restoring des backups funktionierte.. dann muß da schon vorher irgendwas probleme verursacht haben, schätz ich..
flash mit der 2.0.1 FULL-sbf sollte dem jedenfalls abhelfen.
 
F

frY

Neues Mitglied
Threadstarter
Hi again!
Ich weiß jetzt wo das Problem liegt!
Jedoch weiß ich nicht wie ich das beheben kann.
Und zwar ist meine /data Partition zu klein.
/data hat eine Größe von 196MB
das data.img allein hat aber schon 202,9MB und im "entpackten" Zustand dann 273,3MB.

Kann mir mit dieser neuen Erkenntnis evtl jemand weiterhelfen?
 
K

Klodeckel

Erfahrenes Mitglied
Nimm doch den Weg der schon beschreiben wurde. Einfach nochmal eine 2.0.1er sbf flashen und gut ist. Somit bleibt deine data Partition unberührt
 
F

frY

Neues Mitglied
Threadstarter
Die /data Partition hatte ich zwischendurch ja schon mal gewiped.
Aber habe es gerade geschafft sie wiederherzustellen. Der hat Unmengen an Cache Dateien immer mit auf /data klatschen wollen. Die hab ich jetzt beim wiederherstellen gleich gelöscht, dann hatte er auch genug Platz um die wichtigen Daten mit auf die Partition zu schreiben.

D.h. hab jetzt meine Daten wieder und der Stein rennt :)
 
KisteBier

KisteBier

Experte
@fry
hast du den memhack gemacht, der den dalvik-cache auf /data verschiebt...?
dann wäre das eine unangenehme nebenwirkung des hacks....
 
F

frY

Neues Mitglied
Threadstarter
Nein eigentlich nicht...
das Einzige was ich damals gemacht hatte war, HK Version von 2.0.1. Root und Launcher2.

Aber genau wie du sagst war unter anderem auch dieser Ordner einer der Übeltäter! Ein weiterer war der Browser Cache.
 
Oben Unten