1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Daos.apk kommt nach reboot wieder

Dieses Thema im Forum "Archos 70 Forum" wurde erstellt von Duke_TBH, 07.09.2011.

  1. Duke_TBH, 07.09.2011 #1
    Duke_TBH

    Duke_TBH Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    07.09.2011
    Hallo Gemeinde,

    Ich habe folgendes Problem auf meinen A70it und ich weiß nicht weiter.

    Ich habe das gerät gerooted nach der Anleitung von culpri auf die letzte firmware.(2.4.19)
    Den orginal Android habe ich gemäß Punkt 4 gelöscht und bin somit immer root.

    Gestern wollte ich die Daos.apk aus dem /system/app entfernen.

    Habe erst mit rename probiert, was auch funktioniert hat. (Habe das mit dem terminal emulator und su wechsel durchgeführt)

    Nach dem reboot war die Datei wieder als Daos.apk vorhanden.

    Danach habe ich sie gelöscht. Anschließend reboot. Sie war erneut da.

    Ich habe das mehrfach probiert. Auch mit beenden des Dienstes. Jedoch ohne Erfolg.

    Nach google Recherche. Habe ich versucht als su einen remount rw zu machen, aber den Befehl kannte er nicht. Ein anderer Hinweis war es mit dem root explorer zu versuchen, da man dort remount rw und ro oben über den Button einstellen kann

    Also habe ich den root explorer gekauft.

    Da musste ich feststellen das /system/apps schon rw war

    Also noch mal löschen der Daos.apk mit dem root explorer.

    Ergebnis: nach dem reboot ist sie wieder da.

    Habe systemweit gesucht ob sie noch irgendwo anders ist. Aber es gibt sie nur auf der externen sd wo ich sie gesichert habe.

    Wie bekomme ich sie dauerhaft entfernt?

    Hintergrund ist, dass ich überflüssige Dienste dauerhaft beendet haben möchte, wie z.B. diesen firmware update Dienst.

    Ich möchte dies Dienste/Apps nicht jedes mal killen, daher möchte ich auch keine app die das immer selbst macht. Überflüssiges soll erst gar nicht geladen werden.

    Dank euch schon mal.
     
    Zuletzt bearbeitet: 07.09.2011
  2. Cynob, 07.09.2011 #2
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,730
    Erhaltene Danke:
    918
    Registriert seit:
    17.04.2011
    Heyhey
    Also den Kauf vom Root Explorer wirste nicht bereuen :) Bei mir ist das neben dem Terminal Emulator mit die wichtigste Anwendung aufm Archos :D
    Schau mal nach in /data/data/ da gibts ganz viele Ordner die mit "com" anfangen und such dort mal nach der Daos apk und lösch den ganzen Ordner.
    Ich bin auch gerade dabei herauszufinden was ich alles im System entfernen kann um mehr RAM nach dem booten zu haben. Wenn ich damit fertig bin kommt des in nen riesen Script rein das auch noch nen Schnellen launcher, bootanimation, n gemoddetes framework und was mir bis dato sonst noch einfällt dem Archos spendiert.
    Da ich zur Zeit net wirklich viel Freizeit habe wird meist halt nur an den Wochenenden gebastelt...abers wird
     
  3. Duke_TBH, 08.09.2011 #3
    Duke_TBH

    Duke_TBH Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    07.09.2011
    danke Cynob für die antwort.

    ich hatte im 101 forum schon einen hinweis auf das /data/data gefunden.

    als ich schaute, war das /data leer. nachdem ich gestern deine antwort gelesen habe, wusste ich warum es leer war. ich habe mit dem ASTRO geschaut und der hat offensichtlich nicht genügend berechtigungen.

    mit dem root explorer, war es anders :)

    daraufhin habe ich folgendes getan

    1. online firmeware dienst beendet
    2. /system/app/Daos.apk gelöscht
    3. /data/data folder com.archos.daos gelöscht
    4. reboot

    das ergebnis hat mich ein wenig verblüfft, weil der dienst nicht mehr
    gestartet wurde (also wie gewünscht), aber die Daos.apk erneut
    im /system/app angelegt war.

    grundsätzlich, ist es genau das was ich wollte. warum aber das file immer wieder zurückkommt und vor allem woher, bleibt mit unerklärlich O_O

    kann das irgendwie aus dem rootfs.img zurückkommen? das liegt bei mir unter /sdcard und soweit ich das verstanden habe wird das benutzt oder?
     
  4. Cynob, 08.09.2011 #4
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,730
    Erhaltene Danke:
    918
    Registriert seit:
    17.04.2011
    mmhh das ist grad ne gute Frage....
    bei mir war damals Ruhe danach.... hast du das Stock Rom noch auf dem Archos?
    Was jetzt so noch ne option wäre -> mit dem Titanium Backup lassen sich auch Apks löschen.... der müsste dann wirklich alles restlos entfernen. ( die free Version reicht da vollkommen)
     
    Duke_TBH bedankt sich.
  5. FZelle, 08.09.2011 #5
    FZelle

    FZelle Android-Lexikon

    Beiträge:
    938
    Erhaltene Danke:
    151
    Registriert seit:
    15.04.2010
    Phone:
    Sony Xperia Acro S
    Und du bist sicher auch Chulri's r+w Root genommen zu haben?
    Denn /system liegt eigentlich in einem unveränderlichen gepackten squashfs.
    Erst die r+w version vom root legt ein unionfs "drüber" was es ermöglich permanente änderungen durchzuführen.
     
    Duke_TBH bedankt sich.
  6. Duke_TBH, 08.09.2011 #6
    Duke_TBH

    Duke_TBH Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    07.09.2011
    @cynob: ja der original rom ist gelöscht. titanium backup habe ich in der pro aber ich glaube fzelle hat des "pudels kern" gefunden

    ich habe natürlich nicht die 2.4.19 +rw genommen sondern die genau eines darüebr 2.4.19 ohne rw. das könnte doch die ursache des problems sein.
    (dieser gedanke schwante mir auch schon im hinterkopf)

    ich war mir nur nicht ganz sicher. reverted der in der version ohne +rw alles immer zurück? oder nur bestimmte teile im BS?

    dann bräuchte ich doch einfach nur den punkt 3 aus Chulri's anleitung noch mal vollziehen oder? (diesmal mit den +rw files)

    3. Install the custom kernel + initramfs
    • reboot Archos device and hold down "Vol-" button after screen went black
    • Go to "Recovery Menu" and then "Developer Edition Menu"
    • choose "Flash Kernel and Initramfs"
    • connect your Archos device by USB to your computer
    • upload zImage and initramfs.cpio.gz to your device
    • safely disconnect the USB connection
    • press ok on Archos device
    • reboot and hold down "Vol-" button after screen went black
    • choose "Developer Edition"
     
    Zuletzt bearbeitet: 08.09.2011
  7. Cynob, 08.09.2011 #7
    Cynob

    Cynob Android-Guru

    Beiträge:
    2,730
    Erhaltene Danke:
    918
    Registriert seit:
    17.04.2011
    öhm ja
     
  8. Duke_TBH, 08.09.2011 #8
    Duke_TBH

    Duke_TBH Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    07.09.2011
    So jungs, problem gelöst! Nach einspielen der richtigen files +rw geht es.

    Habe die .apk umbenannt und nach reboot war es noch so.

    Also nochmal vielen Dank für Hilfe.
     

Diese Seite empfehlen