1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Erste App - Fehlermeldung im Simulator

Dieses Thema im Forum "Android App Entwicklung" wurde erstellt von speedymcs, 30.06.2011.

  1. speedymcs, 30.06.2011 #1
    speedymcs

    speedymcs Threadstarter Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    0
    Registriert seit:
    30.06.2011
    Hi, ich habe vorhin meine erste Hello World App in Eclipse geschrieben (habe ein wenig Programmierhintergrund mit Java/C++).
    Ich habe wie in Googles Tutorial zunächst die neueste Plattform benutzt, also 3.1, API 12, revision 2. Das hat funktioniert, aber ich wollte mal ein Handy-Format statt Tablet probieren und habe die Version 2.3.3 installiert (unter der Annahme, dass die für Smartphones und die neuere ausschließlich für Tablets ist.. stimmt das überhaupt?) und eine neue AVD erstellt. Wenn ich nun Hello World darauf starte, funktioniert die App zwar, aber alle paar Sekunden erhalte die Fehlermeldung "Sorry! The process android.process.acore has stopped unexpectedly. Please try again."
    Eclipse zeigt mir keinerlei Fehler. Wie kriege ich das weg?

    Der Code:
    PHP:
    package com.example.helloandroid;

    import android.app.Activity;
    import android.os.Bundle;
    import android.widget.TextView;

    public class 
    HelloAndroid extends Activity {
        
    /** Called when the activity is first created. */
        
    @Override
        
    public void onCreate(Bundle savedInstanceState) {
            
    super.onCreate(savedInstanceState);
            
    TextView tv = new TextView(this);
            
    tv.setText("Hello, World!");
            
    setContentView(tv);
        }
    }
     
  2. eagle99, 30.06.2011 #2
    eagle99

    eagle99 Android-Hilfe.de Mitglied

    Beiträge:
    121
    Erhaltene Danke:
    10
    Registriert seit:
    19.04.2009
    Phone:
    HTC Desire HD
    Das Problem könnte sein, dass Android 2.3 die für 3.1 kompilierte Version nicht richtig ausführen kann.

    Einfach mal das Projekt neu machen und im Assistenten einfach eine Android Version unter 3.0 auswählen.

    Im Prinzip ist es so, dass 3.0 und größer zur Zeit nur für Tablet gedacht sind. Erst mit Android Icecream-Sandwitch (vll. 4.0, ist noch nicht bekannt) wird es einheitliche Versionen für Smartphone und Tablet geben.
     
    speedymcs bedankt sich.
  3. speedymcs, 30.06.2011 #3
    speedymcs

    speedymcs Threadstarter Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    0
    Registriert seit:
    30.06.2011
    Danke für die schnelle Antwort und die Infos! Erst habe ich das Projekt nur geändert, aber auch durch neu erstellen und direkt Version 2.3 auswählen wird das Problem leider nicht behoben. Es erscheint auch, wenn ich nicht aus Eclipse heraus starte, sondern aus dem standalone SDK Manager.
     
  4. speedymcs, 30.06.2011 #4
    speedymcs

    speedymcs Threadstarter Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    0
    Registriert seit:
    30.06.2011
    Okay es scheint gelöst. Habe nochmal zwei neue Projekte erstellt und jetzt taucht es nicht mehr auf, vielleicht hatte ich vorher was vergessen oder es ist nur launisch.
     

Diese Seite empfehlen