1. Hast Du Lust, bei uns mitzuarbeiten und das AH-Team zu verstärken? Alle Details zu dieser aktuellen Herausforderung findest Du hier.
  1. speedymcs, 30.06.2011 #1
    speedymcs

    speedymcs Threadstarter Neuer Benutzer

    Hi, ich habe vorhin meine erste Hello World App in Eclipse geschrieben (habe ein wenig Programmierhintergrund mit Java/C++).
    Ich habe wie in Googles Tutorial zunächst die neueste Plattform benutzt, also 3.1, API 12, revision 2. Das hat funktioniert, aber ich wollte mal ein Handy-Format statt Tablet probieren und habe die Version 2.3.3 installiert (unter der Annahme, dass die für Smartphones und die neuere ausschließlich für Tablets ist.. stimmt das überhaupt?) und eine neue AVD erstellt. Wenn ich nun Hello World darauf starte, funktioniert die App zwar, aber alle paar Sekunden erhalte die Fehlermeldung "Sorry! The process android.process.acore has stopped unexpectedly. Please try again."
    Eclipse zeigt mir keinerlei Fehler. Wie kriege ich das weg?

    Der Code:
    PHP:
    package com.example.helloandroid;

    import android.app.Activity;
    import android.os.Bundle;
    import android.widget.TextView;

    public class 
    HelloAndroid extends Activity {
        
    /** Called when the activity is first created. */
        
    @Override
        
    public void onCreate(Bundle savedInstanceState) {
            
    super.onCreate(savedInstanceState);
            
    TextView tv = new TextView(this);
            
    tv.setText("Hello, World!");
            
    setContentView(tv);
        }
    }
     
  2. eagle99, 30.06.2011 #2
    eagle99

    eagle99 Android-Hilfe.de Mitglied

    Das Problem könnte sein, dass Android 2.3 die für 3.1 kompilierte Version nicht richtig ausführen kann.

    Einfach mal das Projekt neu machen und im Assistenten einfach eine Android Version unter 3.0 auswählen.

    Im Prinzip ist es so, dass 3.0 und größer zur Zeit nur für Tablet gedacht sind. Erst mit Android Icecream-Sandwitch (vll. 4.0, ist noch nicht bekannt) wird es einheitliche Versionen für Smartphone und Tablet geben.
     
    speedymcs gefällt das.
  3. speedymcs, 30.06.2011 #3
    speedymcs

    speedymcs Threadstarter Neuer Benutzer

    Danke für die schnelle Antwort und die Infos! Erst habe ich das Projekt nur geändert, aber auch durch neu erstellen und direkt Version 2.3 auswählen wird das Problem leider nicht behoben. Es erscheint auch, wenn ich nicht aus Eclipse heraus starte, sondern aus dem standalone SDK Manager.
     
  4. speedymcs, 30.06.2011 #4
    speedymcs

    speedymcs Threadstarter Neuer Benutzer

    Okay es scheint gelöst. Habe nochmal zwei neue Projekte erstellt und jetzt taucht es nicht mehr auf, vielleicht hatte ich vorher was vergessen oder es ist nur launisch.
     
Die Seite wird geladen...
Ähnliche Themen Forum Datum
[OFFEN] Android app selber entwickeln mit Bluetooth Android App Entwicklung 13.10.2017
[ERLEDIGET] App über href starten Android App Entwicklung 28.09.2017
[OFFEN] Kostenpflichtige App für Beta-Test hochladen Android App Entwicklung 13.09.2017
[OFFEN] App startet nicht... Android App Entwicklung 10.09.2017
[OFFEN] Sind Notifications in einer Webview App möglich? Android App Entwicklung 10.09.2017
[OFFEN] Möchte eine App für Entrümpelungen entwickeln. Android App Entwicklung 08.09.2017
[ERLEDIGT] Alpha-Version meiner App nicht mit S8 kompatibel Android App Entwicklung 06.09.2017
[ERLEDIGT] Verbindung zu MS SQL DB von App aus möglich? Android App Entwicklung 05.09.2017
[OFFEN] App schließt nach Öffnen sofort Android App Entwicklung 04.09.2017
[ERLEDIGT] MIT APP Inventor paralleler Tastendruck Android App Entwicklung 23.08.2017
Du betrachtest das Thema "Erste App - Fehlermeldung im Simulator" im Forum "Android App Entwicklung",