1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Nach TPT Flash blaues Wunder erlebt

Dieses Thema im Forum "Root / Hacking / Modding für ZTE Blade / OSF / Lutea" wurde erstellt von bhf, 20.02.2011.

  1. bhf, 20.02.2011 #1
    bhf

    bhf Threadstarter Android-Guru

    Beiträge:
    3,354
    Erhaltene Danke:
    1,256
    Registriert seit:
    15.01.2011
    Phone:
    Honor 8
    Tablet:
    Google Pixel C
    Moin,

    hier mal meine Erlebnisse, als ich eben mal die Partitionsgröße ändern wollte, um mehr Speicher für Apps zu bekommen. Vielleicht ist es dem einen oder anderen ja eine Lehre, zu viel zu schnell zu wollen. Jedenfalls habe ich keinen Schimmer, wo mein Denkfehler liegen könnte.

    Kurz und schmerzlos: nach TPT-Flash vom JJ9-Image kann ich keine Nandroid-Backups mehr zurückspielen. Eigentlich dachte ich, nachdem ich diverse Threads hier und bei Modaco quergelesen habe, das wäre ein Kinderspiel:

    Mit aktuellem CWM ein Backup erstellen, TPT-Image.zip runterladen und MD5 Summe mit der bei Modaco vergleichen, Image auf dem PC entpacken, MD5-Summe erstellen, auf die SD-Karte kopieren und wieder MD5 Summe überprüfen. Wenn beide übereinstimmen kann der Flash losgehen. Grüne Testwüste gesehen, reboot abgewartet. Neustart des Phones in Recovery und festgestellt, dass AmonRa keine CWM-Backups zurückspielt. Na toll.

    Nagut, CWM 3.0.0.6 aufs Phone geflasht, reboot in Recovery und Restore angestoßen. Böses Erwachen: Boot.img wird gelöscht und beim Zurückschreiben des Boot.img gibt's 'ne Fehlermeldung. Und das wars. Booten des Telefons nicht mehr möglich,, klar, weil schon das Restore der Boot.img scheitert. Ok, ab hier wurde mir dann doch mulmig.

    Also noch mal JJ9-Image per TPT geflasht, ein etwas älteres Backup probiert, gleiche Fehlermeldung an gleicher Stelle. Allmählich macht sich Panik bei mir breit, als ich sämtliche meiner Backups ausprobierte und keines sich zurückschreiben ließ.

    Also per image-original zurück zur Stock-Partitionierung und backup restored. Gleiches Spiel wie oben. Ums Verrecken lässt sich kein Nandroid backup zurückspielen. Egal wie ich es dreh und wende, ein Restore scheitert an einem ungültigen boot.img.

    Pff, wenn den schon ein zurück so oder so nicht funktioniert, dann kann ich mein Phone eben zum gefühlt hundertdrölften Mal komplett neu aufsetzen, dann aber eben mit vergrößerter Data-Partition. Also nochmal das JJ9-Image geflasht, AmonRa durch CWM 3.0.0.6 ersetzt, FLB G2 R8 slim geflasht, am Market angemeldet, vier Apps zur gleichen Zeit runtergeladen und installiert (nur um zu kucken, ob der Cache-Bug zuschlägt), Phone neu eingerichtet, in Recovery gebootet, Backup erstellt, dieses erfolgreich zurückgespielt, zurückgelehnt.

    Wenigstens habe ich jetzt nach komplettem Neuaufsetzen des Phones noch exakt 200,5 MiB frei auf /data, von 288 MiB gesamt. Also hat sich die olle Plackerei gelohnt. Zudem habe ich offenbar das Phone ordentlich entschlackt, da ich vorher nur 49 MB freien Speicher auf /data hatte. Ja ich weiß, dass einige die-hards die 42 MiB Cache-Partition auf knapp 4 MiB verkleinern und so 319 MB auf /data rausholen. Das ist mir aber zu heikel gewesen, da es wohl probleme mit dem Market geben kann.

    Wieso das Zurückspielen der Backups bereits an der Boot.img scheitert, verstehe ich immer noch nicht. Vielleicht kann mich ja jemand erhellen.
     
  2. matthes77, 20.02.2011 #2
    matthes77

    matthes77 Fortgeschrittenes Mitglied

    Beiträge:
    381
    Erhaltene Danke:
    45
    Registriert seit:
    09.11.2010
    Phone:
    Motorola Moto G
    Mal ins Blaue geraten: Hast du das Verzeichnis "image" auf der SD-Karte nach dem Flashen umbenannt bzw. gelöscht? Das soll ansonsten Probleme machen, mindestens dann, wenn man nochmal mit Menu und VolDown startet, weil das Image dann halt von Neuem installiert wird. Aber eventuell auch, wenn man das Recovery-System bootet...
     
  3. kleinerkathe, 20.02.2011 #3
    kleinerkathe

    kleinerkathe Android-Lexikon

    Beiträge:
    1,365
    Erhaltene Danke:
    219
    Registriert seit:
    23.01.2010
    Mit welcher Recoverversion hast du dein Backup erstellt?
    Die Dinger sind unter verschiedenen Versionen nicht immer und zwischen Clockwork und AmonRA glaub nie kompatibel ;)
     
  4. kuemmeltuerk, 21.02.2011 #4
    kuemmeltuerk

    kuemmeltuerk Android-Lexikon

    Beiträge:
    1,161
    Erhaltene Danke:
    283
    Registriert seit:
    15.08.2009
    Was ich gelernt hab ist, das man unter gar keinen umständen nie niemals nicht den Ordern mit den Backups umbennennen darf. sonst gibts nen MD5 Checksummen fehler
     
  5. bhf, 21.02.2011 #5
    bhf

    bhf Threadstarter Android-Guru

    Beiträge:
    3,354
    Erhaltene Danke:
    1,256
    Registriert seit:
    15.01.2011
    Phone:
    Honor 8
    Tablet:
    Google Pixel C
    Das ist ja das Komische: Ich habe die Ordner nie angerührt, weder umbenannt, noch verschoben. Nix. Irgendwas habe ich sicherlich falsch gemacht, nur komme ich partout nicht dahinter was.

    Aber jetzt ist es auch egal. Die 'neuen' Backups werden zurückgespielt. Ob ich das Telefon jetzt einmal mehr oder weniger komplett neu Aufsetze spielt auch keine Rolle mehr. Der zusätzliche freie Speicher war den ganzen Nerv jedenfalls Wert.

    Das einzige Blöde ist, dass ich die Bookmarks vom Stockbrowser immer verliere. Weiß jemand zufällig, wo die liegen oder womit (außer Titanium) man die Bookmarks sichern kann?
     
  6. email.filtering, 21.02.2011 #6
    email.filtering

    email.filtering Gast

    Was hast'e denn gegen Titanium Backup?

    Ich glaube eigentlich nicht, dass es wegen umbenannter Backup-Ordner MD5-Prüfsummenprobleme bei den Dateien gibt. Kann schon mal technisch gar nicht sein, wo doch der Sinn der Prüfsumme genau jener ist, nicht von Äußerlichkeiten abhängig zu sein. Das Problem muss anderswo liegen. Und schließlich kann ich bei Amon RA's Recovery die Backups aus beliebigen Ordner zurückspielen lassen.
     
  7. art78250, 21.02.2011 #7
    art78250

    art78250 Android-Hilfe.de Mitglied

    Beiträge:
    87
    Erhaltene Danke:
    10
    Registriert seit:
    08.02.2011
    Phone:
    Galaxy Nexus
    Ich benutze den Dolphin und verwende zum sichern der Favoriten "Bookmarks To SD"
     
    Zuletzt bearbeitet: 21.02.2011
  8. bhf, 22.02.2011 #8
    bhf

    bhf Threadstarter Android-Guru

    Beiträge:
    3,354
    Erhaltene Danke:
    1,256
    Registriert seit:
    15.01.2011
    Phone:
    Honor 8
    Tablet:
    Google Pixel C
    Sagt mal, könnte das Nicht-zurückschreiben der Backups eigentlich - theoretisch zumindest - daran gelegen haben, dass die System-Partition zu klein für das Backup war? Oder würde trotzdem erstmal losgeschrieben werden, bis kein Platz mehr vorhanden ist?
     
  9. email.filtering, 22.02.2011 #9
    email.filtering

    email.filtering Gast

    Naja, wenn das Minibetriebssystem schlau genug ist, sollte es eine allfällige Überschreitung der Ziellaufwerkskapazität natürlich schon im Vorfeld erkennen können, aber ob das hier auch so ist?

    Aber eigentlich bin ich schon davon ausgegangen, dass der Fragesteller die Partitionsgrößen bei seinen Versuchen berücksichtigt hat, zumal ja auch an Hand der äußeren Größe des Backups erkennbar ist, ob's auf die Zielpartition passen kann.

    Und ich erkenne den Sinn eines Backups (mal von allenfalls enthaltenen persönlichen, aber dann schon zwangsläufig veralteten Änderungen abgesehen) bei diesem Gerät ohnedies nicht, vor allem wenn schon fast jede Woche eine neue Variante erscheint ...

    Andererseits sollte man sich über die Backup-Sache doch noch einige Gedanken machen, zumal meine lediglich zweimaligen Versuche das per ROMDump angelegte Backup meines Originalbetriebssystems einzuspielen ebenfalls (zu meiner Verwunderung) gescheitert sind. Nur dass es mir damals, im Hinblick auf die Ausführungen im Absatz davor, einfach nicht wichtig genug war, um mich weiter mit dem Thema zu beschäftigen.
     
    Zuletzt von einem Moderator bearbeitet: 22.02.2011
  10. tkrhiman, 24.02.2011 #10
    tkrhiman

    tkrhiman Neuer Benutzer

    Beiträge:
    15
    Erhaltene Danke:
    1
    Registriert seit:
    12.01.2011
    Mir ist heute im Prinzip genau das gleiche passiert.

    Ich wollte nach der Anleitung aus dem Modaco-Forum mein Lutea neu partitionieren. Bin dann auch nach der Anleitung vorgegangen, allerdings ist es beim flashen der boot.img bei 90% mit einem Fehler hängen geblieben. Nachdem ich schon Angst hatte das jetzt gar nichts mehr geht, hab ich über TPT JJ9 neu geflasht (hatte auch vorher JJ9 drauf). Hab dann über den Recovery Manager wieder mein orginal Clockwork 2.5.1.8 drauf gemacht. Nur ließen sich bei mir auch keine der vorhandenen Backups zurückspielen. Es kam immer eine Fehlermeldung (irgendwas mit MD5-Checksum), glaube auch beim Versuch die boot.img zu flashen.

    Mich würde interessieren, mit welcher Version du deine Backups gemacht hast, anscheinend läuft da irgendwas nicht richtig.

    Wahrscheinlich gibt es jetzt keine Möglichkeit mehr mein altes System wieder zum laufen zu bringen?! Das gibt mir dann aber die Chance mal wieder ein anderes Customrom auszuprobieren. Mal sehn was ich da jetzt versuche.
     
  11. email.filtering, 26.02.2011 #11
    email.filtering

    email.filtering Gast

    Also ich habe bei ZTE Blade gleich zusammen mit einem "Update" einer Community-Betriebssystemvariante (damals noch Fillyjonk 5) per TFT erledigt. Das hat die wenigste Arbeit gemacht und es waren auch gleich zwei Fliegen mit einer Klappe geschlagen. Und wozu sollte ich jemals wieder die Originalfirmware drauf haben wollen? Wobei es selbst eine Möglichkeit zur Repartitionierung nach Originalvorgaben gibt.
     
  12. goseph, 01.03.2011 #12
    goseph

    goseph Erfahrener Benutzer

    Beiträge:
    230
    Erhaltene Danke:
    47
    Registriert seit:
    09.12.2010
    Ich vermute auch, dass das die System-Partition und die Größe des Backups eine entscheidende Rolle spielen.
    Es ist doch klar, dass das System im Backup wahrscheinlich größer sein wird als die maximalen 128MB.

    Wer sich für TPT entscheidet sollte davon ausgehen, sein System komplett neu aufzusetzen. Vielleicht funktioniert eine Sicherung mit Titanium-Backup?
     
  13. bhf

    bhf Threadstarter Android-Guru

    Beiträge:
    3,354
    Erhaltene Danke:
    1,256
    Registriert seit:
    15.01.2011
    Phone:
    Honor 8
    Tablet:
    Google Pixel C
    Selbst wenn die System-Partition zu klein gewesen wäre (was nicht mal beim Stock der Fall war), wieso steigt NANDroid beim zurückschreiben der Bootpartition aus?

    GsD sind das bestenfalls akademische Probleme, hätte mich nur interessiert.
     
  14. goseph, 01.03.2011 #14
    goseph

    goseph Erfahrener Benutzer

    Beiträge:
    230
    Erhaltene Danke:
    47
    Registriert seit:
    09.12.2010
    TPT bricht die System-Partition auf 128MB runter. Da passt auch keine Stock-Firmware mehr drauf.
     
  15. bhf

    bhf Threadstarter Android-Guru

    Beiträge:
    3,354
    Erhaltene Danke:
    1,256
    Registriert seit:
    15.01.2011
    Phone:
    Honor 8
    Tablet:
    Google Pixel C
    Wenn du das sagst. Das Lutea System-irgendwas vom NANDroid-Backup ist kleiner als 128 MB.
     
  16. colarus, 01.03.2011 #16
    colarus

    colarus Android-Experte

    Beiträge:
    560
    Erhaltene Danke:
    142
    Registriert seit:
    06.08.2009
    Phone:
    Sony Xperia Z1 Compact
    Habt Ihr mal überprüft mit welchem Recovery Ihr die Backups gemacht habt?

    Ich glaube "kleinerkathe" hat recht. Wenn Ihr mit CWM 2.X ein Backup macht könnt Ihr das mit CWM 3.X nicht zurückspielen.

    Spaßeshalber könntet Ihr mal versuchen mit einer älteren Version das Backup zurück zuspielen.

    Ich meine mich aber zu erinnern das es mit einer der ersten CMW 3.X Versionen auch ein Problem mit den Backups gab und deswegen kurz darauf ein weiteres Update kam.
     
  17. bhf

    bhf Threadstarter Android-Guru

    Beiträge:
    3,354
    Erhaltene Danke:
    1,256
    Registriert seit:
    15.01.2011
    Phone:
    Honor 8
    Tablet:
    Google Pixel C
    Ich habe das Update mit 2.5.1.8 gemacht und mit der 3.0.0.6 versucht zurückzuspielen. Ok, das könnte es natürlich sein. Vielleicht ein bisschen minderschlau von mir, mittendrin CWM zu ändern. :)
     
  18. tkrhiman, 01.03.2011 #18
    tkrhiman

    tkrhiman Neuer Benutzer

    Beiträge:
    15
    Erhaltene Danke:
    1
    Registriert seit:
    12.01.2011
    also ich hab mein backup auch mit 2.5.1.8 gemacht. nachdem ich das nach dem tpt flash nicht zurückspielen konnte, hatte ich wieder 2.5.1.8 draufgemacht und damit ging es auch nicht.

    ab jetzt mache ich nach jedem rom flash ein backup und spiele es zurück um zu sehen, ob es funktioniert.
     

Diese Seite empfehlen