1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Noch mehr Speed Ideen

Dieses Thema im Forum "Root / Hacking / Modding für Samsung Galaxy S" wurde erstellt von dahool, 21.08.2010.

  1. dahool, 21.08.2010 #1
    dahool

    dahool Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    299
    Erhaltene Danke:
    164
    Registriert seit:
    18.11.2009
    Zum Testen erst einmal folgendes unter root eingeben:
    adb shell
    su

    echo anticipatory > /sys/block/mmcblk0/queue/scheduler
    echo anticipatory > /sys/block/mmcblk1/queue/scheduler
    echo anticipatory > /sys/block/stl3/queue/scheduler
    echo anticipatory > /sys/block/stl9/queue/scheduler
    echo anticipatory > /sys/block/stl10/queue/scheduler
    echo anticipatory > /sys/block/stl11/queue/scheduler
    echo 0 > /proc/sys/vm/swappiness
    echo 5 > /proc/sys/vm/dirty_ratio

    bzw das ganze in ein Shellscript packen und davor ein:
    #!/system/bin/sh
    setzen


    Nun wäre es hilfreich wenn alle mal ihr Feedback abgeben um womöglich noch mehr Speed aus dem SGS raus zu holen. (Bitte keine Quadrant Zahlen-die bringen wenig um die reine Benutzergeschwindigkeit und Lags zu beschreiben). Wenn es bei den meisten Usern hilft, kommt das in den anderen Speedfix mit rein.

    P.S: Infos die noch keinen SpeedFix verwenden wäre am interessantesten-ob die Lags weniger wurden.
    P.S.S. Neues automatisiertes Bootlogo-Script kommt im Laufe der Woche-leider momentan beruflich etwas eingespannt.
    P.S.S.S. Wer nicht warten will kann das AllIncl Paket ausprobieren (enthält den Fix hier und den anderen SpeedFix) http://www.linux-linux.de/FixAllInclusive.zip
     
    Zuletzt bearbeitet: 23.08.2010
    SGSLover, Asdain, Mycorrhiz und 4 andere haben sich bedankt.
  2. TheDarkWiesel, 22.08.2010 #2
    TheDarkWiesel

    TheDarkWiesel Android-Hilfe.de Mitglied

    Beiträge:
    95
    Erhaltene Danke:
    9
    Registriert seit:
    15.06.2010
    Ich komme nach Punkt 3 nicht weiter. Installieren usw. geht alles tadellos, wobei man anmerken sollte, dass ich die jeweiligen Ordner von hand erstellen musste (also den "sl4a" u.o.ä. weiß ja nicht, wie es gedacht war). Im Programm selbst wird bei mir das scipt1.sh leider nicht gefunden. Ich mache doch bestimmt irgendwas falsch da oder? ^^ P.S. Verwende die jm1 mit root und speedfix
     
  3. dahool, 22.08.2010 #3
    dahool

    dahool Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    299
    Erhaltene Danke:
    164
    Registriert seit:
    18.11.2009
    erstelle mal bitte ein neues script im sl4a programm und gib den oberen markierten Text mal händisch ein-das Script tausche ich eh gegen den Text aus.
     
  4. TheDarkWiesel, 22.08.2010 #4
    TheDarkWiesel

    TheDarkWiesel Android-Hilfe.de Mitglied

    Beiträge:
    95
    Erhaltene Danke:
    9
    Registriert seit:
    15.06.2010
    einfach den kompletten ScriptText abtippen? Was ne Arbeit.
     
  5. dahool, 22.08.2010 #5
    dahool

    dahool Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    299
    Erhaltene Danke:
    164
    Registriert seit:
    18.11.2009
    Warte mal bis morgen ab-ich ändere das, um es gleich automatisch über bootlogo rein zu bekommen.
     
  6. TheDarkWiesel, 22.08.2010 #6
    TheDarkWiesel

    TheDarkWiesel Android-Hilfe.de Mitglied

    Beiträge:
    95
    Erhaltene Danke:
    9
    Registriert seit:
    15.06.2010
    ok =) ich versuchs dann morgen nochmal.
     
  7. andyX, 22.08.2010 #7
    andyX

    andyX Android-Hilfe.de Mitglied

    Beiträge:
    67
    Erhaltene Danke:
    1
    Registriert seit:
    21.06.2010
    Habs mal schnell per Batch reingehauen ... ich glaube zu merken das es weniger "laggt"... aber bei mir hat eh schon fast nichts mehr gelaggt.

    JM5+Fix (non SD)+eigene kleinigkeiten

    Benchmark liegt bei 2600 ( keine steigerung )

    Gruß Andreas
     
  8. dahool, 22.08.2010 #8
    dahool

    dahool Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    299
    Erhaltene Danke:
    164
    Registriert seit:
    18.11.2009
    @andyX merci fürs ausprobieren

    ruf mal noch
    echo 0 > /proc/sys/vm/swappiness
    dazu auf und schau einfach mal ob es Veränderungen bringt, wenn man viele Programme auf&zu macht.
     
  9. BigBSES, 22.08.2010 #9
    BigBSES

    BigBSES Fortgeschrittenes Mitglied

    Beiträge:
    322
    Erhaltene Danke:
    29
    Registriert seit:
    10.06.2010
    Phone:
    Samsung Galaxy S7 Edge Schwarz
    am testen und bisher fliegt mein JP3 + Fix ohne SD :)

    EDIT: Erläutere doch mal bitte, was genau passiert mit den änderungen, ich kann nicht mit allem was anfangen :/
     
  10. djmarques, 23.08.2010 #10
    djmarques

    djmarques Ehrenmitglied

    Beiträge:
    13,430
    Erhaltene Danke:
    2,648
    Registriert seit:
    03.08.2009
    Ich werde es auch mal testen ;) Heute abend oder so ;)

    Speedfix hab ich aber drauf...
     
  11. scheichuwe, 23.08.2010 #11
    scheichuwe

    scheichuwe Android-Ikone

    Beiträge:
    5,440
    Erhaltene Danke:
    2,541
    Registriert seit:
    09.09.2009
    Phone:
    LG G4
    JP3 + Speedfix

    Kaum Unterschiede zu vorher auszumachen, hab aber seit den Speedfixes eh kaum Lags gehabt.
    Vielleicht laufen die Menüs irgendwie flüssiger, kann aber auch Einbildung sein.

    Ich hab die paar Zeilen oben in die userinit.sh eingefügt (die für den Speedfix aufgerufen wird). Wer keine externe SD-Karte hat, der kann diese Zeile auch weglassen:
    Code:
    echo anticipatory > /sys/block/mmcblk1/queue/scheduler
     
  12. thE_29, 23.08.2010 #12
    thE_29

    thE_29 Android-Lexikon

    Beiträge:
    1,379
    Erhaltene Danke:
    90
    Registriert seit:
    07.07.2010
    Also habe mein userinit.sh abgeändert und am Ende diese Befehlen hinzufgefügt..
    Was ich nicht ganz verstehe ist, warum sich der Inhalt nicht ändert?

    Also dirty_ratio und swapiness sind auf die Werte, aber alle anderen nicht..

    cat /sys/block/mmcblk0/queue/scheduler = noop [anticipatory] deadline cfq
    Dann mache ich ein
    echo anticipatory > /sys/block/mmcblk0/queue/scheduler
    Und wenn ich wieder ein cat darauf mache, ist das Ergebnis komplett gleich...
    So als würde ihn das gar nicht interessieren..

    Als komplettansicht:
    Also keine Veränderung..
    Das trifft bei allen "anticipatory" Veränderungen zu..
     
  13. scheichuwe, 23.08.2010 #13
    scheichuwe

    scheichuwe Android-Ikone

    Beiträge:
    5,440
    Erhaltene Danke:
    2,541
    Registriert seit:
    09.09.2009
    Phone:
    LG G4
    Ist doch alles gut, anticipatory ist markiert [], die anderen drei sind auch scheduler. Wikipedia (die englische Seite zumindest) bringt da Licht ins Dunkel.
    Standard war übrigens cfq.
     
  14. thE_29, 23.08.2010 #14
    thE_29

    thE_29 Android-Lexikon

    Beiträge:
    1,379
    Erhaltene Danke:
    90
    Registriert seit:
    07.07.2010
  15. thE_29, 23.08.2010 #15
    thE_29

    thE_29 Android-Lexikon

    Beiträge:
    1,379
    Erhaltene Danke:
    90
    Registriert seit:
    07.07.2010
    Weils mir grad eingefallen ist..
    Vorher hatte ich keinen Lagfix oben und hatte 1800 mit diesen Einstellungen..
    Jetzt isses halt über >2200 mit dem LagFix..
     
  16. djmarques, 23.08.2010 #16
    djmarques

    djmarques Ehrenmitglied

    Beiträge:
    13,430
    Erhaltene Danke:
    2,648
    Registriert seit:
    03.08.2009

    Also hast JP3 drauf??

    Dahool ist halt mal genial :D
     
  17. thE_29, 23.08.2010 #17
    thE_29

    thE_29 Android-Lexikon

    Beiträge:
    1,379
    Erhaltene Danke:
    90
    Registriert seit:
    07.07.2010
    Nönö, JM5 ist oben..
    Habe es auf Werksteinstellungen setzen müssen, nachdem ich es unlocked hatte..
    Das Handy hat sich halt nicht mehr starten lassen.. Dachte dann zuerst der LagFix is noch da, aber das war nicht der Fall :D

    Jedenfalls habe ich die Logoanimationsdatei gekillt :D (darum wäre ich dankbar wenns wer hochladen könnte), als ich wieder das LagFix script ausgeführt habe..
     
  18. djmarques, 23.08.2010 #18
    djmarques

    djmarques Ehrenmitglied

    Beiträge:
    13,430
    Erhaltene Danke:
    2,648
    Registriert seit:
    03.08.2009
    Abend Dahool,

    hab den Script mal gemacht.

    Es läuft jetzt nochmal um einen Tik schneller und smoother! Wirklich Klasse! Er springt nocht schneller ins Menü und wieder zurück zum Homescreen. Das Appmenü läuft noch flüssiger.

    Apps öffnen geht noch schneller

    Auch nach 12 offenen Apps läuft noch alles sehr flüssig. Das war vorher nicht der Fall.

    Wirklich sehr gute Arbeit! Weiß zwar nicht genau was du gemacht hast, aber es läuft um einiges besser.

    Wenns nach mir geht kannst das überall mit einbauen :D

    Gruß und Danke!
     
  19. MrBusiness, 23.08.2010 #19
    MrBusiness

    MrBusiness Android-Ikone

    Beiträge:
    4,862
    Erhaltene Danke:
    1,164
    Registriert seit:
    02.08.2010
    Man könnte noch einen dreizeiler dazuschreiben, was da eigentlich passiert und ob das bei jedem mal "Werkseinstellungen" oder Firmware flash weg geht usw, danke!
     
  20. dahool, 23.08.2010 #20
    dahool

    dahool Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    299
    Erhaltene Danke:
    164
    Registriert seit:
    18.11.2009
    Sobald ich Luft habe, kommt ein angepasster Kernel raus (denke dauert aber noch bis mitte/ende nächster Woche). Auf dem Galaxy geht schon noch was mit dem Speed;). Also ich hab jetzt zwei Galaxy von Kollegen angepasst mit dem normalen SpeedFix und einen angepassten Shellscript von hier.Und die laufen schon ganz gut flüssig-auch bei intensiver Nutzung mit vielen Apps.

    Jetzt als nächstes soll in den neuen Kernel noch der HighMemoryKiller Bugfix rein-dann klappts auch mit dem "posen" neben den IPhone Jüngern;)

    @thE_29 hast du eine Logoani Datei schon erhalten?
    @MrBusiness Mehr Infos und automatisierte Anleitung kommt noch. Ja alles weg wenn Hardreset oder Firmware flash. Auch alles weg bei reboot -wenn es nicht in ein Startupscript eingetragen wird.
     
    Zuletzt bearbeitet: 23.08.2010
    Asdain und MrBusiness haben sich bedankt.

Diese Seite empfehlen