OpenVPN Route???

Dieses Thema im Forum "HTC Desire Forum" wurde erstellt von grisu74, 13.08.2010.

  1. grisu74, 13.08.2010 #1
    grisu74

    grisu74 Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    24.07.2010
    Hallo zusammen.

    Seit einigen Tagen versuche ich einen OpenVPN Tunnel zu erstellen.

    Mein Desire verbindet sich zwar mit dem Server, aber ich kann den Server nicht erreichen.
    Über Ping etz. funktioniert es einfach nicht.

    Meine Frage!!

    Wer kann mir helfen, das ich alle Pakete über das tundev sprich über den Tunnel routen kann.

    Gruß Grisu
     
  2. grisu74, 14.08.2010 #2
    grisu74

    grisu74 Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    24.07.2010
    Keiner bei dem OpenVPN läuft??

    Gruß Grisu
     
  3. tto, 14.08.2010 #3
    tto

    tto Android-Hilfe.de Mitglied

    Beiträge:
    104
    Erhaltene Danke:
    6
    Registriert seit:
    20.06.2010
  4. tto, 15.08.2010 #4
    tto

    tto Android-Hilfe.de Mitglied

    Beiträge:
    104
    Erhaltene Danke:
    6
    Registriert seit:
    20.06.2010
    So habs mit der 1.8c zum laufen gebracht:

    zuerst habe ich diese tun.ko: http://forum.xda-developers.com/showpost.php?p=7682123&postcount=8543 für den froyo kernel (2.6.32) geladen und im Verzeichnis \system\lib\modules\ der 1.8c Zip ersetzt.

    Dann diese Rom geflasht.

    Nun auf der SDCARD nen "openvpn" Verzeichnis anlegen, wo die .conf bzw. .ovpn, .key, .crt etc. reinkommen.

    Jetzt in die Client config ein

    push "redirect-gateway def1"

    eintragen.

    Hab dann die OpenVPN Settings App aus dem Market geladen

    unter erweiterten Einstellungen folgendes eingetragen:

    path to configuations: /sdcard/openvpn
    Path to openvpn binary: /system/bin/openvpn
    Load module using: insmod
    Pfath to tun module: /system/lib/modules/tun.ko

    Mit ner consolen APP je nachdem welches Netz man verwendet, diesen Befehl als (su) eingeben:

    # ip ru del table gprs

    or

    # ip ru del table wifi

    das löst das Routing Problem.

    Und hier wird beschrieben wie man das automatisieren kann:

    http://forum.xda-developers.com/showthread.php?t=673764&page=4

    Allerdings komme mit der adb vom developperkit irgend wie nicht klar, krieg keinen connect zum Handy, falls es da ne gute Beschreibung gibt, wäre ich dankbar!
     
    Zuletzt bearbeitet: 15.08.2010
  5. grisu74, 16.08.2010 #5
    grisu74

    grisu74 Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    24.07.2010
    Hey Super.

    Werde das heute gleich mal testen.
    Super Arbeit.

    Danke
     
  6. grisu74, 16.08.2010 #6
    grisu74

    grisu74 Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    24.07.2010
    @tto

    Welches Rom hast du denn genommen?
    1.8c Froyo oder das andere?

    Gruß Grisu
     
  7. tto, 16.08.2010 #7
    tto

    tto Android-Hilfe.de Mitglied

    Beiträge:
    104
    Erhaltene Danke:
    6
    Registriert seit:
    20.06.2010
  8. grisu74, 16.08.2010 #8
    grisu74

    grisu74 Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    24.07.2010
    @tto

    Was für eine rootconsole nimmst du?
    Irgendwie finde ich keine, die richtig funktioniert.

    Gruß Grisu
     
  9. tto, 16.08.2010 #9
    tto

    tto Android-Hilfe.de Mitglied

    Beiträge:
    104
    Erhaltene Danke:
    6
    Registriert seit:
    20.06.2010
    Zuletzt bearbeitet: 16.08.2010
  10. grisu74, 16.08.2010 #10
    grisu74

    grisu74 Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    24.07.2010
    @tto

    irgendwie funktionieren deine Befehle

    # ip ru del table gprs

    or

    # ip ru del table wifi

    nicht so recht.

    Die Konsole schreibt immer No such file or directory

    #edit: Ach noch was. Hast du tun oder tap eingestellt?

    Gruß
     
    Zuletzt bearbeitet: 16.08.2010
  11. tto

    tto Android-Hilfe.de Mitglied

    Beiträge:
    104
    Erhaltene Danke:
    6
    Registriert seit:
    20.06.2010
    Na dann sind die störenden routing tables schon gelöscht bzw. nicht vorhanden und es müsste funzen.

    Nachtrag: dev tun ist bei mir in der config eingestellt
     
    Zuletzt bearbeitet: 16.08.2010
  12. grisu74, 17.08.2010 #12
    grisu74

    grisu74 Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    24.07.2010
    Kannst du mir Bitte deine Configs vom Server und Client schicken? Ich verzweifel langsam. Die Verbindung Steht!!! Bekomme nur keinen Ping auf das Tun-Device des Servers hin. Firewall ist aus. Vom Server aus klappt auch kein Ping auf das Dev vom Handy. Gruß Grisu
     
  13. grisu74, 17.08.2010 #13
    grisu74

    grisu74 Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    24.07.2010
    Ha geschafft!!!!:))))

    Habe meine Configs auf Tap umgestellt.
    Jetzt klappt der Ping und ich kann endlich imap abrufen.

    Gruß Grisu
     
  14. tto

    tto Android-Hilfe.de Mitglied

    Beiträge:
    104
    Erhaltene Danke:
    6
    Registriert seit:
    20.06.2010
  15. grisu74, 17.08.2010 #15
    grisu74

    grisu74 Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    24.07.2010
    Funktioniert leider nicht.
    Genau das selbe Problem.
    "can not execute external programms"
    Und im bootmanager beim installieren kommt auch ein Fehler.

    Gruß
     

Diese Seite empfehlen