1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Problem mit WI-FI/WLAN Conection, Xperia Mini Pro kann nur mit 60 Zeichen umgehen?

Dieses Thema im Forum "Sony Ericsson Xperia Mini / Mini Pro Forum" wurde erstellt von rabbirobert, 08.10.2011.

  1. rabbirobert, 08.10.2011 #1
    rabbirobert

    rabbirobert Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    08.10.2011
    Hallo zusammen,

    Ich habe mir ein Xperia mini pro (kein x10) gekauft und wollte das heute in mein Netzwerk einbinden, dass mit einem 63 Zeichen langen WPA 2 Schlüssel (klein und groß Buchstaben, Zahlen, Umlaute und Sonderzeichen) gesichert ist (+MAC Filter etc).

    Wenn ich meinen Netzwerkschlüssel mit seinen 63 Zeichen (groß/klein Buchstaben, Zahlen, Umlaute, Sonderzeichen) eingebe und auf verbinden klicke, passiert.. gar nichts. KEIN Authentifizierungsversuch.

    Bei einem kürzeren bzw. einfacheren Schlüssel startet zumindest der Authentifizierungsprozess. Bis zu einer Schlüssellänge von 60 Zeichen scheint es also zu funktionieren.

    Hat einer von euch das Problem auch und kann man hier irgendwie abhilfe schaffen (rooten, bootloader oder sowas)?

    Ich möchte nur ungern mein Heimnetzwerk an einen kürzeren Schlüssel anpassen, zumal ich gerne hätte, dass mein Phone sich an die Spezikationen des WLAN / WPA2 Standards hält.

    Sollte dies ein allgemeines Android Thema, dass nur 60 Zeichen im WLAN WPA2 Schlüssel verwendet werden können, bitte ich die MODs den Beitrag entsprechend zu verschieben.

    Im übrigen funktioniert mein altes HTC XDA Phone mit Windows Mobile 6.1 mit dem Key fehlerfrei...

    Vielen Dank und Grüße
     
  2. kessiyean, 08.10.2011 #2
    kessiyean

    kessiyean Android-Lexikon

    Beiträge:
    1,689
    Erhaltene Danke:
    161
    Registriert seit:
    23.12.2010
    Ich denke, es liegt nicht an der Länge, sondern an den Umlauten und Sonderzeichen. Damit kommen so einige Geräte nicht klar.
     
  3. -Hotte-, 08.10.2011 #3
    -Hotte-

    -Hotte- Android-Hilfe.de Mitglied

    Beiträge:
    113
    Erhaltene Danke:
    28
    Registriert seit:
    24.01.2010
    Ich bezweifle, das hier viele Leute unterwegs sind, die ihr Heimnetzwerk mit einem 63 Zeichen langen Schlüssel absichern.
    Das grenzt ja fast an Verfolgungswahn. Und ich dachte, mit meinen knapp über 20 Zeichen schon fast zu übertreiben.

    Des weiteren sollte man auf Umlaute in Passwörtern verzichten. Damit können nicht alle Geräte umgehen. Vielleicht liegt es ja daran.

    Sent from my GT-P7500 using Tapatalk
     
  4. rabbirobert, 09.10.2011 #4
    rabbirobert

    rabbirobert Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    08.10.2011
    nun ja, alle meine Heimkomponenten sind mit diesem Schlüssel im Netz angemeldet, sowie viele Notebooks von Freunden und Bekannten.

    Bisher 34 Clients erfolgreich...

    Und an den Sonderzeichen sollte es ja nicht liegen, denn das funktioniert ja im Netzwerk wie beschrieben grundsätzlich, und auch auf dem xperia funktioniert das... allerdings nur mit bis zu 60 Zeichen und nicht mit 61-63 Zeichen wie es der WPA2 Standard eigentlich erlaubt :-(

    Hätte einer von euch Interesse das nicht mal auf seinem Gerät zu Hause auszuprobieren, wie das mit einem 63 stelligen Netzwerkschlüssel auf dem xperia bzw. sonstigem Android 2.3.3 aussieht?

    Danke euch und Grüße
     
  5. kemika, 09.10.2011 #5
    kemika

    kemika Android-Hilfe.de Mitglied

    Beiträge:
    83
    Erhaltene Danke:
    9
    Registriert seit:
    26.06.2011
    also ich denke nicht das es an den sonderzeichen liegt. mein schlüssel beinhaltet auch !,%,# und @. funtioniert ohne probleme ;)

    edit:
    hab es gerade ausprobiert und es funktioniert bei mir auch mit 63 zeichen ohne probleme ;)
     
    Zuletzt bearbeitet: 09.10.2011
  6. kessiyean, 09.10.2011 #6
    kessiyean

    kessiyean Android-Lexikon

    Beiträge:
    1,689
    Erhaltene Danke:
    161
    Registriert seit:
    23.12.2010
    Wenn es auch mit 63 Zeichen und Sonderzeichen funktioniert, dann ist vielleicht die Anzahl der zulässigen Geräte überschritten, die der Router zuläßt? Hast du schon mal probiert, dich in ein anderes WLAN Netzwerk einzuwählen? Wenn das funktioniert, dann kann es nur noch an der Geräteanzahl liegen :unsure:
     
  7. rabbirobert, 09.10.2011 #7
    rabbirobert

    rabbirobert Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    08.10.2011
    Danke euch für die Antworten.

    Danke für die Info!
    Eine Frage noch: Was für ein Mobile Phone hast du benutzt? Auch ein Experia mini pro? Müsste ich zu Vergleichszwecken wissen,

    @kessiyean:
    An der Anzahl der Geräte liegt es auch nicht, denn wie gesagt wenn ich den Schlüssel temporär auf 60 Zeichen begrenze funktioniert das Xperia ja.


    Ich werde heute nachmittag mal den 63-stelligen Netzwerkschlüssel mit dem Samsung Galaxy S2 meiner Schwester probieren. Wenn es das Problem auch hat, hm mal schauen, wenn nicht dann geht das xperia mini pro leider postwendend an Amazon zurück. Schade eigentlich weil es sonst eigentlich ein schickes Teil ist (nur ein wenig zu dick).

    Ich hätte schon ganz gerne ein Mobile Phone mit kompletter Tastatur im Slider Mechanismus, viele bleiben da nicht übrig, die akzeptable Renzensionen im Netz haben :-(


    Grüße
     
  8. kessiyean, 09.10.2011 #8
    kessiyean

    kessiyean Android-Lexikon

    Beiträge:
    1,689
    Erhaltene Danke:
    161
    Registriert seit:
    23.12.2010
    Ich würde es eher anders herum probieren... mit dem Mini Pro eine Verbindung zu einem anderen WLAN herstellen... wenn das nicht funktioniert, ist es defekt, wenn es funktioniert... stimmt irgendwas anderes nicht. Weil es scheint ja zu gehen... nur halt bei dir nicht :sad:
     
  9. rabbirobert, 10.10.2011 #9
    rabbirobert

    rabbirobert Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    08.10.2011
    Ohne Worte...

    Super Antwort von Sony Ericsson bzw. der Support Firma^^

    Also damit hat sich Sony Ericsson, und damit das Xperia disqualifiziert.
    Und so ungern ich das sage leider auch Android, denn auf dem Samsung Galaxy S2 ist das gleiche Problem. Mein 63stelliger Netzwerkschlüssel funktioniert nicht, nehme ich aber die letzten 3 Zeichen weg (die ersten 60 bleiben von meinem Schlüssel), dann funktioniert die Authentifizierung.

    Dann muss ich das Ganze mal mit dem HTC 7 pro (Windows Phone 7) und dem Palm Pre Plus (HP WebOS) ausprobieren.

    Danke euch trotzdem für eure Antworten und Hilfe, ist bei mir halt ein sehr individuelles Problem ;)

    Grüße
     
  10. kemika, 11.10.2011 #10
    kemika

    kemika Android-Hilfe.de Mitglied

    Beiträge:
    83
    Erhaltene Danke:
    9
    Registriert seit:
    26.06.2011
    ja, ein Xperia mini pro.

    versteh ich jetzt aber nicht warum das überhaupt gegangen ist wenn android anscheinend nur 60 zeichen unterstützt :confused:
    vieleicht ging es ja deshalb, weil die letzten 52 zeichen vom pw relativ primitiv waren (einfach 2 mal alle 26 buchstaben der tastertur von Q bis M)?!?
     
  11. rabbirobert, 11.10.2011 #11
    rabbirobert

    rabbirobert Threadstarter Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    08.10.2011
    @kemika:
    Naja vielleicht gibt es da mehr alsl eine Abhängigkeit, vieleicht werden manche Sonderzeichen/Umlaute von Android als 2 Zeichen gewertet. Keine Ahnung.

    But @ All by the way:
    Ich habe mir jetzt mal testweise ein Experia X1 geliehen (Windows Mobile 6.1) und damit geht es.
    Also scheint es, ggf in Verbindung mit dem Aufbau des Netzwerkschlüssels, an der WPA2 Implementierung in Android zu liegen.

    Grüße
     

Diese Seite empfehlen