1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Probleme beim Unlocken des Bootloaders unter JB

Dieses Thema im Forum "Google Nexus S Forum" wurde erstellt von Shoashy, 04.08.2012.

  1. Shoashy, 04.08.2012 #1
    Shoashy

    Shoashy Threadstarter Junior Mitglied

    Beiträge:
    29
    Erhaltene Danke:
    0
    Registriert seit:
    11.11.2011
    Hallo,

    Ausgangssituation ist ein neues Nexus S, Vorhaben wie hier beschrieben: http://www.android-hilfe.de/root-hacking-modding-fuer-nexus-s/281544-rooten-unter-4-1-1-a.html

    Die Probleme beginnen aber bereits beim ersten Schritt, dem Entsperren des Bootloaders. Im normalen USB-Modus erkennt mein Win 7 Rechner, die USB-Verbindung sofort, ich kann über den WinExplorer auf die Inhalte des Wechseldatenträgers zugreifen und auch schreiben.

    Versuche ich jedoch im Fastboot Mode, eine USB-Verbindung herzustellen, klappts nicht, das Nexus wird nicht erkannt (egal ob mit oder ohne debugging). Auch taucht es, anders als an verschiedenen Stellen beschrieben, nicht im WinGerätemanager auf.

    Was soll ich tun oder gebe ich mich geschlagen und folge dem alten Sinnspruch: never touch a running system?
    :cursing:

    Thx bereits jetzt
    Shoashy
     
  2. coolfranz, 04.08.2012 #2
    coolfranz

    coolfranz Android-Guru

    Beiträge:
    3,509
    Erhaltene Danke:
    649
    Registriert seit:
    17.11.2010
    Übers Debugging musst du dir keine Sorgen machen, dass hat nur Auswirkungen, wenn das Gerät läuft. Fastboot /Bootloader Mode ist da Eigenständig.

    Anderen PC USB Port probiert?

    Wie bootest du in den Fastboot Mode?

    PS: die Anleitung: http://www.android-hilfe.de/anleitu...-customrecovery-custom-rom-flashen-2-3-a.html kannst du bedenkenlos verwenden.

    Empfehlen würde ich dir aber als Recovery das Touch Recovery 5.8.0.2: http://forum.xda-developers.com/showthread.php?t=1471120
    und zum Rooten die aktuellste Superuser.zip von http://Androidsu.com/superuser
     
    Zuletzt bearbeitet: 04.08.2012
  3. Shoashy, 04.08.2012 #3
    Shoashy

    Shoashy Threadstarter Junior Mitglied

    Beiträge:
    29
    Erhaltene Danke:
    0
    Registriert seit:
    11.11.2011
    Danke, für die schnelle Antwort, Coolfranz.
    Die USB Ports habe ich alle durchprobiert, ohne Änderung. Aber klar: ich könnte es mal an einem anderen Rechner probieren...
    In den Fastboot Mode komme ich wie allgemein beschrieben: Volume up gedrückt und dann On. Gibt es denn noch eine andere Möglichkeit?
     
  4. coolfranz, 04.08.2012 #4
    coolfranz

    coolfranz Android-Guru

    Beiträge:
    3,509
    Erhaltene Danke:
    649
    Registriert seit:
    17.11.2010
    Ok, passt - dachte nur, dass du evtl. gar nicht im Fastboot/ Bootloader Mode bist, ist auch schon hin und wieder passiert...
    Gibt noch ne andere Möglichkeit, und zwar beim laufenden Gerät via "adb reboot bootloader" - das wird hier aber nicht die Lösung sein...

    Hast du den Gerätemanager schon mal durchforstet, nicht das da doch irgendein Android Gerät auftaucht, evtl. mit einem alten/falschen Treiber von einem deiner anderen Android Geräte?
     
  5. Shoashy, 04.08.2012 #5
    Shoashy

    Shoashy Threadstarter Junior Mitglied

    Beiträge:
    29
    Erhaltene Danke:
    0
    Registriert seit:
    11.11.2011
    Also im Gerätemanager manifestiert sich das Nexus lediglich im Punkt "Tragbare Geräte" als Laufwerk "I". Allerdings wenn ich in der Taskleiste auf die Option "Hardware sicher entfernen..." gehe steht dort "Nexus S auswerfen -Wechseldatenträger I". Mein Windows weiß also irgendwie schon, dass es hier mit einem Nexus zu tun hat.
     
  6. coolfranz, 04.08.2012 #6
    coolfranz

    coolfranz Android-Guru

    Beiträge:
    3,509
    Erhaltene Danke:
    649
    Registriert seit:
    17.11.2010
    Dann ist dein Nexus aber nicht im Bootloader/ Fastboot Mode. Nur der ist jetzt mal interessant...
     
  7. Shoashy, 04.08.2012 #7
    Shoashy

    Shoashy Threadstarter Junior Mitglied

    Beiträge:
    29
    Erhaltene Danke:
    0
    Registriert seit:
    11.11.2011
    Im Fastboot Mode ist bei hergestellter USB-Verbindung der Laufwerksbuchstabe weg, im Hardware auswerfen - Menü taucht kein Nexus mehr auf
     
  8. coolfranz, 04.08.2012 #8
    coolfranz

    coolfranz Android-Guru

    Beiträge:
    3,509
    Erhaltene Danke:
    649
    Registriert seit:
    17.11.2010
    richtig, drum hab ich ja auch gesagt, dass du den GERÄTEMANAGER durchforsten sollst ;-)
     
  9. Shoashy, 04.08.2012 #9
    Shoashy

    Shoashy Threadstarter Junior Mitglied

    Beiträge:
    29
    Erhaltene Danke:
    0
    Registriert seit:
    11.11.2011
    Ah Heidiho! Nunmehr habe ich unter Andere Geräte ein Android 1.0 war vor her nicht da

    Der ursprüngliche Beitrag von 11:16 Uhr wurde um 11:44 Uhr ergänzt:

    alles klar, coolfranz, danke für die hilfe: bootloader ist offen.
    dann gehe ich weiter nach der von dir benannten Anleitung vor
    beim rooten - würde ich mal denken - Möglichkeit zwei mit aktuellem Superuser-3-1-3-armsigned, oder?
     
  10. coolfranz, 04.08.2012 #10
    coolfranz

    coolfranz Android-Guru

    Beiträge:
    3,509
    Erhaltene Danke:
    649
    Registriert seit:
    17.11.2010
    Wenn dein SDK / Adb richtig eingerichtet ist solltest du das Gerät nun via "fastboot devices" "sehen" können.

    Achso, bei Punkt 3 _Unterpunkt 2 meinst du...

    Ja, genau, wie in der Anleitung mit der von dir genannten .zip. Und bei 2 halt das CWM 5.8.0.2.
     
    Shoashy bedankt sich.
  11. Shoashy, 04.08.2012 #11
    Shoashy

    Shoashy Threadstarter Junior Mitglied

    Beiträge:
    29
    Erhaltene Danke:
    0
    Registriert seit:
    11.11.2011
    wenn ich im cmd fastboot devices eingebe bekomme ich dort die serial number des phones. meinst du das?

    Der ursprüngliche Beitrag von 11:47 Uhr wurde um 11:56 Uhr ergänzt:

    alles klar. vielen Dank.
    falls irgendwas nicht klappt, darf ich dich nochmal ansprechen?

    Der ursprüngliche Beitrag von 11:56 Uhr wurde um 12:53 Uhr ergänzt:

    Achgottachgottachgott.
    der Punkt 3.2. buchstabe b. der Anleitung führt bei mir nicht in die Custom Recovery, sondern zu einem rittlings liegenden Androiden mit geöffnetem Bauch und rotem Warndreieck drüber. Nach geraumer Zeit verschwindet der grüne Junge und das Nexus bootet neu. Was tun?
     
  12. coolfranz, 04.08.2012 #12
    coolfranz

    coolfranz Android-Guru

    Beiträge:
    3,509
    Erhaltene Danke:
    649
    Registriert seit:
    17.11.2010
    Siehe Anleitung ganz unten, beim Neustart wird das Recovery überschrieben, also Recovery im Fastboot flashen und dann gleich ins Recovery wechseln, das Nexus darf dazwischen nicht hochfahren.

    Genau, das sagt dir, dass dein Gerät erkannt wurde.
     
  13. Shoashy, 04.08.2012 #13
    Shoashy

    Shoashy Threadstarter Junior Mitglied

    Beiträge:
    29
    Erhaltene Danke:
    0
    Registriert seit:
    11.11.2011
     

Diese Seite empfehlen