1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Root, aber nur auf dem Telefon

Dieses Thema im Forum "Root / Hacking / Modding für T-Mobile G2 Touch" wurde erstellt von suisse, 17.09.2009.

  1. suisse, 17.09.2009 #1
    suisse

    suisse Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    71
    Erhaltene Danke:
    0
    Registriert seit:
    06.09.2009
    Hi

    Seit gestern bin ich auf dem Telefon root, was ich im File Explorer sehen kann. Danke an dieser Stelle für die kinderleichte Anleitung.

    Ist es aber richtig, dass ich z. B. kein adb push in ein Systemverzeichnis machen kann?

    Ich kann per adb-shell und mit su zwar root werden, aber weil die Konsole keinen cp-Befehl zur Verfügung stellt, bleibt mir zum Ersetzen von Systemdateien nur der Weg über fastboot mit dem recovery image.

    Ist das bei euch auch so, oder könnt ihr beliebig pushen?
     
  2. patzek, 17.09.2009 #2
    patzek

    patzek Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    17.09.2009
    Ich push die files immer auf die SDCARD und ersetze die systemdateien dann in der adb shell
     
  3. suisse, 17.09.2009 #3
    suisse

    suisse Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    71
    Erhaltene Danke:
    0
    Registriert seit:
    06.09.2009
    Das wollte ich auch machen, aber ohne cp ?
     
  4. patzek, 17.09.2009 #4
    patzek

    patzek Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    17.09.2009
    wenn du z.b. die datei xyz.123 kopieren willst dann kannst du das per "cat /quelle/xyz.123 > /ziel/xyz.123" machen
     
  5. suisse, 17.09.2009 #5
    suisse

    suisse Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    71
    Erhaltene Danke:
    0
    Registriert seit:
    06.09.2009
    klar! guter tipp, danke. das wäre dann ausnahmsweise kein "UUOC" (useless use of cat)... :)
     
  6. razorblade, 18.09.2009 #6
    razorblade

    razorblade Android-Hilfe.de Mitglied

    Beiträge:
    54
    Erhaltene Danke:
    10
    Registriert seit:
    16.08.2009
    Phone:
    HTC Hero
    Liegt vermutlich daran, dass du sie nicht vorher gemountet hast.
    DATA und System muss man im laufenden Betrieb mounten.
     

Diese Seite empfehlen