1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

WiFi WPA2-Enterprise vergisst Zertifikate

Dieses Thema im Forum "LG Optimus Speed (P990) Forum" wurde erstellt von allesneumachtdermai, 26.05.2011.

  1. allesneumachtdermai, 26.05.2011 #1
    allesneumachtdermai

    allesneumachtdermai Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    118
    Erhaltene Danke:
    7
    Registriert seit:
    28.05.2009
    Hi,

    ich habe mich letztens erfolgreich in ein WPA2-Enterprise-Netz (also mit. pers. Zertifikat) eingeklinkt und alles lief nach Plan.

    Ich hätte erwartet, dass sich das Gerät die Zertifikate merkt und beim nähsten Mal wieder in dieses Netz kommt (so wie es das bei normalem WPA ohne Certs macht).

    Tut es nicht. Am nächsten Tag waren die Zertifikate vergessen und ich hätte diese erneut importeren müssen.

    Ist das normal? Ein Bug? Mache ich einen Fehler?

    Hat jemand Erfahrung damit?

    Nutze noch das Stock ROM ohne Root.

    Danke, anmdm
     
  2. MeisterQuitte, 26.05.2011 #2
    MeisterQuitte

    MeisterQuitte Junior Mitglied

    Beiträge:
    25
    Erhaltene Danke:
    1
    Registriert seit:
    19.03.2011
    Bei mir hat er sich Zertifikate dauerhaft gemerkt.

    Problem war, das ich beim eingeben des Zertifikats ein Sicherheitschlüssel (Passwort zur Verschlüsselung der EInwahldaten) angeben musste.
    Wenn sich das LGOS nun automatisch mit dem Netzwerk verbinden sollte, hat es dies nicht gemacht, weil er den Sicherheitsschlüssel benötigt, aber gar nicht danach gefragt hat (Einwahl lief ins Leere)!
    Trotzdem war bei mir das Sicherheitszertifikat weiter vorhanden:

    Falls das bei dir auch der Fall ist:
    Die Lösung bei mir war es das Sicherheitszertifikat (CA2 Telekom) gar nicht erst zu installieren. Es war gar nicht nötig (obwohl es eigentlich nötig sein sollte)!


    Falls das Sicherheiszertifikat wirklich gelöscht wird kann ich nicht helfen (ist bei mir (Stock) nicht passiert)
     
  3. allesneumachtdermai, 26.05.2011 #3
    allesneumachtdermai

    allesneumachtdermai Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    118
    Erhaltene Danke:
    7
    Registriert seit:
    28.05.2009
    Danke für Deine Antwort. An die Sache mit dem Passwort erinnere ich mich. Aber so ganz verstehe ich noch nicht, wie Du das meinst:

    Du hast kein Zertifikat erneut installiert, und dann hat es funktioniert? Vielleicht hatte sich das Gerät das Zertifikat in den Settings gemerkt, und deshalb geht es. Aber wieso will er dann kein Passwort mehr haben?

    Ohne persönliches Zertifikat kann das bei echtem WPA2-E. nicht gehen. Da ist was faul ;)

    Das Zertifikat von der SD-Card ist übrigens bei mir weg, in den Settings steh nichts mehr. Ich kann also nichts löschen.

    Was soll ich tun?

    anmdm
     
  4. allesneumachtdermai, 26.05.2011 #4
    allesneumachtdermai

    allesneumachtdermai Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    118
    Erhaltene Danke:
    7
    Registriert seit:
    28.05.2009
    Ergänzung: Ich habe gerade gesehen, dass der Haken bei "Anwendungen Zugriff auf sichere Anmeldeinformationen" (oder so ähnlich) nicht mehr gesetzt war. Habe das mal wieder aktivert. Teste das mal in den nächsten Tagen.

    ist hier jemand, bei dem das dauerhaft klappt?
     
  5. sensitron, 26.05.2011 #5
    sensitron

    sensitron Android-Hilfe.de Mitglied

    Beiträge:
    52
    Erhaltene Danke:
    4
    Registriert seit:
    13.04.2011
    Hab ähnliche Probleme mit Eduroam. Zertifikate sind installiert, ich komm auch ins Wlan rein, aber wenn ich mich auslogg und wieder ins Wlan gehe klappt es nicht mehr. Daheim im Wlan habe ich solche Probleme nicht.
    Das Offene Wlan netz in der Uni(also ohne Eduroam) funktioniert soweit gut.
     
  6. allesneumachtdermai, 26.05.2011 #6
    allesneumachtdermai

    allesneumachtdermai Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    118
    Erhaltene Danke:
    7
    Registriert seit:
    28.05.2009
    Also doch ein Bug? Ich muss da nochmal mehr mit rumprobieren.
     
  7. MeisterQuitte, 27.05.2011 #7
    MeisterQuitte

    MeisterQuitte Junior Mitglied

    Beiträge:
    25
    Erhaltene Danke:
    1
    Registriert seit:
    19.03.2011
    Muss du den beim einrichten der Verbindung (nach dem Angeben der Benutzerdaten und des Passworts) ein Schlüssel angeben (erneutes Passwort)???
     
  8. MeisterQuitte, 27.05.2011 #8
    MeisterQuitte

    MeisterQuitte Junior Mitglied

    Beiträge:
    25
    Erhaltene Danke:
    1
    Registriert seit:
    19.03.2011
    Das telekomm root ca 2 was bei mir gefordert wurde braucht man unter Linux (und Android) meist nicht!

    Um welches Zertifikat handelt es sich den?
     
  9. allesneumachtdermai, 27.05.2011 #9
    allesneumachtdermai

    allesneumachtdermai Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    118
    Erhaltene Danke:
    7
    Registriert seit:
    28.05.2009
    Ich hab's gerade nochmal ausprobiert. Wenn ich WiFi einschalte, werde ich nicht nach einem Passwort (für die sicheren Zugangsinfos) gefragt. Eine Verbindung in das vormals konfigurierte und funktionierende Netz schlägt fehl. Ich muss offenbar erstmal die sicheren Anmeldeinfos freischalten (unter Einstellungen->Standort und Sicherheit).

    Wenn ich dann ins Netz will, versucht er es, scheitert aber, weil überhaupt kein Zertifikat mehr da ist. Argh!

    Unser Netz erfordert ein Root-Zertifikat und auch ein privates. Beides hatte ich drauf und alles lief -- leider nur genau ein Mal, danach war alles wieder vergessen.
     
  10. allesneumachtdermai, 27.05.2011 #10
    allesneumachtdermai

    allesneumachtdermai Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    118
    Erhaltene Danke:
    7
    Registriert seit:
    28.05.2009
    Ich glaube, ich hab's. Man muss nach einem Neustart zuerst

    Einstellungen-->Standort und Sicherheit-->Sichere Anmeldeinformationen verwenden

    aktivieren (=Passwortabfrage für diese Einstellungen). Danach wendet das System auch das zuvor importierte private Zertifikat an.

    Nach einem Neustart ist die Einstellung wieder von selbst deaktiviert!
     

Diese Seite empfehlen