Inland-Roaming mit dem Alcatel 997D

  • 10 Antworten
  • Neuester Beitrag
Diskutiere Inland-Roaming mit dem Alcatel 997D im Alcatel One Touch 997D / Base Lutea 3 Forum im Bereich Alcatel Forum.
T

tom.luft

Neues Mitglied
Ich versuche seit ein paar Stunden Inlands-Roaming auf dem Smartphone zum Laufen zu bringen und schaffe es einfach nicht.
Es gibt im Internet ein paar Vorschläge zu dem Thema:

  1. modifiziere die Datei /etc/spn_conf.xml ([OFFURL]https://www.android-hilfe.de/android-ice-cream-sandwich/182499-nationales-roaming-ics.html[/OFFURL]) Das funktioniert aber leider ab ICS nicht mehr (die fake-Provider werden ignoriert)
  2. herumfrickeln mit /system/framework/framework.jar (Solution for roaming problem with MVNO's! - xda-developers). Das funktioniert aber leider mit dem Alcatel nicht, weil es nicht deodexed ist.
  3. Ausführen eines Skripts, das die Variablen gsm.operator.alpha und gsm.operator.isroaming überschreibt (http://forum.xda-developers.com/showpost.php?p=23394954&postcount=2669). Diese Variante beschäftigt mich eben seit geraumer Zeit.
Nachdem das Überschreiben der beiden Variablen nichts gebracht hat, habe ich mir folgendes Skript gebastelt um mehr Informationen zu erhalten und eventuell etwas interessantes zu entdecken. Alle Versuche waren bis jetzt fruchtlos.

Anmerkung: 23207 ist die Kennung meines MVNOs (tele.ring) und 23203 die Kennung meines "echten" Providers (T-Mobile Austria)
Code:
#!/system/bin/sh

print_my_prop () { 
echo "******** $1 ********"
getprop | grep $1
echo ---------------------------
}

print_my_prop "23207"
print_my_prop sim
print_my_prop roaming
print_my_prop tele
print_my_prop data

echo "******** setze Variablen ********"

setprop gsm.sim.operator.alpha "T-Mobile Austria"
setprop gsm.sim.operator.default-name "T-Mobile Austria"
setprop gsm.sim.operator.numeric "23203"
setprop gsm.operator.isroaming false
echo ---------------------------
print_my_prop roaming
Die Ausgabe des Skripts ist wie folgt:
Code:
******** 23207 ********
[gsm.sim.operator.numeric]: [23207]
---------------------------
******** sim ********
[gsm.sim.inserted]: [1]
[gsm.sim.operator.alpha.2]: []
[gsm.sim.operator.alpha]: []
[gsm.sim.operator.default-name]: [tele - ring]
[gsm.sim.operator.iso-country.2]: []
[gsm.sim.operator.iso-country]: [at]
[gsm.sim.operator.numeric.2]: []
[gsm.sim.operator.numeric]: [23207]
[gsm.sim.retry.pin1]: [3]
[gsm.sim.retry.pin2]: [3]
[gsm.sim.retry.puk1]: [10]
[gsm.sim.retry.puk2]: [10]
[gsm.sim.ril.phbready.2]: [false]
[gsm.sim.ril.phbready]: [true]
[gsm.sim.state.2]: [ABSENT]
[gsm.sim.state]: [READY]
[gsm.siminfo.ready]: [true]
[persist.radio.default_sim]: [0]
[persist.radio.default_sim_mode]: [12]
[persist.sys.simcountry]: [DE]
[persist.sys.simlanguage]: [de]
[ril.ready.sim]: [true]
---------------------------
******** roaming ********
[gsm.operator.isroaming.2]: [false]
[gsm.operator.isroaming]: [true]
[gsm.roaming.indicator.needed]: [true]
[ro.com.android.dataroaming2]: [false]
[ro.com.android.dataroaming]: [false]
---------------------------
******** tele ********
[gsm.sim.operator.default-name]: [tele - ring]
[gsm.stk.perso.app_title]: [tele.ring]
---------------------------
******** data ********
[dalvik.vm.mtk-stack-trace-file]: [/data/anr/mtk_traces.txt]
[dalvik.vm.stack-trace-file]: [/data/anr/traces.txt]
[ro.com.android.dataroaming2]: [false]
[ro.com.android.dataroaming]: [false]
[ro.crypto.fs_mnt_point]: [/data]
[ro.crypto.fs_real_blkdev]: [/emmc@usrdata]
[ro.mobile_data_enable]: [1]
[vold.post_fs_data_done]: [1]
---------------------------
******** setze Variablen ********
---------------------------
******** roaming ********
[gsm.operator.isroaming.2]: [false]
[gsm.operator.isroaming]: [false]
[gsm.roaming.indicator.needed]: [true]
[ro.com.android.dataroaming2]: [false]
[ro.com.android.dataroaming]: [false]
---------------------------
Die Variablen werden alle anstandslos gesetzt, aber an dem Roamingsysmbol und dem Zwang, Datenroaming aktivieren zu müssen ändert sich nichts.

Ich weiß nicht nach welchen Variablen ich noch suchen soll, bzw. welche Variablen ich noch ändern könnte.

Habt ihr Vorschläge?

Edit: Bemerkenswert ist auf jeden Fall, dass die Variable gsm.sim.operator.alpha bevor ich sie mit meinem Skript setze leer ist. Das Gerät benutzt diese Variable also gar nicht?!
 
Zuletzt bearbeitet:
FreeBird123

FreeBird123

Ambitioniertes Mitglied
Hi,

hatte ich auch, aber seit dem Dezember Update fürs 997D kann ich Roaming deaktiviert lassen und die Datenverbindung funktioniert trotzdem.

Bin aber bei Bob (Roaming über A1).

Bist Du auf der letzten Firmware ?

Gruß
FreeBird
 
T

tom.luft

Neues Mitglied
Ja, das Update war meine erste Aktion mit dem Handy. Nach dem Root wird zwar nicht mehr die 4.0.4-01001 sondern nur 4.0.4 angezeigt, es ist aber nachwievor die neueste Firmware (vB5Y-0).

Es ist jedenfalls interessant, dass es bei dir funktioniert.
 
Zuletzt bearbeitet von einem Moderator:
kokurya

kokurya

Erfahrenes Mitglied
Also bei mir mit Bob / A1 funktioniert es nur wenn roaming aktiviert ist....
 
FreeBird123

FreeBird123

Ambitioniertes Mitglied
Ich hab leider keine Ahnung warum es bei mir funktioniert und bei euch nicht.

Hier mal meine Konfiguration:

Auf SIM Slot 1 meine Bob Karte (mit 3G und Datenverbindung)
Auf SIM Slot 2 eine A1 Karte (Firmennummer).

Auch bei deaktivierter A1 Karte funktioniert die Datenverbindung noch ohne Roaming.

Upgedatet habe ich nicht über OTA sondern mit dem Alcatel Software Updater.

Mein Telefon ist nicht gerootet.

Meine Softwarestände:
Firmware-Version: 4.0.4
Baseband-Version: MAUI.11 AMD.W12.22.SP.V1.F4.P1, 2012/11/12 15:54
Kernel-Version: 3.0.13 android-bld@aclgcl-ubnt32 #1 SMP PREEMPT Sat Nov 24 16:37:34 CST 2012
Build-Nummer: Ice Cream Sandwich
Benutzerdefinierte Version: vB5Y-0

Sollte alles bei euch gleich sein, weiß ich auch nicht weiter.

Gruß
FreeBird
 
R

Raphings

Neues Mitglied
Ist besser wenn sie nicht den letzten update draufspielt. Ich kenne solche probleme garnicht... :D
 
T

tom.luft

Neues Mitglied
FreeBird123 schrieb:
Ich hab leider keine Ahnung warum es bei mir funktioniert und bei euch nicht.

Hier mal meine Konfiguration:

Auf SIM Slot 1 meine Bob Karte (mit 3G und Datenverbindung)
Auf SIM Slot 2 eine A1 Karte (Firmennummer).

Auch bei deaktivierter A1 Karte funktioniert die Datenverbindung noch ohne Roaming.

Upgedatet habe ich nicht über OTA sondern mit dem Alcatel Software Updater.

Mein Telefon ist nicht gerootet.

Meine Softwarestände:
Firmware-Version: 4.0.4
Baseband-Version: MAUI.11 AMD.W12.22.SP.V1.F4.P1, 2012/11/12 15:54
Kernel-Version: 3.0.13 android-bld@aclgcl-ubnt32 #1 SMP PREEMPT Sat Nov 24 16:37:34 CST 2012
Build-Nummer: Ice Cream Sandwich
Benutzerdefinierte Version: vB5Y-0

Sollte alles bei euch gleich sein, weiß ich auch nicht weiter.

Gruß
FreeBird
Ich hab genau die gleichen Versionen, mein Gerät ist aber gerootet.
Es wäre auf jeden Fall auch bemerkenswert wenn der Hersteller einfach so einen Bug in Android (und nichts anderes ist das!) ausmerzen würde.
Bisher gibts das (glaube ich) ja sonst nur bei CMs und bei Brandingversionen von 3 (hier gibts jeweils einfach eine zusätzliche Option "nationales Datenroaming" im Menü).

Das Programm Alcatel Software Updater kann ich übrigens nirgends finden; nur One Touch Upgrade Q 1.9.9, das ist aber nicht kompatibel mit dem 997D.
 
Zuletzt bearbeitet:
kokurya

kokurya

Erfahrenes Mitglied
Hat mittlerweile jemand eine Lösung gefunden?
 
T

tom.luft

Neues Mitglied
kokurya schrieb:
Hat mittlerweile jemand eine Lösung gefunden?
Laut https://code.google.com/p/android/issues/detail?id=3499 ist das Problem mit Android 4.2.2 behoben. Es ist aber mehr als fraglich, ob es diese Version jemals für das OT geben wird.

Ich vermute mal, dass das Alcatel wegen der 2 Simkarten anders funktioniert und deswegen
Code:
setprop gsm.sim.operator.alpha <dein provider>
wie in der Diskussion vorgeschlagen wird keinen Sinn macht (siehe auch meinen ersten Post!).