[Frage] TWRP Restore PIN/Pattern Bug. Was ist die Ursache?

  • 0 Antworten
  • Neuester Beitrag
Diskutiere [Frage] TWRP Restore PIN/Pattern Bug. Was ist die Ursache? im Allgemeines zum Custom-Recovery im Bereich Allgemeines zu Root, Kernel und Custom-Roms.
Kiwi++Soft

Kiwi++Soft

Ehrenmitglied
Seit Android 6.0 kommt es bisweilen beim Restoren eines TWRP-Backups zum 'TWRP Restore PIN/Pattern Bug'.

Man spielt ein ein TWRP Backup ein, und wenn man dann das Android bootet, wird man nach PIN oder Pattern gefragt, aber wenn man die/das korrekte PIN/Pattern eingibt, wird das Gerät nicht entsperrt, sondern PIN oder Pattern als falsch gemangelt.

Ich habe bisher beobachtet, dass das Problem dann auftritt, wenn man zwischen Backup und Restore ein anderes ROM installiert hat, und daher einen Factory-Reset durchgeführt hat.

Das Problem ist zwar leicht lösbar, (man muss wieder ins TWRP booten, und die PIN oder das Pattern löschen, Anleitungen findet man viele im Netz), aber mich würde die Ursache interessieren.

Man kann zwar lesen, dass das am mit Android 6.0 eingeführten Gatekeeper-Service liegt, aber mir leuchtet noch nicht ein, wieso dieser das Problem verursachen könnte. Letztlich wird der Key des Gatekeeper-Services ja auch in der '/data-Partition' gespeichert, genau so wie die PIN/Pattern'-Information und sollte somit eigentlich passen.

Sinn würde es nur ergeben, wenn der Key des Gatekeepers irgendwo anders im Gerät gespeichert würde und nach einem Factory-Reset neu generiert wird.Wenn dann das TWRP-Backup wieder eingespielt würde, könnte es nicht zum neu generierten Key passen.

Leider habe ich bisher keine sinnvolle Erklärung zu dem Phänomen finden können. Ich würde mich über eine sinnvolle Erklärung oder einem Link zu einer solchen freuen!

Danke im voraus!
 
Ähnliche Themen - [Frage] TWRP Restore PIN/Pattern Bug. Was ist die Ursache? Antworten Datum
0
2
57