Icon-Cache vergrößern?

  • 6 Antworten
  • Neuster Beitrag
ollifoto

ollifoto

Neues Mitglied
Threadstarter
Hallo! :)

Ich-bin-ratlos. Dank Rooting meines ZTE Blade L5 konnte ich "ein paar" Apps mehr installieren, welche nun auf der 2. Partition der SD-Karte liegen. Und jeder habe ich ein eigenes Icon gebastelt und auch zugewiesen, nur setzt Android ab und an immer wieder verschiedene App-Icons nach einem Neustart des Gerätes auf das eigentliche App-Icon zurück - was doch reichlich enervierend ist.

Daher meine Frage, woran das liegen könnte? Ist der Icon-Cache vielleicht zu klein? Könnte ich ihn irgendwie vergrößern? Oder ist dieser Gedankengang schon verkehrt?

Ich wäre wirklich für jeden Tipp sehr dankbar!

Beste Grüße
Olli
 
swa00

swa00

Moderator
Teammitglied
Hallo Olli,
und herzlichst willkommen im Forum.

a) Erste Frage aus Entwicklersicht :
Wie hast du denn deine eigenen Icons dem Package zugewiesen ?

b) hast du alle Versionstypen bereit gestellt ?

c) Ist dir bekannt, dass grundsätzlich die Resourcen des Packages zuerst genommen werden ?
 
ollifoto

ollifoto

Neues Mitglied
Threadstarter
Hallo swa00!

Vielen Dank für das freundliche Willkommen und Deine Antwort!

Ich habe die Icons alle manuell geändert, über die "Bearbeiten"-Funktion, wenn man das App-Icon länger gedrückt hält. Es funktioniert auch, nur werden sie ab und an halt wieder zurück gesetzt...
 
Zuletzt bearbeitet:
swa00

swa00

Moderator
Teammitglied
Die Zuweisung alternativen Icons erfolgt über den Cache.

Und dieser scheint bei deinem gerootetem Image nicht zuverlässig zu arbeiten und nimmt sich - wie oben schon bereits erwähnt,
das Icon aus der Resource der App.

a) Ich vermute ein Schreib/Lesefehler während des Bootens. (ggf. Lesegeschwindigkeit) von der SD
b) Oder die SD ist zu diesem Zeitpunkt noch nicht gemounted und das System bedient sich der App
Ggf. mal eine neue / schnellere SD verwenden.

Mehr kann ich dazu nicht beitragen , mein Latein wäre hier schon am Ende. :)
 
Zuletzt bearbeitet:
ollifoto

ollifoto

Neues Mitglied
Threadstarter
Dennoch herzlichen Dank, Stefan. Ich habs schon mit verschiedenen Karten (Größe, Geschwindigkeit) ausprobiert, aber es passiert leider immer wieder, dass das Default-Icon benutzt wird, anstatt das von mir zugewiesene. Es ist auch immer unterschiedlich; mal sind's diese Apps, mal sind's jene.
 
swa00

swa00

Moderator
Teammitglied
Dann ist das gute alte Stück einfach zu langsam im Bootvorgang :)
Da wirst du auch dann nichts daran ändern können - So unbeliebt Dir diese Aussage auch sein wird :)
 
ollifoto

ollifoto

Neues Mitglied
Threadstarter
Das wird's dann wohl -leider- sein, ja. Schade.

Als kleines Dankeschön für Deine Hilfe hier mal der Link zu meinen Icons:
ollicons 3 – Google Drive
 
Oben Unten