dauerndes Timeout bei messages.android.com usw.

F

Flexman

Erfahrenes Mitglied
Threadstarter
Ich nutze gerne die SMS und auch Whatsapp am PC, über die jeweilige Webseite.
Wenn mein Handy (Blackberry Keyone, Android 8.1.1) allerdings im WLAN ist, dann heißt es oft "Gerät nicht verbunden", bei mobiler Datenverbindung springt es schneller wieder an.

Es wirkt als gäbe es da irgendeinen Standby-Modus, bloß habe ich alles was ich gefunden habe auch schon abgeschalten (unter anderem das WLAN auf immer aktiv gesetzt, die jeweiligen Apps vom Energiesparen ausgenommen, etc.). Warum also ist das Gerät regelmäßig nicht erreichbar, und warum funktionieren dann die Web-Dienste erst wieder, wenn ich die jeweilige App am Handy starte und dort eine Nachricht schreibe?
 
F

Flexman

Erfahrenes Mitglied
Threadstarter
Ich glaube, ich hab's!

Einstellungen => Apps und Berechtigungen => Spezialzugriff => Unbegrenzte Datennutzung, und dann dort Apps wie Messages oder WhatsApp erlauben. Seitdem geht das.
Mich wundert, dass das sonst niemandem aufgefallen ist. Ist das eine Spezialität des Geräts, oder verwendet kaum jemand die PC-Verbindung?
 
F

Flexman

Erfahrenes Mitglied
Threadstarter
Pff... jetzt hat das ein Monat perfekt funktioniert und seitdem fangen die Spinnereien wieder an. Die Verbindung am PC lauft nur wenn man die Apps regelmäßig aufmacht. Ich frage mich welche Einstellung da durch welches Update wieder passiert sein kann, die das ganze wieder blockiert...
 
evasion

evasion

Lexikon
Dann gib doch auch noch die Unbegrenzte Datennutzung für das Netzwerk frei. Versuch ist es wert.
 
F

Flexman

Erfahrenes Mitglied
Threadstarter
Wenn ich das wo finden würde.... wo ist dieser Punkt denn versteckt?
 
evasion

evasion

Lexikon
Da wo du Einstellungen => Apps und Berechtigungen => Spezialzugriff => Unbegrenzte Datennutzungden anderen Punkt gefunden hast
 
F

Flexman

Erfahrenes Mitglied
Threadstarter
Hmm... Soll das eine App dort sein? Ich habe diesen Punkt nicht.

Es ist schon sehr seltsam... Tut irgendwie so, als wären die Apps nicht aktiv und ich müsste sie immer hier und da mal im Vordergrund halten.
Dabei hat es zwischenzeitig wirklich 1 Monat lang perfekt funktioniert!

Ich finde aber keine Einstellung, die eine App blockieren könnte. Batterie-Optimierung ist für die beiden Apps abgeschalten, Hintergrundnutzung erlaubt, unbegrenzte Datennutzung erlaubt. In den Expertenoptionen sind auch beliebig viele Apps im Hintergrund erlaubt...
Was könnte es denn noch sein, und vor allem, wieso hat sonst niemand dieses Problem?
 
F

Flexman

Erfahrenes Mitglied
Threadstarter
Das lustige:
Ich habe jetzt die Unbegrenzte Datennutzung für die beiden Apps wieder ausgeschalten - jetzt geht es wieder.

Das wirkt irgendwie so, als wäre die Einstellung mit irgendeinem Update auf ihren Ursprungszustand gesetzt worden, während die Schaltflächen auf "ein" geblieben sind. Und mit dem Ausschalten, habe ich sie dann vielleicht wieder eingeschalten? Alles sehr komisch...
Aber so weit ich weiß hat es bei Android ja auch schon mal einen Übersetzungsfehler gegeben wodurch der WLAN-Modus in der deutschen Version nur dann durchgehend aktiv war, wenn man eingestellt hat, dass WLAN ins Standby gehen soll...

Danke für die Mithilfe jedenfalls, ich hoffe das bleibt jetzt wieder stabil.
 
F

Flexman

Erfahrenes Mitglied
Threadstarter
Ok ich glaube, ich hab's!
Die Datennutzung war jetzt nicht mehr der Grund (die muss auch aktiviert sein), sondern das Hintergrund-Prozesslimit!

Mit irgendeinem Update hat Google die Verwaltung zu den Entwickleroptionen, zum Punkt "Hintergrundprüfung" verschoben. Dabei wurden offenbar auch meine bereits getroffenen Einstellungen wieder zurückgesetzt.
Gleichzeitig gibt es bei den Entwickleroptionen den Punkt "Prozesslimit im Hintergrund: Standard". Keine Ahnung wie hoch "Standard" ist, aber das ist schon der maximale Wert. Offenbar waren bei mir mehr Hintergrundprozesse aktiv, als dieser Wert erlaubt, dadurch wurden also Apps wie Messages und Whatsapp im Hintergrund eingebremst, bis ich sie wieder geöffnet habe.

Ich habe jetzt bei der "Hintergrundprüfung" sämtliche Apps deaktiviert, die im Hintergrund eh nicht laufen müssen - jetzt sieht es wieder sehr gut aus, und geht auch viel flüssiger.

Der Begriff "Hintergrundprüfung" ist eigentlich missverständlich, ich habe mir zuerst gedacht dass das heißt, dass die abgewählte Apps von der Limitierung ausgenommen werden. Aber in Wirklichkeit dürfen nur die Apps im Hintergrund laufen, die dort aktiviert sind. Die Option war vorher bei meinem Gerät unter anderem Namen irgendwo anders - so wie's halt ist beim Android. Mal schauen wo sie das nächste Woche wieder hinschieben...
 
Thread starter Similar threads Forum Replies Date
Truncate Android 8.x.x (Oreo) 0
Similar threads
Hotspot Timeout bei Oreo
Oben Unten