1. Hast Du Lust, bei uns mitzuarbeiten und das AH-Team zu verstärken? Alle Details zu dieser aktuellen Herausforderung findest Du hier.
  1. Droidjo, 03.04.2012 #1
    Droidjo

    Droidjo Threadstarter Fortgeschrittenes Mitglied

    Kennt jemand das Problem, dass sich das Layout in der XML-Vorschau ändert, wenn man unterschiedliche Android Versionen auswählt?

    Ich habe gerade eine App für Version 2.1 programmiert. Nun wollte ich mal schauen, wie das ganze in anderen Versionen ausschaut. Bis Version 3.0 schaut alles aus, wie ich es programmiert habe. Ab Version 3.0 fangen dann die Probleme an. Sowohl bei 3.0, 3.1 und 3.2 sind die Ränder, die ich mit margin beschnitten habe, nicht blau, sondern schwarz. Ab Version 4.0 werden sie dann wieder blau, dafür ändert sich dann die gravity von einigen Elementen allerdings nach rechts.
    Das kann doch nicht normal sein!? Hat jemand eine Idee, wie man dieses Problem lösen kann?
     
  2. swordi, 03.04.2012 #2
    swordi

    swordi Gewerbliches Mitglied

    das liegt wohl am default theme der jeweiligen version

    musst halt alle werte selbst festlegen, wenn dir die default vorgaben nicht passen.
     
  3. Droidjo, 03.04.2012 #3
    Droidjo

    Droidjo Threadstarter Fortgeschrittenes Mitglied

    Hab ich doch gemacht. :biggrin: Das Problem ist dennoch wie oben beschrieben.

    EDIT: Frag mich nicht wieso, aber das Problem mit 4.0 ist plötzlich wie von Geisterhand verschwunden. Weiterhin besteht aber das Problem mit den schwarzen, statt den blauen Rändern, bei den Versionen 3.x.
     
  4. swordi, 03.04.2012 #4
    swordi

    swordi Gewerbliches Mitglied

    naja weitere hilfe wird nicht möglich sein, wenn du uns nicht zeigst, was du so gemacht hast.
     
  5. Droidjo, 03.04.2012 #5
    Droidjo

    Droidjo Threadstarter Fortgeschrittenes Mitglied

    Ich würde euch gerne mehr zeigen, aber leider gibt es nichts zu zeigen. Es ist einfach der margin Befehl, der bei 3.x statt blauen schwarze Balken produziert.
     
  6. swordi, 03.04.2012 #6
    swordi

    swordi Gewerbliches Mitglied

    naja dann müsste ja der default theme background greifen.
    oder eben der background deiner layout datei...

    das hast du angepasst ?
     
  7. Droidjo, 04.04.2012 #7
    Droidjo

    Droidjo Threadstarter Fortgeschrittenes Mitglied

    Ja, der Background meines "root" Layout ist das angesprochene Blau. Wenn ich beim zweiten Layout margin benutze müsste also dieses Blau erscheinen. Tut es auch bei 2.x und 4.x. Nur bei 3.x erscheint stattdessen schwarz.
    Ich habe jetzt stundenlang rumexperimentiert und muss leider resignieren. Das Problem lässt sich einfach nicht lösen. Eigentlich seltsam, dass dieses Problem nicht weiter verbreitet, bzw. scheinbar noch nicht bekannt ist.
     
Die Seite wird geladen...
Ähnliche Themen Forum Datum
[OFFEN] RadioButtons mit Button Tinting sehen auf Geräten unterschiedlich aus (API > 21) Android App Entwicklung 09.09.2017
[Offen] Android Layout funktioniert nicht Android App Entwicklung 08.09.2017
[ERLEDIGT] Alpha-Version meiner App nicht mit S8 kompatibel Android App Entwicklung 06.09.2017
[OFFEN] Xposed Modul ändert keine Integers Android App Entwicklung 11.06.2017
[OFFEN] Klick auf Marker soll ein zweites kleineres Layout anzeigen, Map soll trotzdem noch scrollbar (verwendbar) sein Android App Entwicklung 04.04.2017
[ERLEDIGT] Layout (Design) erkennt style nicht? Android App Entwicklung 13.03.2017
Verständnisprobleme beim Layout Android App Entwicklung 21.02.2017
Layout-Probleme auf verschiedenen Geräten Android App Entwicklung 19.01.2017
Text View erzeugt rendering Problem Android App Entwicklung 18.11.2016
Du betrachtest das Thema "Layout ändert sich in unterschiedlichen Versionen" im Forum "Android App Entwicklung",