Meldungen zum Emulator

Skogtroll

Skogtroll

Fortgeschrittenes Mitglied
Threadstarter
Moin Leut's!

Ich möchte natürlich das, welches ich in Android Studio (AS) mache, im Emulator visuell Nachvollziehen/kontrollieren können. Der Emulator startet auch, aber dann dreht der "Zeitkreisel" ohne Ende und ich warte und warte...

Ich erhalte 2 Dialog-Meldungen, die ich so nicht verstehe. Auch eine umfangreiche Suche im Netz bringt mir nicht die konkrete Antwort. Es sind so viele, dass ich ein wenig verwirrt bin :blink:

Hinweis01.PNG


Hinweis02.PNG


Ich bitte Euch, mir diese Meldungen zu erklären und mir eine Lösung an die Hand zu geben. Danke!

Wenn ich irgend etwas downloaden muss, setzt mir bitte den gezielten Link zu den Dateien hier mit dazu. Ich komme so oft auf Seiten, die mich mit dem Download-Angebot erschlagen. Oft kann ich da auch nichts zuordnen. Danke!

-----

Via einem USB-Kabel kann ich die laufende Projekt-App in AS mit meinem Smartphone darstellen. Diese Einrichtung habe ich geschafft :biggrin:
 
swa00

swa00

Moderator
Teammitglied
Hallo Skog,

die Meldung besagt , dass du eine veraltete ADB version auf deinem Rechner hast. (obsolete)
und die zweite Meldung besagt , dass du nicht die x86 Images des emulator benutzt , was keinen Sinn macht

Abhilfe : AS vollständig deinstallieren und die neue AS 3.1.4 installieren
 
Zuletzt bearbeitet:
Skogtroll

Skogtroll

Fortgeschrittenes Mitglied
Threadstarter
Danke für die rasend schnelle :thumbsup: Antwort!

swa00 schrieb:
Abhilfe : AS vollständig deinstallieren und die neue AS 3.1.x installieren
....ich habe die neueste AS Version 3.1.4 installiert.
 
swa00

swa00

Moderator
Teammitglied
Hast du auch deine "alten" Images des Emulators gelöscht ? (appdata/local/android/sdk)
Ich gehe auch davon aus , dass du irgendwo noch ein altes adb drauf hast und darauf das Environment gesetzt ist

Danke für die rasend schnelle :thumbsup: Antwort!
Wir geben unser Bestes :)
 
Skogtroll

Skogtroll

Fortgeschrittenes Mitglied
Threadstarter
swa00 schrieb:
(appdata/local/android/sdk)
Dieser Pfad funktioniert bei mir nicht! ...da er ja über "User\Mein Name\...usw. usw." ein Leerzeichen beinhalten. Ich habe den SDK-Ordner direkt unter "C:\" angelegt und in AS den Pfad dorthin bestimmt.

Das SDK habe ich über diese Seite "Download Android Studio and SDK tools | Android Developers" - weiter unten - downgeloaded und installiert.

swa00 schrieb:
...dass du irgendwo noch ein altes adb drauf hast und darauf das Environment gesetzt ist
Es müsste eigentlich auch hier das aktuellste ADB sein.... :confused2:

-----

Habe da was überlesen:

swa00 schrieb:
Hast du auch deine "alten" Images des Emulators gelöscht ?
Was heißt das genau? Kann ich etwas löschen und dann erstellt es sich alles automatisch neu?!?
 
swa00

swa00

Moderator
Teammitglied
Dieser Pfad funktioniert bei mir nicht! ...da er ja über "User\Mein Name\...usw. usw." ein Leerzeichen beinhalten
Also das ist NICHT richtig .. der funktioniert seit bestehen von AS einwandfrei :)

ch habe den SDK-Ordner direkt unter "C:\" angelegt und in AS den Pfad dorthin bestimmt.
Warum ? - Lass doch mal AS es so machen , wies es seine Struktur benötigt , bevor du "Hand" anlegst.
Jegliche Änderung bei der Installation bewirkt gleichzeitig jede menge Änderungen , die dann manuell vorgenommen werden müssen .
Das ist Abendfüllend - zumal ein kleiner Fehler und gar nichts mehr läuft - und man wirklich Fit sein muss.
(Ich wage es nach x Jahren noch nicht)

Bevor wir hier die Kristallkugel anwerfen und nach einem Fehler suchen , sollten wir erst mal wissen , ob AS in der Default - Konfiguration läuft (Ausschlussverfahren)
 
Skogtroll

Skogtroll

Fortgeschrittenes Mitglied
Threadstarter
Danke für Deine erneute Antwort!

swa00 schrieb:
Also das ist NICHT richtig .. der funktioniert seit bestehen von AS einwandfrei :)
....nachdem ich AS installiert habe, habe ich definitiv mehrfach die Meldung erhalten, das der Pfad zum SDK-Ordner KEINE (!) Leerzeichen enthalten darf!

Und mehrere Seiten im Netz "lösten" das Problem mit dem Hinweis den SDK-Ordner einfach so zu verschieben, dass kein Leerzeichen mehr im Pfad besteht. Und dann bestimmt man unter "Settings" in AS den Pfad zum SDK-Ordner neu.

-----

Ich muss jetzt leider außer Haus und bin erst heute Abend - evtl. erst sehr viel Später - wieder zu Hause.
 
D

deek

Stammgast
Das sollte auch kein Problem sein, ich bestimme seit jeher selbst wo mein SDK liegt.

starte mal im tools ordner im SDK: android update sdk
Dann sollte er alles updaten was so da ist.

Den Emulator solltest du als x86 image neu einrichten.
 
swa00

swa00

Moderator
Teammitglied
@deek

Das sollte auch kein Problem sein, ich bestimme seit jeher selbst wo mein SDK liegt.
Ich auf einigen Maschinen auch , ich möchte nur bei ihm erst einmal Grundsätzliches ausschließen.
 
J

jogimuc

Erfahrenes Mitglied
Hallo mal eine Frage. Welch cpu hast du in deinem Rechner Intel oder AMD?

Den Emulator solltest du als x86 image neu einrichten.
Nicht den emulator sondern das avd.

.nachdem ich AS installiert habe, habe ich definitiv mehrfach die Meldung erhalten, das der Pfad zum SDK-Ordner KEINE (!) Leerzeichen enthalten darf!
Dann hast du keine Standart Installation gemacht oder du hast in deinem Windows bei den User Konten etwas verändert.

Das SDK habe ich über diese Seite "Download Android Studio and SDK tools | Android Developers" - weiter unten - downgeloaded und installiert.
Das brauchst du nicht runterladen das wird bei der Installation selber runter geladen. Es reicht die Installations exe auszuführen die pathe kannst auch so lassen wie es As will. Nach der Installation von As wird automatisch das sdk geladen. Wenn du noch weitere sdk brauchst Dafür ist der sdk Manager da, benutze den dafür.

Das mit dem sdk extra war bei AS 2.x üblich und notwendig. Mir scheint als ob du ein sehr alte Anleitung für die Installation von Android studio benutzt.
 
Zuletzt bearbeitet:
Skogtroll

Skogtroll

Fortgeschrittenes Mitglied
Threadstarter
Hallo Ihr Alle! Danke für Euer reges Interesse an meinem Thread und Euren Lösungsmöglichkeiten!

jogimuc schrieb:
Hallo mal eine Frage. Welch cpu hast du in deinem Rechner Intel oder AMD?
Intel Pentium CPU B960 2,2GHz

-------------------------

Ich mache jetzt mal einen "Coold Cut"! Ich deinstalliere alles nach dieser Anleitung, die ich im Netz gefunden habe:

Schritt 1: Führen Sie das Android Studio-Deinstallationsprogramm aus > Systemsteuerung > Programme > klicke auf "Android Studio" und drücke Uninstall.

Schritt 2: Entfernen Sie die Android Studio-Dateien.

Um alle Überreste von Android Studio-Einstellungsdateien zu löschen, gehen Sie im Datei-Explorer in Ihren Benutzerordner ( %USERPROFILE% ) und löschen Sie .android , .AndroidStudio und alle analogen Verzeichnisse mit Versionen am Ende, also auch .AndroidStudio1.2 als .gradle und .m2 wenn sie existieren.

Wechseln Sie dann zu %APPDATA% und löschen Sie das JetBrains Verzeichnis.

Schließlich gehen Sie zu C:\Program Files und löschen Sie das Android Verzeichnis.

Schritt 3: SDK entfernen

Um irgendwelche Reste des SDKs zu löschen, gehen Sie zu %LOCALAPPDATA% und löschen Sie das Android Verzeichnis. Bzw. ich lösche da, we o bei mir die SDK liegt.

Schritt 4: Löschen Sie Android Studio-Projekte

Android Studio erstellt Projekte in einem Ordner %USERPROFILE%\AndroidStudioProjects , den Sie möglicherweise löschen möchten.
Dann werde ich die Datei "android-studio-ide-173.4907809-windows.exe" (das ist die Aktuelle von "Download Android Studio and SDK tools  |  Android Developers") dopelklicken und die normale Standard-Installationen durchlaufen lassen. Mal sehen was passiert.

Dann gehe ich noch mal bei und werde versuchen den Emulator zum Laufen zu bringen.

Ich werde mich wahrscheinlich erst wieder am Samstag melden können oder vielleicht schon morgen Abend. Habe z.Zt. ein wenig viel um die Ohren :biggrin:
 
Skogtroll

Skogtroll

Fortgeschrittenes Mitglied
Threadstarter
Moin Leut's! ....erstens kommt es anders und dann als man denkt.... :scared: Mein Dienst ist per Telefonanruf umgeschmissen worden und nun habe ich ein paar Stunden Zeit.

So. Ich habe gestern Abend Android Studio (AS) kpl. nach meiner oben geposteten Anleitung vom Notebook geschmissen und dann wie bereits beschrieben ein kpl. Standard Installation gemacht. Nur der Doppelklick auf die *.exe und dann immer weiter geklickt. Nix weg oder dazu gemacht, habe mein System einfach mal rattern lassen :biggrin:

Standardmäßig wurde mir bei der Erst-Erstellung einer ProjektApp aus den Vorlagen heraus die Auswahl "Nexus 5X API 28 x86" angeboten - habe ich mal alles gelassen. Iim AVD-Manager finde ich genau diesen Eintrag wieder. Ich gehe mal davon aus, das es sich hier um ein x86'er Profil handelt, da ich diese Zahl hier wieder finde.

Laut SDK-Manager hat sich der "Android Emulator" installiert.

Ich klicke jetzt auf den grünen Play-Button, erhalte das Profil "Nexus 5X API 28 x86" zur Auswahl und klicke mich weiter....

01.PNG


...ist die erste Meldung die ich bekomme...

02.PNG

....ist ein Dialogfeld welches ich öffnen konnte....

03.PNG


...ist dann das finale Ergebnis.

Was mache ich falsch? ....oder liegt es an meiner "Intel Pentium CPU B960 2,2GHz" CPU? Bin ziemlich ratlos :confused2: :D

-----
-----

Ach ja, by the way: Es kam dann wieder der "Whitespace"-Hinweis, jetzt nur wegen des "NDK's", aber bei meinen Vorinstallationen kam er auch definitiv wegen des SDK-Managers...

Whitespace01.PNG

...aber das nur am Rande :winki:
 
Zuletzt bearbeitet:
J

jogimuc

Erfahrenes Mitglied
Hallo
Wenn das AVD erhalten geblieben ist hast du nicht alles gelöscht.
lösche mal das AVD und erstelle ein neues.
Hast du auch den Haxm mit Installiert ?
upload_2018-8-31_10-11-42.png


Hast du auch VT-x Intel Virtualisirung im Bios aktiviert?

Sonst läuft der Haxm Treiber nicht.

Wie gesagt gehe in den AVD Manager und erstelle ein neues Gerät. Lösche das alte.

Und erstelle ein neues mit x86 Image. Wenn denn Haxm nicht geht dauert es extrem lange bis der Emulator fertig startet.
upload_2018-8-31_10-26-18.png

upload_2018-8-31_10-26-41.png

-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Wegen den Lehrzeichen dein PC Username hat wohl ein Lehrzeichen? Wenn Ja dann ändere das. Ein Lehrzeichen in Username macht oft ärger solte man nicht machen.
Android legt bei einer standart Inst. alles unter den UserOrdner an.
Das wird wohl dein Hauptproblem sein.
 
Zuletzt bearbeitet:
Skogtroll

Skogtroll

Fortgeschrittenes Mitglied
Threadstarter
Vielen Dank für die Antwort!

jogimuc schrieb:
Hast du auch VT-x Intel Virtualisirung im Bios aktiviert?
....habe ich gleich gechekt: Diese Einstellung finde ich nicht in meinem BIOS.

jogimuc schrieb:
Wegen den Lehrzeichen dein PC Username hat wohl ein Lehrzeichen? Wenn Ja dann ändere das. Ein Lehrzeichen in Username macht oft ärger solte man nicht machen.Android legt bei einer standart Inst. alles unter den UserOrdner an. Das wird wohl dein Hauptproblem sein.
...und die Lösungsmöglichkeit den SDK-Ordner einfach direkt unter "C:\" zu positionieren und dann in den AS-Settings den Pfad neu zu bestimmen ist nix?

Ich hatte noch nie wegen eines Leerzeichens in meiner User-Zuordnung irgendwelche Probleme mit diversen Programmen. Und das waren hunderte wenn nicht sogar tausende...

Wenn das bei AS so ist, dann akzeptiere ich das natürlich. Aber ich würde dann lieber die Ordner-Position verändern als den User-Namen. Ich befürchte dann nämlich andere Probleme mit zahlreichen Programmen, die ihre Bezüge mit dem User-Namen haben.

-----

jogimuc schrieb:
Wenn das AVD erhalten geblieben ist hast du nicht alles gelöscht.
lösche mal das AVD und erstelle ein neues.
Was heißt das? Das kpl. Interface, wo die Profile drinne stehen ODER nur das "Nexus 5X API 28 x86" Profil?

jogimuc schrieb:
Hast du auch den Haxm mit Installiert ?
Schau ich denn jetzt gleich noch mal schnell. War bis jetzt ja mit dem BIOS beschäftigt :biggrin:

Ich muss jetzt aber wieder außer Haus und bin erst heute Abend wieder online!

------

So das schaffe ich noch schnell: "Haxm" ist wohl installiert....

haxn01.PNG
 
Zuletzt bearbeitet:
J

jogimuc

Erfahrenes Mitglied
...und die Lösungsmöglichkeit den SDK-Ordner einfach direkt unter "C:\" zu positionieren und dann in den AS-Settings den Pfad neu zu bestimmen ist nix?
Wenn dann muss der path für das ndk auch verändert werden.Wobei ich bezweifle ob du als denke Anfänger das überhaup brauchst.
Auch deine AVDs werden unter dem User Ordner abgelegt weiss jetzt nicht aus dem Kopf wie du den änderst das war in einer config Datei.

Da deine CPU kein vt-x hat kannst du sowieso nur mit der langsameneSoftware Emulation arbeiten musst. Kannst du auch mal einen alternativen emulator testen. Vileicht Genymotion. Der lief auch als es den haxm noch nicht gab immer besser als der vom Studio.

Zu den Lehzeichen ich persönlich bin da kein Freund von, auch wenn es die meisten Programme mittlerweile können gibt es immer wieder Programme die damit nicht zurecht kommen. Denke mal darüber nach.

Wenn du Angst hast deinen User Namen zu ändern. Kannst du dir ja vorher ein Image von deinen System machen. So kannst du wenn es grosse Probleme nach dem umstellen gibt schnell und leicht wieder zurück. Ich nehme acronis dafür. Geht arber auch mit Windows Board Mitteln.
 
Zuletzt bearbeitet:
Skogtroll

Skogtroll

Fortgeschrittenes Mitglied
Threadstarter
So, da bin ich denn mal wieder!

Also ich habe jetzt die letzten Stunden ein wenig nachgedacht. Ich hole mir ein neues Notebook. Es macht so gar keinen Sinn - nicht nur wegen Android Studio. Ich hab auch Probleme mit einigen anderen Anwendungen

Dieses Wochenende will ich sowieso alles für einen neuen Desktop-Rechner bestellen und da kommt jetzt auch ein neues Notebook mit dazu. Der Desktop-Rechner wird ein Silent-Rechner speziell für Audio-Anwendungen (ich mache Musik und habe ein kleines Homestudio). Es wird ein AMD-System mit einem 8-Kerne Ryson7. Aber dieses System wird NUR (!) für Audio- und Videoanwendungen da sein - sonst NIX anderes!

Ein Notebook habe ich immer für alles andere, auch wegen der Mobilität!

Worauf habe ich denn bei der CPU zu achten, wenn ich mit dem Notebook auch mit Android Studio arbeiten möchte? Hier erbitte ich Eure Hilfe!

Ich schätze es wird bis zu 2 Wochen dauern, bis ich mich hier wieder melde. Es wird ein Win10 64Bit System werden > ich werde ein paar Tage brauchen, bis ich weitestgehend die Späh-Funktionen dieses Systems eleminiert habe und ich mich einigermaßen privat fühlen kann. AUCH werde ich mich als Administrator NICHT unter meinem Namen als User hinterlegen > es wird nur ein Wort werden.

Wäre es wichtig darauf zu achten, ob das Win10 64Bit die Professionel oder Home-Version sein kann? Auch hier wäre mir Euer Rat sehr wichtig!

Ich denke, dass ist der beste Weg.
 
J

jogimuc

Erfahrenes Mitglied
Bei dem Laptop würde ich auf jeden Fall eine Intel CPU nehmen. Denn android studio und AMD passt nicht so gut. Der Emulator soll zwar nun auch auf einem AMD flotter laufen. Wie gut das wirklich ist weiss ich nicht.
 
Skogtroll

Skogtroll

Fortgeschrittenes Mitglied
Threadstarter
Aber das ist schon mal eine Aussage! ...und es heißt für mich im Umkehrschluss, dass auch AMD CPUs mit AS+Emulator funktionieren.

@jogimuc , ich nehme Dich natürlich ernst, aber ich persönlich tendiere mehr zu AMD: Man bekommt einfach mehr Leistung für's Geld! Und - zumindestens - mit dem Ryzen7 ist AMD ein ganz großer Wurf gelungen. Zusammen mit einem ASUS Motherboard sind die AMD CPUs sehr sehr gut!!!! Aber ASUS produziert auch Notebooks mit AMD CPUs... ;)

Danke Dir herzlich!
 
J

jogimuc

Erfahrenes Mitglied
Das es mit AMD gehen soll ist erst seit kurzen ein zwei Monate ob es wirklich fehlerfrei arbeite weiss ich nicht.
Mir wäre das zu unsicher.
 
Oben Unten