1. Mitglieder surfen ohne Werbung auf Android-Hilfe.de! ✔ Jetzt kostenlos Mitglied in unserer Community werden.
  1. missG, 03.11.2010 #1
    missG

    missG Threadstarter Android-Hilfe.de Mitglied

    Hallo,

    hab eine App mit absolutelayout erstellt und die positionen/größe der bilder/buttons etc. mit px gesetzt. Auf der emulator-andoird version 1.5 war die darstallung problemlos. Aber bei den größeren versionen, ist alles größer skaliert, warum?

    vG
     
  2. Rotesmofa, 04.11.2010 #2
    Rotesmofa

    Rotesmofa Fortgeschrittenes Mitglied

    Bist du dir sicher das du die gleiche Auflösung für den Emulator gewählt hast?
    Wie sieht es denn in der Vorschau aus?

    Nutzt du aus einem bestimmten Grund das Absolut Layout?
    Ich würde das so gut wie möglich vermeiden! Da du damit einen großen Vorteil der Darstellung auf mehreren Auflösungen verlierst bzw. stark einschränkst.


    Gruß
    Rotesmofa
     
  3. missG, 04.11.2010 #3
    missG

    missG Threadstarter Android-Hilfe.de Mitglied

    ja es hat schon einen grund warum ich absolutelayout verwende. Ich brauche die App nur für eine Auflösung. :)

    Ich habe den emulator für die höhere API 8 genauso, wie die für API 3 eingestellt. Als hardwareeinstellung beim emulator nur lcd.density auf 240 einegstellt. bei beiden :)
     
  4. Rotesmofa, 04.11.2010 #4
    Rotesmofa

    Rotesmofa Fortgeschrittenes Mitglied

    Was machst du denn in deinem Layout?

    Bring mal ein paar Infos in den Thread, damit man sich das mal anschauen kann.

    Gruß
    Rotesmofa
     
  5. missG, 04.11.2010 #5
    missG

    missG Threadstarter Android-Hilfe.de Mitglied

    Also mein Layout soll die absolute GRöße 480x800 haben. Das Gerät ist an sich landscape. Deshalb habe ich der activity das attribut "portrait" zugewiesen. Hab einige button an einer bestimmten position, welche ich anhand der pixel-koordinaten zuweise.

    auf der 1.5 api 3 klappt alles, wird alle schön angezeigt, allerdings wenn ich das mal auf der 2.2 api 8 teste will...wird alles scaliert und zwar so, dass es doppelt so groß ist. und ich somit auf dem display nur 1/4 vom ganzen sehen kann...und wzar nur die linksoberen viertel :)
     
  6. Rotesmofa, 05.11.2010 #6
    Rotesmofa

    Rotesmofa Fortgeschrittenes Mitglied

    Warum weisst du den Portrait zu wenn dein Gerät Landscape hat?? :huh:

    :smile:
    Gruß
    Rotesmofa
     
  7. missG, 05.11.2010 #7
    missG

    missG Threadstarter Android-Hilfe.de Mitglied

    ich glaub ich weiß jetzt woran es liegt. es gibt bei der api 8 andere drawable ordner, also unterteil in verschieden dpi. bei der api3 gab es nur den drawable ordner.

    so wie kann ich nun den code für api3 in api8 anpassen? :)
    wo müssen die bilder aus drawable der api3 hin?
     
  8. Rotesmofa, 05.11.2010 #8
    Rotesmofa

    Rotesmofa Fortgeschrittenes Mitglied

    das ist es nicht, daran habe ich auch schon gedacht.

    Android packt sich einfach die passende Auflösung der Bilder von selbst.
    Wenn du wie in API3 nur ein drawable ablegst und auf API 8 stellst dann wird das OS sich einfach das selbe drawable holen.
     
  9. missG, 08.11.2010 #9
    missG

    missG Threadstarter Android-Hilfe.de Mitglied

    ich weiß jetzt woran es lag. ich hatte im manifest die SDKversion ausgelassen. bei der api3 hatte es keine probleme gemacht, nur eine warnung. bei der APi 8 halt die falsche darstelltung. jetzt klappt alles super! :) juhuu
     
Die Seite wird geladen...
Ähnliche Themen Forum Datum
Problem mit variable.setText (für TextView) Android App Entwicklung 25.10.2018
MIT AppInventor App erstellen um PDFs zu öffnen, problem Android App Entwicklung 10.10.2018
Problem mit for-Schleife, delay und Margins Android App Entwicklung 08.10.2018
Meldungen zum Emulator Android App Entwicklung 30.08.2018
Map wird in Emulator angezeigt, aber nicht auf Handy Android App Entwicklung 03.06.2018
Problem mit startActivityForResult() Android App Entwicklung 25.01.2018
android emulator root Android App Entwicklung 19.01.2018
[OFFEN] ListFragment innerhalb eines TabFragments darstellen Android App Entwicklung 02.01.2018
Du betrachtest das Thema "Problem Emulator-Darstellung" im Forum "Android App Entwicklung",
  1. Android-Hilfe.de verwendet Cookies um Inhalte zu personalisieren und dir den bestmöglichen Service zu gewährleisten. Wenn du auf der Seite weitersurfst stimmst du der Cookie-Nutzung zu.  Ich stimme zu.