1. Hast Du Lust, bei uns mitzuarbeiten und das AH-Team zu verstärken? Alle Details zu dieser aktuellen Herausforderung findest Du hier.
  1. Chri, 18.02.2010 #1
    Chri

    Chri Threadstarter Gewerbliches Mitglied

    Hi Leute!

    Hab noch ein weiteres Problem.
    Und zwar wird bei mir, wenn ich meinen Service mit "bindService" starte, dieser NICHT mit "stopService" beendet!
    Hingegen, wenn ich ihn mit "startService" starte wird er schon wieder gestopt!

    (Ich muss "bindService" verwenden, da ich dem Service Daten übermittle)
    (oder kann ich das auch Daten mit "startService" übermitteln? -Habe hierfür keine möglichkeit gefunden -)

    Danke im Voraus!
    mfg Chri
     
  2. Shinigami, 18.02.2010 #2
    Shinigami

    Shinigami Fortgeschrittenes Mitglied

    Hi,

    unbindService() verwendeste schon oder? Glaube zumindest, dass es daran liegen könnte.

    Dazu aus der Referenz:
    "Note that if a stopped service still has ServiceConnection objects bound to it with the BIND_AUTO_CREATE set, it will not be destroyed until all of these bindings are removed."

    Gruß,
    Shini
     
  3. Chri, 19.02.2010 #3
    Chri

    Chri Threadstarter Gewerbliches Mitglied

    Also wenn ich unbindeService mit einer null- Referenz starte (Da ich auch bei der ServiceConnection von bindService null übergeben habe) hat es keine Auswirkungen!
    Und wenn ich eine Klasse definiere, die ServicConnection implementiert (Ich habe in dei Methoden nichts hineingeschrieben) dann funktioniert es auch nicht!
     
  4. Chri, 19.02.2010 #4
    Chri

    Chri Threadstarter Gewerbliches Mitglied

    Also zum Abschluss:

    Mit null- Referenzen funktioniert es NICHT!
    Hingegen wenn man eine eigene Klasse zB MyServiceConnection, die ServiceConnection implementiert, macht und davon eine Instanz bildet und diese wiederum als Übergabeparameter für bindService() bzw unbindService() verwendet funktioniert es nach meinem jetzigen Wissensstand (nmjWs) einwandfrei! (Wenn sich an diesem in dieser Hinsicht etwas ändert, wird es natürlich sofort gepostet)

    PS: stopService() wird nmjWs nicht mehr gebraucht.

    mfg
     
Die Seite wird geladen...
Ähnliche Themen Forum Datum
[ERLEDIGT] Wandernder Text Android App Entwicklung Dienstag um 11:49 Uhr
[OFFEN] Lists-in-List-Problem Android App Entwicklung 12.10.2017
[OFFEN] Problem mit meiner Login App Android App Entwicklung 10.06.2017
[OFFEN] git-Problem in Android Studio (Windows) Android App Entwicklung 24.05.2017
[ERLEDIGT] put in HashMap bringt App zum abstürzen Android App Entwicklung 22.05.2017
[ERLEDIGT] Problem mit Async Task und auszuführender Aufgabe Android App Entwicklung 02.05.2017
[ERLEDIGT] Problem beim Starten einer neuen Activity Android App Entwicklung 21.03.2017
Excel Dokument mithilfe von JExcelAPI auslesen funktioniert nicht :/ Android App Entwicklung 02.03.2017
Notizen App problem Android App Entwicklung 11.01.2017
Text View erzeugt rendering Problem Android App Entwicklung 18.11.2016
Du betrachtest das Thema "Problem mit "stopService"" im Forum "Android App Entwicklung",