1. Mitglieder surfen ohne Werbung auf Android-Hilfe.de! ✔ Jetzt kostenlos Mitglied in unserer Community werden.
  1. oliver.s, 08.12.2010 #1
    oliver.s

    oliver.s Threadstarter Neuer Benutzer

    Hallo,

    ich habe gestern begonnen mich mit dem Android Buch von Arno Becker zu beschäftigen.

    Bei ersten Beispiel hab ich jetzt ein etwas seltsames Problem:

    Wenn ich die main.xml vom Buch abschreibe, wird der Spinner nach der RadioGroup nich angezeigt, sondern nur die zwei RadioButtons ...


    <?xml version="1.0" encoding="utf-8"?>
    <LinearLayout xmlns:android="http://schemas.android.com/
    apk/res/android"
    android: orientation="vertical"
    android:layout_width="fill_parent"
    android:layout_height="fill_parent">

    <TextView

    android:layout_width="fill_parent"
    android:layout_height="wrap_content"
    android:text="@string/hello" />

    <RadioGroup android:id="@+id/position"

    android:layout_width="fill_parent"
    android:layout_height="wrap_content"
    android: orientation="vertical">

    <RadioButton android:id="@+id/stauAnfang"

    android:layout_width="wrap_content"
    android:layout_height="wrap_content"
    android:text="Stauanfang" />
    <RadioButton android:id="@+id/stauEnde"
    android:layout_width="wrap_content"
    android:layout_height="wrap_content"
    android:text="Stauende" />

    </RadioGroup>


    <Spinner android:id="@+id/stauUrsache"

    android:layout_width="fill_parent"
    android:layout_height="wrap_content"
    android:drawSelectorOnTop="true" />
    </LinearLayout>




    Wenn ich jedoch den Spinner vor der RadioGroup definiere wird alles korrekt angezeigt!?


    Wenn mir jemand erklären könnte, was da nicht stimmt, wäre ich sehr dankbar :)

    lg oliver
     
  2. ktt, 09.12.2010 #2
    ktt

    ktt Android-Hilfe.de Mitglied

    Hi Oliver,

    also ich habe gerade dein Layout kopiert außer das 2 leerzeichen anstellen waren wo keine sein sollen konnte ich nix feststellen und er zeigt bei mir auch alles an.

    Gruß Kevin
     
  3. oliver.s, 09.12.2010 #3
    oliver.s

    oliver.s Threadstarter Neuer Benutzer

    Hmmm ... ich habe jetzt ein neues Projekt erstellt, bei dem die Reihenfolge wieder, zuerst RadioGroup dann Spinner ist und der Spinner wird wieder nicht angezeigt.

    Gleich wie beim Alten funktioniert das Ganze wenn ich die Spinner und RadioGroup vertausche ...

    das ist irgendwie seltsam!?
     
  4. ktt, 09.12.2010 #4
    ktt

    ktt Android-Hilfe.de Mitglied

    Hi,

    welches Api Level hast du denn eingestellt und hast du sonst noch was verändert außer die main.xml ?

    Testest du im Emulator oder auf einem Handy ?

    Gudde
     
Die Seite wird geladen...
Ähnliche Themen Forum Datum
Android Studio: Auf Datenbank mit zwei Spinner zugreifen. Android App Entwicklung 07.06.2018
Problem mit startActivityForResult() Android App Entwicklung 25.01.2018
Zweiten Spinner hinzufügen Android App Entwicklung 07.01.2018
Spinner Position der Dropdown Liste Android App Entwicklung 05.01.2018
Spinner item in Datenbank schreiben mysql Android App Entwicklung 23.12.2017
Problem beim Geofencing in einer Android App Android App Entwicklung 24.11.2017
Loading Spinner Android App Entwicklung 12.11.2017
[OFFEN] WebView Loading Spinner Android App Entwicklung 08.11.2017
[ERLEDIGT] Wandernder Text Android App Entwicklung 17.10.2017
[OFFEN] Lists-in-List-Problem Android App Entwicklung 12.10.2017
Du betrachtest das Thema "Spinner Problem" im Forum "Android App Entwicklung",
  1. Android-Hilfe.de verwendet Cookies um Inhalte zu personalisieren und dir den bestmöglichen Service zu gewährleisten. Wenn du auf der Seite weitersurfst stimmst du der Cookie-Nutzung zu.  Ich stimme zu.