Webshop mit WebView funktioniert nicht wie Website

  • 3 Antworten
  • Neuester Beitrag
Diskutiere Webshop mit WebView funktioniert nicht wie Website im Android App Entwicklung im Bereich Betriebssysteme & Apps.
K

Kapikalaani

Neues Mitglied
Moin moin,

ich bin schon seit ein paar Jahren aus der Androidentwicklung raus, und hauptsächlich aktuell nur noch mit C# auf Windows zu gange.

Jetzt wollte ich aber mal eine kleine App bauen, die eine fertige Website nimmt, und quasi als "Pseudo"-App anzeigt und genauso funktioniert wie die Website.

Die Anzeige funktioniert auch soweit, vor allem auch, da die Mobile-Version der App gut entwickelt ist.

Allerdings gibt es ein Problem bei der Verwendung von WebView: Ich kann nur noch einen Artikel in den Warenkorb hinzufügen, beim zweiten Artikel lädt die App einfach unendlich lang.

Liegt das an der Verwendung von WebView, wegen der Probleme, die vor einiger Zeit mal in den Medien waren?
Gibt es eine andere schnelle und günstige Variante, die Website als App vollfunktional zu verwenden?
Oder muss ich doch die Website einmal in Layouts nachbauen, und separat an die Webservices koppeln?

Ich danke euch schon mal.

Grüße
 
swa00

swa00

Moderator
Teammitglied
@Kapikalaani

herzlich willkommen im Forum.

Eigentlich kann man auf deine Frage keine ausreichende und treffende Antwort geben, denn es können zahlreiche Gründe vorliegen, was denn die Ursache sein kann - auf beiden Seiten.

Grundsätzlich ist der Webview ein Chrome-Abklatsch und es muss auch darauf geachtet werden , dass alle Optionen angepasst
sind und man muss Vieles zu "fuß" machen. (Callbacks / Javascript / Cookies etc.)

Da wir weder deine Webseite kennen, noch das, was du genau auf Client Seite umsetzen möchtest, auch nicht den Source beider Seiten kennen , ist eine Hilfe nicht zielführend.

Schau dir das einmal an, dass dürfte schon weiterhelfen
GitHub - delight-im/Android-AdvancedWebView: Enhanced WebView component for Android that works as intended out of the box
 
Zuletzt bearbeitet:
K

Kapikalaani

Neues Mitglied
Danke für den Link, ich werde mir das mal anschauen, und wenn es mein Problem löst, nochmal Rückmeldung geben.

Grüße
 
K

Kapikalaani

Neues Mitglied
Ich danke dir nochmal für deinen Link.
Dieser hat mir sehr geholfen und fast alle Probleme wurden beseitigt.

Jetzt bleibt nur noch eine Frage:
Die Website nutzt einen Button zur Ermittlung des Standorts.

Dieser funktioniert allerdings über die WebView (auch die AdvancedWebView) nicht.

Es passiert bei betätigung einfach nix, es sollte aber eigentlich das darüberliegende Textfeld mit dem Standort befüllt werden.

Gibt es dafür auch eine schnelle Lösung?

Grüße
 
Ähnliche Themen - Webshop mit WebView funktioniert nicht wie Website Antworten Datum
0