1. Hast Du Lust, bei uns mitzuarbeiten und das AH-Team zu verstärken? Alle Details zu dieser aktuellen Herausforderung findest Du hier.
  1. invictus, 03.06.2012 #1
    invictus

    invictus Threadstarter Android-Hilfe.de Mitglied

    Hallo Leute,
    ich hab folgendes Problem:

    Ich habe bisweilen für mein TabHost unter einem Tab ein WebView genutzt, der leider bei Weiterleitung aber den Browser geöffnet hat.
    Das Problem wollte ich nach Recherche durch den WebViewClient lösen. Leider wird dieser aber nicht im Tab angezeigt, sondern der Tabinhalt bleibt schwarz.

    Hier mein Quelltext von der Activity, die den WebViewClient im Tab anzeigen soll (also nicht die "Hauptactivity"):

    Code:
    public class Tab1Activity extends Activity {
    WebView mWebView;
    
    public void onCreate(Bundle savedInstanceState)
    {
    	super.onCreate(savedInstanceState);
    
    	mWebView = new WebView(this);
    	
    	  mWebView.getSettings().setJavaScriptEnabled(true);
    	  mWebView.loadUrl("http://www.google.de");
    	  mWebView.getSettings().setDefaultZoom(WebSettings.ZoomDensity.FAR);
    	  mWebView.setWebViewClient(new WebViewClient() {
    
    	        @Override
    	        public boolean shouldOverrideUrlLoading(WebView view, String url)
    	        {
    	            view.loadUrl(url);
    	            return true;
    	        }
    	    });
    }
    
    @Override
    public boolean onOptionsItemSelected(MenuItem item) {
        switch (item.getItemId()) {
        	case R.id.refresh:	
        						mWebView.reload();
        							Toast.makeText(this, "Aktualisiert!", Toast.LENGTH_SHORT).show();
    
        						break;
            case R.id.impressum:     Toast.makeText(this, "infos", Toast.LENGTH_LONG).show();
        							break;
    
            
            
        }
        return true;
    }
    
    }
    
    Kann mir jemand sagen, was ich hier falsch gemacht habe?

    LG Invictus
     
    Zuletzt bearbeitet: 03.06.2012
  2. invictus, 03.06.2012 #2
    invictus

    invictus Threadstarter Android-Hilfe.de Mitglied

    Okay, dumme Frage... Hab sie selbst gelöst mit folgendem Befehl:

    setContentView(mWebView);
     
Die Seite wird geladen...
Ähnliche Themen Forum Datum
Der Zurück-Button wird nicht angezeigt Android App Entwicklung 23.01.2017
Google Play: Youtube-Video wird nicht angezeigt Android App Entwicklung 13.12.2016
Android Quiz App bei falscher Frage soll sie angezeigt werden. Android App Entwicklung 23.10.2016
Du betrachtest das Thema "WebViewClient wird nicht angezeigt" im Forum "Android App Entwicklung",