Android auf Laptop

  • 13 Antworten
  • Neuster Beitrag
T

timbu884

Neues Mitglied
Threadstarter
Hallo ich hab versucht Android auf meinem steinalten HP nx6324 zum laufen zu bringen.
Ich habe die ISO runter geladen und mit unetbooting auf einen USB Stick gezogen.
Wenn ich dann versuche es über den USB Stick zu booten, kommt die Nachricht, dass nichts Bootfähiges gefunden wurde.
Hat jemand ne Idee?
 
nik

nik

Senior-Moderator
Teammitglied
Hast du den Stick auch bootfähig gemacht?

Außerdem solltest du noch beachten, ob dein Laptop UEFI oder noch BIOS nutzt.
 
T

timbu884

Neues Mitglied
Threadstarter
Wie lache ich ihn denn Bootfähig?

Ich glaube er hat normales BIOS
 
TimeTurn

TimeTurn

Inventar
Müsste ich glatt auch mal wieder testen, dann kann ich was dazu sagen. Werde ich morgen mal angehen.
 
T

timbu884

Neues Mitglied
Threadstarter
Hey super, ich freue mich auf deine Antwort
 
TimeTurn

TimeTurn

Inventar
Verdammt, habs vergessen. Werd gleich mal Android x86 laden.

Update: So, erste Tests abgeschlossen. Nun, gebootet hattes sowohl von USB (auf der realen Maschine, VirtualBox kann nicht von USB booten) als auch vom ISO in der virtuellen Maschine. Aber nach der Installation hat die VM das System nicht gebootet, obwohl GRUB installiert wurde. Vielleicht hab ich da bei der Partitionierung noch was versemmelt, da das ein sehr rudimentäres Partitionierungstool ist was die Installation da bootet.

Verwendet habe ich die LinageOS 14.1-er Version von Android x86, also Android 7.1.2

Als Live-"CD" bootet es aber problemlos vom Stick:

IMG_20180402_135257.jpg

Erstellt hab ich den Stick nicht mit UnetbootIN sondern Rufus:

2018-04-02 13_11_43-Rufus 2.18.1213 (Portable).jpg

Wenn das nun auch von der Platte booten würde, wäre das schick. Aber auf die reale Maschine lass ich das mal nicht gleich los.

Performant ist das Ganze, obwohl die virtuellen Maschinen bei mir auf dem NAS liegen und das Notebook per 5 GHz WLAN so um die 15 Meter entfernt steht durch 2 Wände hindurch, hat so ca. 235 MBit/s Verbindungsgeschwindigkeit.

2018-04-02 12_41_43-Oracle VM VirtualBox Manager.jpg
2018-04-02 12_47_05-Android x86 [wird ausgeführt] - Oracle VM VirtualBox.jpg 2018-04-02 12_43_47-Android x86 [wird ausgeführt] - Oracle VM VirtualBox.jpg 2018-04-02 13_06_52-.jpg
 
Zuletzt bearbeitet:
Nufan

Nufan

Ehrenmitglied
timbu884 schrieb:
Wie lache ich ihn denn Bootfähig?
Indem du dir das .ISO herunterlädst und mit unetbootin einen bootfähigen Stick erzeugst, deinen Eröffnungsbeitrag hatte ich so verstanden, als hättest du dies genau so getan?
Ich glaube er hat normales BIOS
Hat er... ..ein etwas über zehn Jahre altes..

Mein nc6320 frißt es anstandslos (live), habe unetbootin genommen, gibt es eine Möglichkeit aus dem live-system heraus zu installieren, so hakelt es doch arg..
IMG_20180402_142825.jpg
 
TimeTurn

TimeTurn

Inventar
So, nun bootet es auch von der Platte. Hatte GPT als Laufwerkstyp angegeben, man muss aber einfach nur den klassischen MBR (also GPT = Nein) nehmen:

2018-04-02 13_41_49-Microsoft Store.jpg

Ach ja noch ein Hinweis: Das @ kann man über die echte Tastatur aus welchem Grund auch immer nicht auf gewohntem Weg eingeben. In dem Fall einfach unten rechts auf das Tastatursymbol clicken und die virtuelle Tastatur zusätzlich einblenden.
 
Zuletzt bearbeitet:
T

timbu884

Neues Mitglied
Threadstarter
Vielen Dank für eure Antworten :)
Ja genauso hatte ich es gemacht, die ISO gezogen und Mithilfe von unetbooting auf einen Stick gezogen.
Ich hatte bei dem Stick auch noch Windows 10 drauf, als er dann Windows 10 gebootet hat, habe ich ihn formatiert Android nochmal mit unetbooting auf den Stick gezogen. Leider wieder ohne Erfolg. Kann das Dateisystem einen Einfluss darauf haben?
Ansonsten versuche ich es nochmal mit rufus.
 
TimeTurn

TimeTurn

Inventar
Muss normalerweise FAT32 sein, damit es bootet.
 
T

timbu884

Neues Mitglied
Threadstarter
Hey super das war der fehler, der Stick bootete:)
War nur leider nett der Schritt zum nächsten problem...
Android ließ sich nicht installieren, da das Installationsprogramm die Platte froher mounten, bzw formatieren wollte. Das habe ich bestätigt. Danach kam aber eine Fehlermeldung, dass es die Platte nicht mounten kann und nach mehrmaligen Versuchen hat es gefragt ob es Neustarten soll.
Das habe ich bejaht und dann hat es sich aufgehängt und den Stick zerschossen, so dass ich ihn erst formatieren und dann Android erneut aufspielen musste.
Anschließen habe ich versucht Android erstmal vom Stick zu booten, was aber auch nicht funktionierte. Er fing an zu arbeiten, bis auf dem Bildschirm nur "Android" mit nem blinkenden cursor zu sehen war und nichts weiter passierte.
Hat noch jemand ne Idee?
 
TimeTurn

TimeTurn

Inventar
Da muss ich passen - bei mir startete das normal. Kann am Wochenende mal nochmal mein steinaltes DELL vostro 1000 (Baujahr 2007) darauf loslassen, ob es da auch Probleme gibt.
 
T

timbu884

Neues Mitglied
Threadstarter
Mh das wäre super.

Könnte es vll daran liegen das ich vorher versucht habe xenialpup darauf zu installieren?
Mit xenialpup habe ich vorher eine Partition erstellt
 
TimeTurn

TimeTurn

Inventar
So, mal getestet. Bei meinem DELL vostro 1000 startet es nicht von der SSD (64 GB S-ATA), auch wenn GRUB installiert ist. Vermutlich müsste ich mal die SSD komplett putzen, sodass diese jungfräulich ist. Aber das macht bei dem Teil keinen sinn, da Android darauf nicht stabil läuft - LineageOS macht Probleme, der Starter-Prozess stürzt immer wieder ab. Hab aber sowas erwartet, da es sich um einen Athlon 64 X2 und AMD-Chipsatz handelt - ist wohl nicht besonders kompatibel.
 
Ähnliche Themen - Android auf Laptop Antworten Datum
6
0
11
Oben Unten