[How-To] Android 4.2 Factory Image ohne Datenverlust flashen

  • 177 Antworten
  • Neuester Beitrag
Diskutiere [How-To] Android 4.2 Factory Image ohne Datenverlust flashen im Anleitungen für Galaxy Nexus im Bereich Root / Hacking / Modding für Galaxy Nexus.
J

Jojo-1985

Neues Mitglied
Hallo,
möcht mein GN auch auf das Factory Image bringen.
Meine Built ist: JRO03C.I9250XWLH2 .

Meine Frage ist kann ich mit Win XP auch der Anleitung dieses Threats folgen, oder funktioniert das nicht?

Gruß Johannes
 
ostylk

ostylk

Neues Mitglied
Also ich habe ein Problem......:mad:
Ich wollte auch auf die Stock zurück aber ohne Datenverlust und habe genau die Schritte die hier stehen gemacht.Er hat alles super toll geflasht außer wenn er beim flashen der Stock war......Hatte er eine Fehlermeldung:
archive does not contain 'boot.sig'
archive does not contain 'recovery.sig'
archive does not contain 'system.sig'
So das wäre die Fehlermeldungen und dann habe ich noch festgestellt das der Ordner wo ich die zwei .img Files kopieren soll bei mir kein Ordner sondern ein .zip Archiv ist!:confused2::confused2::confused2:
Eine Sache noch wenn ich die flash-all.bat als Administrator ausführe kann er garnichts flashen dann kommen nur Fehlermeldungen egal ob es der Bootloader ist oder das Radio wenn ich es starte ohne "Als Administrator ausführen"darauf zu klicken flasht er alles bis auf die ROM wie oben beschrieben!:confused2::cursing:Dann hätte ich auch noch ne Frage :D Das .zip Archiv was dort ist kann ich das löschen und dann meine CustomRom dort rein tun und die änderung entsprechend in der flash-all.bat ändern so das wenn er alles flasht er gleich meine CustomRom drauf macht?????

P.S.: Liegt es vieleicht daran weil ich Windoof 8 benutzte???
 
Q

questionesse

Stammgast
Hallöchen,

ich dachte, ich könnte die 4.3er Version auch so updaten.
bekomme aber die selbe fehlermeldung, wie auf S.1 schon angesprochen.
Hat jemand eine Idee?

 
K

knuspertante

Neues Mitglied
questionesse schrieb:
Hallöchen,

ich dachte, ich könnte die 4.3er Version auch so updaten.
bekomme aber die selbe fehlermeldung, wie auf S.1 schon angesprochen.
Hat jemand eine Idee?

Hallo,
ist dein Bootloader entsperrt?
 
Q

questionesse

Stammgast
ja, offenes schloss :smile:
 
androidwissen

androidwissen

Experte
Und hast Stock Android druf?
 
Q

questionesse

Stammgast
Ja, 4.2.2
 
Q

questionesse

Stammgast
wohoo - das wars offensichtlich - mit der yakju läufts schlagartig!
Besten Dank!
 
Happosai

Happosai

Stammgast
Hmm, seltsam. Ich habe gerade Android 4.4 auf meinem Nexus 7 (2012) geflasht. Obwohl ich "-w" entfernt habe, wurde es trotzdem komplett gelöscht. :ohmy:
 
androidwissen

androidwissen

Experte
Kann ich mir nicht erklären.. so ohne weitere Infos.
 
Happosai

Happosai

Stammgast
Das glaube ich dir, ich war auch schon ziemlich überrascht. ;)
 
Happosai

Happosai

Stammgast
Ich glaube, jetzt weiß ich, warum bei mir trotz entfernens des "-w" alles gelöscht worden ist. Man muss im flash-all.bat auch zusätzlich die Zeile "fastboot erase userdata" entfernen.

@Androidwissen: Ich würde diesen Hinweis auch im Eingangsposting dazuschreiben.

By the way: Warum kann ich meinen alten bzw. letzten Einträg nicht bearbeiten? :huh:
 
Zuletzt bearbeitet:
qu4nd

qu4nd

Ehrenmitglied
Happosai schrieb:
By the way: Warum kann ich meinen alten bzw. letzten Einträg nicht bearbeiten? :huh:
Es gibt eine Frist bis zu deren Ablauf man Beiträge standardmäßig bearbeiten kann... Frag mich jetzt bitte nicht nach dem genauen Zeitpunkt ;)
 
androidwissen

androidwissen

Experte
Happosai schrieb:
Ich glaube, jetzt weiß ich, warum bei mir trotz entfernens des "-w" alles gelöscht worden ist. Man muss im flash-all.bat auch zusätzlich die Zeile "fastboot erase userdata" entfernen.

@Androidwissen: Ich würde diesen Hinweis auch im Eingangsposting dazuschreiben.
Nun, wie im Startpost zu sehen, gibt es die Zeile "fastboot erase userdata" nicht

Code:
@ECHO OFF
:: Copyright 2012 The Android Open Source Project
::
:: Licensed under the Apache License, Version 2.0 (the "License");
:: you may not use this file except in compliance with the License.
:: You may obtain a copy of the License at
::
::      http://www.apache.org/licenses/LICENSE-2.0
::
:: Unless required by applicable law or agreed to in writing, software
:: distributed under the License is distributed on an "AS IS" BASIS,
:: WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
:: See the License for the specific language governing permissions and
:: limitations under the License.

PATH=%PATH%;"%SYSTEMROOT%\System32"
fastboot flash bootloader bootloader-maguro-primelc03.img
fastboot reboot-bootloader
ping -n 5 127.0.0.1 >nul
fastboot flash radio radio-maguro-i9250xxlf1.img
fastboot reboot-bootloader
ping -n 5 127.0.0.1 >nul
fastboot update image-yakju-jzo54k.zip

echo Press any key to exit...
pause >nul
exit
 
Andy

Andy

Ehrenmitglied
Ist auch klar, da es das 4.2er Factory Image betrifft und er aber das 4.4er geflasht hat. :)
 
androidwissen

androidwissen

Experte
Na dann schreib ich das mal in den Startpost.
 
L

lynxxx

Fortgeschrittenes Mitglied
Komme vom Slimbean Custom Rom (-> bootloop) und wollte nun, nachdem wipe Cache (im CWM recovery), und anderes nicht klappte, nun ohne Datenverlust, versuchen das Factory Image Stock ROM flashen, nur hatte ich dieselben Fehler, wie hier im Thread teilweise beschrieben wurden, und habe dann per Hand im Command, alles eingegeben, aus der Batch, inkl. dem "-w", wie es in dem ersten Post für Custom ROM User extra heisst (also Punkt 5., das Löschen von "-w" weglassen, als Custom ROM User: "5. entferne dort die zwei Zeichen "-w" (dadurch wird kein Full-Wipe gemacht) und speichere die Datei ab") . Soweit hat es alles geklappt, doch nun hänge ich Punkt flashing system, schon fast ne halbe Stunde dran.
Wie lange dauert das denn? Oder löscht er nun doch meinen gesamten Speicher, inkl. 8 GB Musik, Filme, Fotos, usw.?
Bitte um Tipps oder Erfahrungswerte... :(

EDIT: Oh, jetzt ist er nach einer halben Stunde oder so doch noch weiter gegangen. Dabei habe ich diesen Punkt gesehen:
Code:
Creating filesystem with parameters
    Size: 14539534336
    Block size: 4096
    Blocks per group: 32768
    Inodes per group: 8144
    Inode size: 256
    Journal blocks: 32768
    Label:
    Blocks: 3549691
    Block groups: 109
    Reserved block group size: 871
Scheint so, als würde doch der gesamte Speicher gelöscht werden? Könntet ihr das bitte im ersten Post nochmals präzisieren? Das nämlich "-w" bei denjenigen, die von einem Custom ROM kommen, eben NICHT das Ergebnis liefert, welches der Threadtitel suggeriert? ("... ohne Datenverlust flashen")

Der ursprüngliche Beitrag von 21:50 Uhr wurde um 22:08 Uhr ergänzt:



Der ursprüngliche Beitrag von 22:08 Uhr wurde um 22:12 Uhr ergänzt:

Oh, Mist, trotz erfolgreichen Flashens, so zumindest die Meldungen im Command Fenster, habe ich immer noch das Slimbean ROM, welches kurz nach dem vollständigen Bootens, wieder gleich einen Reboot macht... :( Irgendwelche Ideen? Hardware-Defekt?
 
Zuletzt bearbeitet: